Sign up here and you can log into the forum!

2.02.32-EXT3_Palace_Plus-0.1.4 * updated 10/3/14

General WDLXTV-Gen3 forum

Re: 2.02.32-EXT3_Palace_Plus-0.1.4 * updated 10/3/14   

Postby kdavid » Tue Oct 21, 2014 9:31 pm

Good morning guys,

Has anyone managed to run a "wdtv usb app"? (I mean by creating a folder named "apps" into the root of a connected usb drive and putting inside the app as wdtvsdk says)

Last night I tried but the OSD keeps saying that "no app found".

Is there any chance that 2.02.32-EXT3_Palace_Plus is blocking this feature in any way?

Thanks!
kdavid
n00b
 
Posts: 8
Joined: Sun Oct 19, 2014 6:16 am

Re: 2.02.32-EXT3_Palace_Plus-0.1.4 * updated 10/3/14   

Postby KAD » Tue Oct 21, 2014 10:38 pm

kdavid wrote:Good morning guys,

Has anyone managed to run a "wdtv usb app"? (I mean by creating a folder named "apps" into the root of a connected usb drive and putting inside the app as wdtvsdk says)

Last night I tried but the OSD keeps saying that "no app found".

Is there any chance that 2.02.32-EXT3_Palace_Plus is blocking this feature in any way?

Thanks!


I don't see how it would be blocked at all, it should work, but on the other hand, nobody has put any any apps to test with
if I had one to test I would confirm that it works
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

Re: 2.02.32-EXT3_Palace_Plus-0.1.4 * updated 10/3/14   

Postby kdavid » Wed Oct 22, 2014 12:55 am

KAD wrote:
kdavid wrote:Good morning guys,

Has anyone managed to run a "wdtv usb app"? (I mean by creating a folder named "apps" into the root of a connected usb drive and putting inside the app as wdtvsdk says)

Last night I tried but the OSD keeps saying that "no app found".

Is there any chance that 2.02.32-EXT3_Palace_Plus is blocking this feature in any way?

Thanks!


I don't see how it would be blocked at all, it should work, but on the other hand, nobody has put any any apps to test with
if I had one to test I would confirm that it works


Thanks KAD. You can find an app to test on the 2.02.32-EXT3_Palace_Plus-0.1.4 itself! You can ftp and download one ready built-in app from the apps folder (on root). Then you can copy the same app on your USB root folder under apps new folder. And then you test it from "Apps on USB" from the Services menu of WDTV.

So to summarize (and thanks for your help):

1) FTP into WDTV
2) Go to apps folder and download the whole folder of a built-in app on your PC. (e.g. ABC-news if I remember right). Change folder name (on your PC) to something else (e.g. testapp)
3) Create a folder on your connected USB drive named "apps" (without quotes)
4) Upload the folder "testapp" into "apps" folder you created on step 3
5) Navigate to Services menu of your WDTV OSD and find "USB apps" (it may prompt you to choose Source, choose USB)

At this point a message "no apps found" is generated even though a non-problematic app is inside destination folder...
kdavid
n00b
 
Posts: 8
Joined: Sun Oct 19, 2014 6:16 am

Re: 2.02.32-EXT3_Palace_Plus-0.1.4 * updated 10/3/14   

Postby KAD » Wed Oct 22, 2014 7:06 am

kdavid wrote:
KAD wrote:
kdavid wrote:Good morning guys,

Has anyone managed to run a "wdtv usb app"? (I mean by creating a folder named "apps" into the root of a connected usb drive and putting inside the app as wdtvsdk says)

Last night I tried but the OSD keeps saying that "no app found".

Is there any chance that 2.02.32-EXT3_Palace_Plus is blocking this feature in any way?

Thanks!


I don't see how it would be blocked at all, it should work, but on the other hand, nobody has put any any apps to test with
if I had one to test I would confirm that it works


Thanks KAD. You can find an app to test on the 2.02.32-EXT3_Palace_Plus-0.1.4 itself! You can ftp and download one ready built-in app from the apps folder (on root). Then you can copy the same app on your USB root folder under apps new folder. And then you test it from "Apps on USB" from the Services menu of WDTV.

So to summarize (and thanks for your help):

1) FTP into WDTV
2) Go to apps folder and download the whole folder of a built-in app on your PC. (e.g. ABC-news if I remember right). Change folder name (on your PC) to something else (e.g. testapp)
3) Create a folder on your connected USB drive named "apps" (without quotes)
4) Upload the folder "testapp" into "apps" folder you created on step 3
5) Navigate to Services menu of your WDTV OSD and find "USB apps" (it may prompt you to choose Source, choose USB)

At this point a message "no apps found" is generated even though a non-problematic app is inside destination folder...


good idea for testing a known working app, I'll check it out, see if I can figure out what's going on
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

Re: 2.02.32-EXT3_Palace_Plus-0.1.4 * updated 10/3/14   

Postby kg2000 » Wed Oct 22, 2014 12:13 pm

Hello,
I have just switched from my old, good WD Live Gen2 to Gen3 and of coz installed Palace _Plus. There was no problem with firmware, sshd, ftpd etc running great.
However I can't figure how to display moviesheets on new box. I used to copy movie file and sheet file (x.mkv_sheet.jpg) on old box and nice fullscreen sheet was shown during browsing files. Is it possible on Palace_Plus too ? I only manage to display small thumbnails but despite setting LINKSHEETS, MSHEETSMODE=sheet and LISTMSHEET I don't see any sheets. I also installed custom themes like Titan, AlaskaRemix and Black Mamba but while themes are working, the sheets are still not displayed.

Could anyone help me with issue ?
TIA
kg2000
n00b
 
Posts: 3
Joined: Tue May 25, 2010 10:15 pm

Re: 2.02.32-EXT3_Palace_Plus-0.1.4 * updated 10/3/14   

Postby KAD » Wed Oct 22, 2014 12:27 pm

kg2000 wrote:Hello,
I have just switched from my old, good WD Live Gen2 to Gen3 and of coz installed Palace _Plus. There was no problem with firmware, sshd, ftpd etc running great.
However I can't figure how to display moviesheets on new box. I used to copy movie file and sheet file (x.mkv_sheet.jpg) on old box and nice fullscreen sheet was shown during browsing files. Is it possible on Palace_Plus too ? I only manage to display small thumbnails but despite setting LINKSHEETS, MSHEETSMODE=sheet and LISTMSHEET I don't see any sheets. I also installed custom themes like Titan, AlaskaRemix and Black Mamba but while themes are working, the sheets are still not displayed.

Could anyone help me with issue ?
TIA


sure, it's possible

but things don't work exactly the same way

first issue, is that theme's are actually supported by official firmware, and so many themes do not support linksheets
but some do

generally if you read through the theme info, it will say if it supports LinkSheets or not
but a good test theme would be "Goodbye Black Mamba" because I know it supports linksheets

so next step since your running this firmware is to copy the theme them to your thumbdrive
The folder must be named .Goodbye Black Mamba.theme.linksheets - naming format is .<theme name here>.theme.linksheets

and yes linksheets and sheet mode, etc .. must be enabled in the webend

once all that is done reboot, and you should have working linksheets
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

Re: 2.02.32-EXT3_Palace_Plus-0.1.4 * updated 10/3/14   

Postby kdavid » Wed Oct 22, 2014 1:41 pm

KAD wrote:good idea for testing a known working app, I'll check it out, see if I can figure out what's going on


I finally made it work. I found out that the built-in apps on WDTV are not compatible with USB apps!

I created a sample app that shows the Transmission torrent web ui (if the torrent webui is run on default port 9091). It's just an example. Do not expect the remote control keys to work (except for the Home key). You can just watch the download progress of your torrents. I will try to make this better when I find some time.

This is the link: http://zettahost.tv/umowegik3b45.html

Decompress the containing files into your USB drive and reboot WDTV. Then go to "Apps on USB" on Services menu and run the Torrent app.

Everyone is welcome to optimize this first ever published wdtv USB app.
kdavid
n00b
 
Posts: 8
Joined: Sun Oct 19, 2014 6:16 am

Re: 2.02.32-EXT3_Palace_Plus-0.1.4 * updated 10/3/14   

Postby KAD » Wed Oct 22, 2014 1:45 pm

that's a great idea for app on usb

glad it's working, and looking forward to any future improvements or other apps
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

Re: 2.02.32-EXT3_Palace_Plus-0.1.4 * updated 10/3/14   

Postby JoeySmyth » Wed Oct 22, 2014 3:39 pm

kg2000 wrote:Hello,
I also installed custom themes like Titan, AlaskaRemix and Black Mamba but while themes are working, the sheets are still not displayed.
Could anyone help me with issue ?
TIA


Titan and my AlaskaRemix theme(s) do not contain the xml code to display Linksheets .... but, it's pretty simple to make a few edits to enable them

For Gallery View: <image image="@@browse_text" x="0" y="0" w="1280"h="720" scale="100" bg="1"/>

For All Other Views: <image image="@@focused_title" x="0" y="0" w="1280" h="720" scale="100" bg="1"/>
User avatar
JoeySmyth
DLX'er
 
Posts: 67
Joined: Sat Sep 27, 2014 3:37 pm
Location: Down Under

Re: 2.02.32-EXT3_Palace_Plus-0.1.4 * updated 10/3/14   

Postby Ajax171 » Wed Oct 22, 2014 11:39 pm

Hi i'm trying to get to work xmount and unionfs on WDTV Live SMP. I go t the latest palace firmware, but i cant get it ot work. The xmount with nfs work with no problem but unionfs not working at all. The xmount creates folders on usb stick (.movies1, .movies2...) with files in it, but also creates folder HD_Movies but its empty. When i access share from SMP i see only first four folders (Movies_HDD1, Movies_HDD2...). I dont know what is the problem on old WDTV Live it was working with no problems. I post here a script that im using for nfs. Maybe i'm doing it wrong, SMP has support of nfs sharing itself, maybe it loads nfs sharing directly without xmount.

xmount "192.168.2.110:/volume1/Movies_HDD1" ".movie1" nfs "vers=3,proto=tcp,rsize=32768,wsize=32768"
xmount "192.168.2.110:/volume2/Movies_HDD2" ".movie2" nfs "vers=3,proto=tcp,rsize=32768,wsize=32768"
xmount "192.168.2.110:/volume3/Movies_HDD3" ".movie3" nfs "vers=3,proto=tcp,rsize=32768,wsize=32768"
xmount "192.168.2.110:/volume4/Movies_HDD4" ".movie4" nfs "vers=3,proto=tcp,rsize=32768,wsize=32768"
xmount ".movie1:.movie2:.movie3:.movie4" "HD_Movies" unionfs
Ajax171
n00b
 
Posts: 2
Joined: Tue May 18, 2010 8:46 am

PreviousNext

Return to Discussion

Who is online

Users browsing this forum: No registered users and 1 guest