Sign up here and you can log into the forum!

Gen3 boot problem

General WDLXTV-Gen3 forum

Re: Gen3 boot problem   

Postby KAD » Mon Feb 23, 2015 8:56 am

well that's some really good news

so now you'll want to update the official firmware

once you're on official 2.02.32
and it's all stable

you should be able to run this http://forum.wdlxtv.com/viewtopic.php?f=23&t=9048
without any issues
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

Re: Gen3 boot problem   

Postby warrior6 » Mon Feb 23, 2015 8:58 am

Just a quick question.
I read that official 2.02.32 have issues playing mp4 files.
What if I want to update with the previous official firmware, 2.01.86?
How can I do that?
With an usb drive?
warrior6
DLX'er
 
Posts: 51
Joined: Tue Feb 17, 2015 10:20 pm

Re: Gen3 boot problem   

Postby KAD » Mon Feb 23, 2015 9:01 am

yeah, you just have to download the firmware from WD's site and put it on a USB drive

edit: WD's older firmwares can be a bit difficult to find on there website
here it is http://download.wdc.com/wdtv/wdtvlivegen3_rollback_2.01.86.zip

also if mp4's are an issue, then you should not run WDLXTV firmware
because it will have the same issues as official version 2.02.32
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

Re: Gen3 boot problem   

Postby warrior6 » Mon Feb 23, 2015 9:19 am

Thanks.
I noticed that the .zip you provided me has four files in it:
.bin
.bin2
.ver
.fff
On the WD site the instructions talk about a fifth file, the .info one.
Is it necessary?
warrior6
DLX'er
 
Posts: 51
Joined: Tue Feb 17, 2015 10:20 pm

Re: Gen3 boot problem   

Postby KAD » Mon Feb 23, 2015 9:28 am

I'm not 100% sure

but you'll notice that's an official wd download link, so it should be fine
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

Re: Gen3 boot problem   

Postby warrior6 » Mon Feb 23, 2015 9:47 am

Updates flawlessly :D
I can confirm that the .info file isn't required, it contains the info about the firmware release and nothing more.

Thank you so much, KAD, you really helped me cleaning the mess I made.
I'm grateful for all the time spent and patience you had dealing with me :D
warrior6
DLX'er
 
Posts: 51
Joined: Tue Feb 17, 2015 10:20 pm

Re: Gen3 boot problem   

Postby JoeySmyth » Mon Feb 23, 2015 2:17 pm

happy to hear, you got it sorted warrior6
User avatar
JoeySmyth
DLX'er
 
Posts: 67
Joined: Sat Sep 27, 2014 3:37 pm
Location: Down Under

Re: Gen3 boot problem   

Postby warrior6 » Tue Feb 24, 2015 3:10 am

Thanks, joey.
Everything works perfectly, now.
warrior6
DLX'er
 
Posts: 51
Joined: Tue Feb 17, 2015 10:20 pm

Re: Gen3 boot problem   

Postby fuzzballerz » Sun May 24, 2015 12:07 am

KAD wrote:you know before we go with this file

let's revisit something, looking through your posted output, I found something early where you had a 1 instead of lower case L

so let's retry that first

Code: Select all
setxenv 0 l.alpha.fw_sign okok
export FW_SIGN="okok"
rm -rf /usrdata/.wd_tv/theme/*
rm -rf /conf/*
config_tool -s
config_tool -s
reboot


if that doesn't get you back to booting stock, let me know, and I'll upload that file


I just wanted to say thanks to KAD & warrior6 for this.
I too had encountered the same issue and after going through this thread, I was able to fix my boot looping WDTV gen3. I had never updated my device so I was pretty much running the stock FW (1.05.18) and wanted to jump right in to homebrew 2.02.32 without updating to the official 2.02.32 which led me to this thread. :mrgreen:

KAD just curious what does the "fwup, okok, sisi, and one more" for l.alpha.fw_sign mean?
the fw_sign_set.sh did not have much info on that. I'm assuming fwup means boot usb? :?
fuzzballerz
n00b
 
Posts: 2
Joined: Sat May 23, 2015 11:52 pm

Re: Gen3 boot problem   

Postby KAD » Sun May 24, 2015 2:42 pm

well there are 3 valid values

1. sisi - used for booting WDLXTV
2. okok - used for standard boot procedure
3. fwup - used to initiate flashing of new firmware

fw_sign_set.sh is a small shell script for writing the values to nand (permenant memory)
fw_sign_get.sh is a small shell script for reading the values from nand (permenant memory)

the problem with fw_sign_get.sh is that it uses a catch all which will output fwup, this is a false positive, something failed, so it says fwup
even though the value really is not fwup

after calling fw_sign_set.sh or fw_sign_get.sh there's about 2 or 3 more levels of scripts that call each other before some binary files get executed with translates the value to a hexadecimal
and then actually write the hex values to nand

at boot time the nand is read, and has various items, from very basic like cpu and ram frequency, regional settings, US or EU, etc ...
the value l.alpha.fw_sign with it's corresponding hex value is used to determine which boot procedure is run
1. sisi - used for booting WDLXTV
2. okok - used for standard boot procedure
3. fwup - used to initiate flashing of new firmware

where you run into issues with old firmwares is that
1. the newer scripts and binaries did not all exist yet
2. the old and new binaries are not compatible with each other

just for example here's how the entry actually looks in nand for value sis
Code: Select all
(0x00) 4 l.alpha.fw_sign 73.69.73.69. 0x69736973
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

PreviousNext

Return to Discussion

Who is online

Users browsing this forum: No registered users and 1 guest