Page 1 of 61

2.02.32-EXT3_Palace_Plus-0.1.4 * updated 10/3/14

PostPosted: Thu Dec 19, 2013 6:56 pm
by KAD

version 0.1.4
has some significant changes
1. has been updated - Please don't use old homebrew files, use the new ones. this permanently fixes version string issues
2. there is now limited support for the new WDTV Media Player. I do not own this device and must rely on feedback from beta testers - discussion can be found at
3. the most significant changes you'll find have to do with how themes are handled

User Themes
You now have several choices, and they all can be located on any attached drive

.theme is used to force the osd to load .theme at boot time, you will also find it is now a selectable option under settings - appearance - themes, it will be titled "forced"
note only first instance of .theme will be loaded

.<myosd name here>.theme is a new option
you can have as many of these as you want and all of them will be selectable from the settings menu
so if the theme is titled ".PM4.theme" it will show up in settings as "PM4" and be selectable

.<myosd name here.theme.linksheets is a new option
you can have as many of these as you want and all of them will be selectable from the settings menu
note that all themes ending with .linksheets will share the same moviesheets
the difference here is that will be used to automagically link all your moviesheets
so for those of you that have been manually renaming and moving moviesheets, etc ...
with this option that is no longer necessary
this option will also require several settings to be enabled via WEC
MSHEETMODE=sheet (actually mode does not matter, just required to select one of them)
1 of the following must also be selected, doesn't matter which one or all of them

Image Image
Image Image

app.bin's can be downloaded from WAM
and function per normal except there's no support for loading kernel modules via app.bins
I don't plan to add support for kernel modules, although I have verified it's possible to load modules
since any app.bins requiring kernel modules will need to be recompiled for the new kernel, I recommend to load your modules via insmod

WAM will only display and download app.bin listed on svn
containg <model>SMP</model>
min & max firmware checking has been temporarily disabled

for starters known working app.bin's on SMP

NOTE: for problems with individual app.bins, please post to the authors thread, likely found here

Nzbgetweb has been added
-- untested, I have no account to test with, so I'll have to rely on your reports
-- the daemon however does start correctly

MiniDLNA has been added
-- version is from svn which RMerlin had put together, and is now included here

Videoscreensaver overhaul, takes advantange of new upnp-cmd option which allows the added features without requiring WDTVext
-- does not run while netflix is active
-- add support for files with spaces in name
-- add multivideo support
-- add random screensaver option

Regarding Transsmissionbt,
--- just a note, tranmission does have a management page on the webend, however I recommend accessing management via <yourWDsIPaddress>:9091 as it's much more responsive that way

Regarding UMSP Media Server
is alive and functional, download and manage plugins via WAM & WEC
NOTE: for problems with individual UMSP plugins please post to the plugin authors thread, likely found here

Regarding xmount
is now very stable, and fully function with the exception of the 2 files systems listed below, those require kernel modules
xfs, reiserfs, unionfs should be working - starting with v 0.1.2
known non-working filesystems: aufs

regarding busybox
updated to version 1.22.1
this should allow you a stable predictable option if you need to do any scripting
you can still access the old version if needed
example: busybox.old [applet] [args] [options]
Code: Select all
busybox.old ls -al

would use the old busybox version of ls

2.02.32-EXT3_Palace_Plus-0.1.4 (450MB)
this contains a modified version of b-rad's WDLXTV-Palace-homebrew-kit
& an ext3 version of official firmware 2.02.32 Plus some changes I made

of coarse much thanks to b-rad for the kit, it's his work that made this possible

Telnet : Default root : <blank>
FTP : same as telnet
SSH : Must set passwd via telnet
dmaosd.log : Must set DMAOSD_DEBUG to 1 or 2
User scripts : /etc/ini.d/SxxScript (note: Capital S followed by 2 numbers)
User Theme: The folder ".theme" or .myosd.theme or .myosd.theme.linksheets can be placed on usb drive
Reset: Both files must be located on same drive as wdlxtv-palace.bin
**Create file reset-pwd to reset telnet/ftp passwords
**Create file reset-all to completely remove all stored settings
Updated Version of Busybox
Added bandwidth_test script
EXT3=Writable filesystem (change whatever you want)
UMSP Media Server
TransmissionBt (torrent client)
app.bin support

umsp not showing up - fixed in version 0.1.3
Boot Screen Popup - it tries to download firmware - fails, dumps you to main screen - this might not be completely fixed
Unable to Login to FTP - fixed in version 0.0.5
lots of Webend Problems - fixed in version 0.0.7
xmount does not always work after reboot - fixed in version 0.0.8
Official WD android remote does not work while WDLXTV webend is active (if you want to use this app you must set WEBEND_TYPE=WD) - fixed in version 0.1.2
RSS reader does not work - fixed in version 0.1.2
Version string is very slow to update (1 min + sometimes) - fixed in version 0.1.0
Mode mismatch (if running official firmware in homebrew mode, some keys on remote don't function correctly, but only on some screens) - to fix 1. run wdlxtv firmware or 2. use stockify cmd to put device is normal operating mode
VideoScreensaver crashes Netflix (upnp-cmd issue) - fixed in version 0.0.9
overlaid text at boot - fixed in homebrew v4

Change your passwd immediately
Visit the webend to set an IP address for the wd-webend
Don't Change system files, unless you know what you're doing - I'm not responsible for what you do to your device

Boot Tips
* Thumbdrive Format
--- Fat32 is best booting off thumbdrive
--- EXT3 works providing that a+x permissions are set on boot files
--- NTFS will probably never work for booting, permisssions issue, default fmask prevents scripts from being executable
* Official Firmware/Kernel
--- both 2.01.86 & 2.02.32 official firmwares use the same kernel
--- you must have one of these flashed to the device first in order to use this custom firmware

Install Instructions
1. Download package above
2. Unzip
3. Edit device-ip.txt (included in download)
4. run win-homebrew-upload.bat
5. run win-homebrew-brewme.bat
6. run win-homebrew-status.bat
7. place wdlxtv-palace.bin on thumbdrive
8. place homebrew files on same thumbdrive (wdlxtv-palace.bin,, wdtvlivegen3.bin.mpm, wdtvlivegen3.bin.mpm.sha1.sum)
9. plug thumbdrive into SMP
10. Reboot SMP
11. Confirm settings - system - about shows the firmware version as "2.01.86-EXT3_Palace_Plus-0.0.8"
12. Thumbdrive must stay plugged in, as firmware is running live on the thumbdrive

Version History
v 0.1.4
* add firmware package for new WDTV Media Player code name Liverpool
* fix perl interpreter
* add
* update WEC with linksheets options
* add and update
* update S10theme, support for .theme , .myosdmod.theme, .myosdmod.theme.linksheets
* .theme or other themes can be located on any attached drive and show up under appearances (".theme" will be titled "forced")
* remove WD's version of transmissionbt, symlinks in place point to version I previously compiled
* fix videoscreensaver single video mode
* update homebrew files
* finally a good fix for version string
* update WEC config options
* update S91webend, do not allow same IP address for both webends
* update WD-Webend Plugin, do not allow same IP address for both webends
v 0.1.3
* fix for umsp not displayed on screen
* add telnet applet on webend
* add nfsd.ko
* replace busybox links for full version of depmod modprobe lsmod
* add rpcinfo
* add online.delayer script only
* add exportfs and
* binaries added groupadd useradd
* move busybox start script to primary init file
* add
* fix symlink to
* add nzbgetweb plugin
* update start scripts to call /tmp/init.d , run scripts found in /conf & usb drives
* early mount all attached drives
* mount app.bins prior to running any start scripts
v 0.1.2
* completely rebuilt from scratch using official 2.02.32 base
* rewrote password management
* fix dbus errors kernel log
* fix non-functional RSS reader
* fix Sudo unable to resolve host error
* fix compatibilty with WD official android remote
* update app.bin scripts for compatibility with official apps
* update minidnla & ffmpeg libs
* update apache config, now both WDLXTV and WD webend's can run at the same time
* add wd-webend links to WDLXTV webend
* add WDLXTV Logo to wd-webend
* update WEC options
* add unionfs
* fix pam.d errors in messages.txt
v 0.1.1
* fix symlink /etc/ - > /tmp/
* fix symlink /etc/ - > /tmp/
* replace busybox link to ps with full version of ps
* add /usr/lib/
v 0.1.0
* update RV-BG.jpg to include WDLXTV logo
* add mkcramfs2 (thanks to recliq)
* update app-plugman-web (thanks to recliq)
v 0.1.0Beta2
* disable entware
* fix webend Icon integration (index.html or index.php) is functional
v 0.1.0-Beta
* add UMSP_LAN - broadcast UMSP content to your LAN
* add UMSP_LAN config on webend
* add symlink /usr/bin/bash - > /bin/bash for compatibility with legacy scripts
* add symlink /etc/ - > /tmp/
* add symlink /etc/ - > /tmp/
* add sys.path for app.bins modify $PATH, scripts should source /tmp/sys.path
* add app-plugman-web
* add post-init script to load app.bins
* add UMSP to daemons list on webend
* fix videoscreensaver start script to actually allow enable/disable log file
* Update Homebrew theme to v4, fixes overlaid text on boot
* move videoscreensaver.log to thumbdrive
* add swap support : file must be located on same drive as firmware and named ".swapfile" - use webend to enable/disable
* symlink /etc/fstab -> /tmp/fstab , make sure fstab doesn't have stale entries before enable swap
* add swap config entries on webend
* fix webend version string
* fix dynamic version string update on about page of OSD
* add app.bin download and management via WAM
* replace busybox link for syslogd with full version of syslogd
* add /etc/syslog.conf
* disable klogd (this will make messages.txt very small, you will only see items specifically logged by start scripts , no more kernel messages)
* dev option (config_tool -c KLOGD=ON) this option will not be added to webend, if enabled klogd will be started for kernel messages
* replace broken ldconfig with working ldconfig from debian-squeeze.img
* fix tons of symlinked libraries that ldconfig complained about
* fix broken mediainfo (ldconfig related as well)
* confirmed app.bin integration with webend works (wec.php & add daemon per normal)
* fix webend app.bin integration with app Icons
* add libraries
* only display app.bin that are SMP compatible
* do not filter app.bins based on required firmware
v 0.0.9
* add MiniDLNA
* add libogg and libvorbis (required for MiniDLNA)
* disabled videoscreensaver when netflix is active
* add log configuration to videoscreensaver
* fix videoscreensaver play mode NORMAL or REPEAT_ONE
* prevent videoscreensaver premature start
* add upnp-cmd SetNextAVTransportURI
* add MULTI_VIDEO support to videoscreensaver
* add support for files with spaces in name to videoscreensaver
* add random file selection for videoscreensaver
* fix broken symlink libldap
v 0.0.8-1
* WDLXTV webend is default
v 0.0.8
* new helper script remove_mount - removes dead/empty folders used by xmount
* add curlftpfs , dvdfs, sshfs, unlink, screen & required libraries
* update existing curl binary to version 7.33
* update bash to version 4.3.8(1)
* replace busybox link to lsof with full version (fixes upnp-cmd)
* add symlinks php-cgi & php5-cgi both point to /webserver/bin/php
* disable S99webend init (it did nothing useful)
* update init scripts for daemon status start,stop, etc
* add device status back into webend
* fix webend daemons (add load.webplugin, remove.webplugin, load.web_managed_daemons)
* remove the word "stock" from firmware name - this package no longer resembles the stock firmware
* add videoscreensaver
* update upnp-meta to include all video,audio,image file codecs (if codec not found exit)
* filter OSD garbage out of dmaosd.log
* add transmissionbt (torrent client)
* update umsp-plugman-web (fix for "fs")
v 0.0.7
* Homebrew Kit updated to version 3
--- functions under both official and custom firmware
--- add function to start telnet under stock firmware
* add Homebrew mode changer to WDLXTV webend
* replace busybox links with full versions of find & wget
* add cramfsck mkcramfs partprobe strace tcpdump ffmpeg msdl mediainfo rtmpdump and required libraties
* update & - required for ffmpeg
* UMSP is working :)
* Too Many Webend change to list all of them
--- Anything that does not apply to SMP has been removed
--- Anything that was broken has been removed
--- Quite a few broken items have been fixed
--- At this point what is still on the webend is to my knowledge 100% functional
--- Additional items may be added back into webend at a later date
v 0.0.6
* add nano & required libraries
* add ldd & required libraries
* enable syslogd and klogd with output to /tmp/messages.txt
* enable configuration via S00custom-options script
* add php binary to system path
* add perl & required libraries
* add file & required libraries
* add sudo and required libraries
* replace webend - Official webend can still be enabled WEBEND_TYPE=WD
* add dropbear ssh server and required libraries
* add xmount
v 0.0.5
* add /root folder to fix ftp login issue
* add reset script
* update busybox
* read DMAOSD_DEBUG setting to enable/disable dmaosd.log
v 0.0.4
* change user scripts from lower case s to capital S
* add S10theme script to set theme path ".theme" on thumbdrive
v 0.0.3
* fix boot screen popup
v 0.0.2
* Secured telnet with login prompt
* add FTP
* add support for user scripts at /etc/init.d/sxx
* assign firmware name
v 0.0.1
* I'm alive - it boots + unsecurred telnet

feedback welcome :D

Re: 2.01.86-EXT3_Palace_Stock_Plus-0.0.2 * updated 1/12/14

PostPosted: Sun Jan 12, 2014 11:01 am
by KAD
updated :)

Re: 2.01.86-EXT3_Palace_Stock_Plus-0.0.3 * updated 1/12/14

PostPosted: Mon Jan 13, 2014 1:51 am
by recliq
KAD wrote:User scripts : /etc/ini.d/sxxScript (note: lower case s followed by 2 numbers)

Well done KAD!
But why did you change the schema for init scripts? Tradidionally (not just on WDLXTV) it's been a capital "S"...

Re: 2.01.86-EXT3_Palace_Stock_Plus-0.0.3 * updated 1/12/14

PostPosted: Mon Jan 13, 2014 4:19 am
by KAD
Official firmware start scripts use Sxx with capital
I dont want those to run twice

theres probably quite a bit ive done that would not be the normal correct way, but it works
I certainly welcome anybody to chip in and fix/add/improve

Lowercase s ...
This might be changable later, it appears brad converted official start scripts from S to s then elected to have WDLXTV scripts start with S

Also my implementation is less robust
No searching conf or other directories
No dos2unix - does not exist in official firmware

probably next step will be to transplant missing items (dos2unix,nano,etc)
from WDLXTV palace to this, well assuming that works

Re: 2.01.86-EXT3_Palace_Stock_Plus-0.0.4 * updated 1/13/14

PostPosted: Wed Jan 15, 2014 9:12 am
by engineer14

Thanks KAD for your work, great to see someone working on the SMP.

I just switched to the SMP quite recently, had the old Live before, with wdlxtv, using linksheets.

After reading the forums for quite some time, I understand Linksheets work with the SMP as well, but with the 30MB Limitation, which would make it rather useless for me.

So, if I get it right, this limitation can be avoided using b-rads FW. I think I understand most part of how to do it, but the last steps are missing (and, I am no Linux guy, sorry ;).

So, as I see it, I should create an (empty?) Folder named ".theme" on the root of the USB Device (same place as wdlxtv-palace.bin). So the Palace knows where to look for the theme.
What I miss is, how I get the actual theme there. Do I still upload it using a web browser (the "normal" way), or do I manually put it on the usb device - and if so, do I put it into the ".theme" folder or just into the main folder.
And, last question, do I still have to make a .zip - File or can the File just be copied over there.

And, the sheets must be put in the same folder as the theme, right?

Sorry to bother you with these probably "banal" questions ... thx again!

Re: 2.01.86-EXT3_Palace_Stock_Plus-0.0.4 * updated 1/13/14

PostPosted: Wed Jan 15, 2014 9:35 am
by KAD
yep linksheets work, well sort of

does not use an actual script for linksheets like the old WD Live or Live Plus does
so instead we'll manually place sheets inside the theme and manually rename the sheets as needed

so to use create .theme
and manually (no upload) put all the theme data inside that folder (not zip'ed)
Basically, think of it this way
unzip the theme you want to use
then change the main folder name from TitanLive etc to .theme
and it will work

for linksheets the sheets must be renamed like this
Batman.m2ts_sheet.jpg becomes Batman.m2ts
the folder sheet Batman_sheet.jpg becomes Batman (no extension)
then the sheets with modified names get dumped inside the .theme folder

this is very similiar to the old MSHEETDIR method, so if you're at all familiar with that, you'll recognize the naming scheme

Re: 2.01.86-EXT3_Palace_Stock_Plus-0.0.4 * updated 1/13/14

PostPosted: Wed Jan 15, 2014 9:41 am
by engineer14
thank you for the quick reply.

Yep, the naming schema is the same I used with the old box (MSHEETDIR), so I am familiar with that.

So, the Theme is loaded when the Palacemakes a restart from Poweroff, right?

So, if I want to add new sheets, I will have to make a restart again, I guess?

I will give that a try tomorrow. Thanks again.

Re: 2.01.86-EXT3_Palace_Stock_Plus-0.0.4 * updated 1/13/14

PostPosted: Wed Jan 15, 2014 9:57 am
by KAD
actually just the theme path is set at boot

so if you're just adding new sheets, no need to reboot again

Re: 2.01.86-EXT3_Palace_Stock_Plus-0.0.4 * updated 1/13/14

PostPosted: Thu Jan 16, 2014 2:07 am
by engineer14
so, tried it, and, basically it worked flawlessly.

One thing: After switching the devixe off via remote (soft power), I didn´t get a picture when switching on again. The LED´s were on, but no picture, I had to disconnect it from power. Tried that several times, always the same.

Thanks again, greetings

oh, another thing - I wasn´t able to get it to work with an USB Harddrive, only a stick worked ...

Re: 2.01.86-EXT3_Palace_Stock_Plus-0.0.4 * updated 1/13/14

PostPosted: Thu Jan 16, 2014 8:50 am
by KAD
not sure what's causing the power off/on no image issue

my only thoughts are hdmi handshake issues

as for booting, the SMP is definetely more selective about what it will boot from compared to prior gen live or live plus
I'm only able to boot from thumbdrive formated fat32
other formats I've tried ext3, ntfs, vfat (vfat was inconsistant - it would boot sometimes)

tried it, and, basically it worked flawlessly.

nice to know that in general, it just works