Sign up here and you can log into the forum!

1.05.04_B.WDLXTV_Plus_0.5.1.1 - NTP not updating (downgrade)

1.05.04_B.WDLXTV_Plus_0.5.1.1 - NTP not updating (downgrade)   

Postby winger88 » Tue Feb 18, 2014 9:27 am

I was using the latest WDLXTV and decided to downgrade back to stock wd just so I could use my phone as a remote.
After doing this netflix stopped working because the system time was not updating resulting in a ssl handshake failure. I retried the downgrade clearing the /conf directory and that didnt work either Time/date still was not updating (and had I not backed up my /conf folder I would have been in bigger doodoo right now :roll: ).
Put WDLXTV back on and even with all the options set:
-enable NTP
-enable IPUP
-NTP delay 5s
-Tried various NTP servers

It will not update automatically. The only way it will update is if I telnet in and : ntpdate -s pool.ntp.org

Where is the call to update the time actually initiated and is this file overwritten when I flash the wdtv? The reason I ask is because should I chose to downgrade again to stock wdtv I would appreciate if the time still updated itself :P

Any help/tips/solutions are greatly appreciated. You can be technical.. I am fairly familiar with linux.

Thanks!!
winger88
n00b
 
Posts: 2
Joined: Tue Feb 18, 2014 9:12 am

Re: 1.05.04_B.WDLXTV_Plus_0.5.1.1 - NTP not updating (downgr   

Postby KAD » Tue Feb 18, 2014 12:23 pm

well you can try a longer delay

but afaik at boot system date is always 12/31/1999
this is true of WDLXTV and stock
until system time is updated via ntp
WDLXTV attempts to do this before dmaosd starts
but while you can see ntp system time can be updated
but causes dmaosd to do some wierd things

so I guess my question, once you updated the time does netflix work
I've never heard of a system time issue with netflix before
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

Re: 1.05.04_B.WDLXTV_Plus_0.5.1.1 - NTP not updating (downgr   

Postby winger88 » Tue Feb 18, 2014 1:00 pm

Hi Kad,

Thanks for your reply.

Yes once I update the time then netflix works as it is able to validate the ssl certificates.

If I put in a longer delay and I then downgrade.... does that change still remain or does reflashing the stock wd alter the config?

Thanks!
winger88
n00b
 
Posts: 2
Joined: Tue Feb 18, 2014 9:12 am

Re: 1.05.04_B.WDLXTV_Plus_0.5.1.1 - NTP not updating (downgr   

Postby KAD » Tue Feb 18, 2014 1:22 pm

reflashing to stock does not change / alter the /conf directory or any configuration entries

however
I dont' know how stock attempts NTP

the NTP_DELAY
IPUP and others are definetely WDLXTV only
stock firmware doesn't know what these settings are, or what to do with them
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

Re: 1.05.04_B.WDLXTV_Plus_0.5.1.1 - NTP not updating (downgr   

Postby salomon_grundy » Tue Apr 01, 2014 5:46 am

I have the very same problem and is causing me to not have Netflix, Hulu or Youtube Leanback. The people at Western Digital have been very unhelpful in this matter, which i think is their fault (a faulty update, script or something) and is frustrating that they give you half answers or none at all. :cry:
Anyway, I have been trying to use the S00custom to change the time settings, but haven't been able to make it work. So I try something simple to see what I was doing wrong, and this is what I did:

    Took S00custom-options just like it was inside the custom-firmware folder and only delete one hashtag (#) from the line #config_tool -c SCREEN_SAVER_IMAGE=screen_saver.png; I just wanted to see if I could change the background.

    Unplugged the WD TV from the wall, and inserted a FAT-32 formatted jump drive, with only the S00custom file inside, in the USB slot.

    I plugged the WD TV and waited for the booting.

    WD TV came on but the background was the same.

So, I really would like to change the settings for the NTP, but if I can't change a background much less a time-server setting. Please help. :(
salomon_grundy
WDTVer
 
Posts: 26
Joined: Fri Sep 21, 2012 5:45 pm

Re: 1.05.04_B.WDLXTV_Plus_0.5.1.1 - NTP not updating (downgr   

Postby KAD » Tue Apr 01, 2014 7:51 am

check out wec for confirguring ntp and other settings ;)

look here under webend http://forum.wdlxtv.com/viewtopic.php?f=2&t=2803
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

Re: 1.05.04_B.WDLXTV_Plus_0.5.1.1 - NTP not updating (downgr   

Postby recliq » Tue Apr 01, 2014 9:43 am

Moving this topic because this is not a WDLXTV bug.

Stock fw is stock fw... if you reflash stock firmware the only files left over from WDLXTV might be in /conf, wipe that dir after reflashing stock fw and you have 100% stock WDTV.
If something doesn't work then you should have a look at the official forums and support.
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany


Return to WDTV Live Plus

Who is online

Users browsing this forum: No registered users and 1 guest