Sign up here and you can log into the forum!

Netflix broken - tried everything (or have I)?

General WDLXTV-Plus forum

Netflix broken - tried everything (or have I)?   

Postby nafrance » Sun Dec 18, 2011 1:25 pm

Having got my WDTV Live + from the US, I firstly threw WDLXTV on (5.0.0.0), without firstly checking Netflix worked - I figure that was my big mistake!

I've now downgraded back to the latest stock firmware, but cannot at all get Netflix working.
Deactivated, factory reset, etc. etc.
Netflix loads my queues fine, I just get a message "We're having trouble playing this title right now. Please try again later or select a different title."
...for every title!

I'm in the UK, but using a valid Netflix account and a VPN (Unblock-us). I know both my connection and Netflix account work, 'cos the AppleTV2 that's sat next to the WDTV and plugged into another HDMI port on the TV works fine with the same details and same VPN!

Has the original use of WDLXTV *before* trying Netflix hosed my chances of ever getting it working again? :(
nafrance
n00b
 
Posts: 2
Joined: Sat Oct 01, 2011 2:43 am

Re: Netflix broken - tried everything (or have I)?   

Postby kroetkroet » Sun Dec 18, 2011 1:47 pm

Without ever tried it myself but from memories of other more netflix experienced users:
within wdlxtv, remove the complete /conf directory, then flash stock firmware with reset factory. Then play for at least 5' netflix and your keys get validated. Then wdlxtv can be flashed again...
WDLXTV-fan! - In case you need further assistance: read our WIKI, search our Forum and most of all: donate 'something' to b-rad for his great efforts!!!
User avatar
kroetkroet
Beta Tester
 
Posts: 1004
Joined: Mon Apr 05, 2010 11:53 pm

Re: Netflix broken - tried everything (or have I)?   

Postby lanynya » Mon Dec 19, 2011 7:51 pm

I had the same experience try for weeks nothing work except this >

rm /conf/systemData* /conf/nrd* /conf/devcert* /conf/activated
lanynya
Donor
 
Posts: 4
Joined: Fri Jul 01, 2011 5:44 pm

Re: Netflix broken - tried everything (or have I)?   

Postby nafrance » Wed Dec 21, 2011 10:55 am

Thanks for the input guys.

Just did the following (from the non-working official firmware):

Installed 0.5.1.1
Telnet'd in, rm /conf/*
Powered off
Booted with USB drive with latest official firmware
Installed latest firmware
Factory reset (for good measure)
Netflix setup
WORKED!
...about to now re-install WDLXTV.

Thanks again!
nafrance
n00b
 
Posts: 2
Joined: Sat Oct 01, 2011 2:43 am

Re: Netflix broken - tried everything (or have I)?   

Postby phil_tester » Wed Dec 21, 2011 11:12 pm

nafrance wrote:Thanks for the input guys.

Just did the following (from the non-working official firmware):

Installed 0.5.1.1
Telnet'd in, rm /conf/*

Thanks again!


Not a lot of thanks :(

Suffering from the same problem with Netfilx I tried original firmware which give me the same error.
Then I went back and flashed wdxltv again and this time did as in the quoted post
rm /conf/*
(not just selected directories)
which immediately killed the system.

Is there a way to restore the config, right now it does not boot at all, and usb flash light is not powered,
so I'd assume it would not boot EXT3 version as well?
phil_tester
n00b
 
Posts: 6
Joined: Wed Dec 21, 2011 11:06 pm

Re: Netflix broken - tried everything (or have I)?   

Postby kroetkroet » Thu Dec 22, 2011 12:35 am

I like the "killed my system"... If that's true, every beta-tester would have a large pile of bricks :lol:

In the early days, "rm -rf /conf" was mandatory when updating betaversions.

For clearing your complete system, I advice to do the "rm -rf /conf", flash the original stock WD firmware (do use the .ver trick if required), boot up original stock WD firmware and do a complete factory reset. Test netflix, youtube, to make sure everything works (eg. youtubekeys get created).

Then it's safe to go back to wdlxtv and tadaa: /conf is completely re-arranged.

Good luck "killing" ;)
KK
WDLXTV-fan! - In case you need further assistance: read our WIKI, search our Forum and most of all: donate 'something' to b-rad for his great efforts!!!
User avatar
kroetkroet
Beta Tester
 
Posts: 1004
Joined: Mon Apr 05, 2010 11:53 pm

Re: Netflix broken - tried everything (or have I)?   

Postby recliq » Thu Dec 22, 2011 2:58 am

We didn't kill your device (if it's killed) but you did. So there is no reason to be angry with us.
This is a homebrew firmware and it's clearly stated that you flash it in your own resposibility!
Also, like KroetKroet said, it's unlikely the WDLXTv is the cause but what whatever you did, otherwise there would be thousands of complains...

...anyways,

Tip of the day:
If it's not booting anymore, try holding down the reset button while powering the device on. You should be presented with an emergency flash screen. Insert an USB drive with stock firmware or WDLXTV to flash then.
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

Re: Netflix broken - tried everything (or have I)?   

Postby phil_tester » Thu Dec 22, 2011 10:18 am

recliq wrote:We didn't kill your device (if it's killed) but you did. So there is no reason to be angry with us.
This is a homebrew firmware and it's clearly stated that you flash it in your own resposibility!
Also, like KroetKroet said, it's unlikely the WDLXTv is the cause but what whatever you did, otherwise there would be thousands of complains...

...anyways,

Tip of the day:
If it's not booting anymore, try holding down the reset button while powering the device on. You should be presented with an emergency flash screen. Insert an USB drive with stock firmware or WDLXTV to flash then.


I don't complain I was kinda hoping that firmware would restore defaut config files if it does not find them, especially the poster above said that it helped.

I tried holding paper clip in reset hole of the left side next to a usb jack, while plugging power cable.
Did not help, no video signal tried both composite and hdmi output, and it seems usb port is not powered up
since there is no power light on usb drive or on usb indicator on wd's front panel.
phil_tester
n00b
 
Posts: 6
Joined: Wed Dec 21, 2011 11:06 pm

Re: Netflix broken - tried everything (or have I)?   

Postby Hwulex » Fri Mar 09, 2012 8:38 pm

In case it might help anybody else out there having the same problem, in part to this thread I just managed to get Netflix working on my WDlxTV which up to this point had failed on all fronts.

Unfortunately I'd never tried to use Netflix before I installled the WDlxTV firmware so after some research and failed attempts had to jump through a few hoops to get it going but this way you never have to downgrade or install a stock firmware over wdlxtv.

First up:
- Unregister your Netflix account. To do so, open Netflix and press
-- UP, Up, Down, Down, Left, Right, Left, Right, Up, Up, Up, Up, Enter
- Choose the deregister option
- Find a USB drive >= 512MB and plug it in to your wdlxtv
- SSH in to your wdtv and backup your conf directory to the USB drive
-- cd /tmp/media/usb/USB1/789798-5423423-634554
-- tar -zcf conf_backup.tar.gz /conf/*
- Remove the entire contents of your existing conf directory
-- rm -rf /conf
- Eject and unplug the USB drive from your wdlxtv and put it in your computer
- On your computer, download the latest WDTV Live Plus firmware from WD to the USB drive
- Likewise, from the Booting_Original_FW wiki page, download the mkrootbin.sh.gz script to the same USB drive
- Eject the USB drive from your computer, plug in to your WDLXTV, SSH in and navigate to its folder
- Unpack both the firmware and the script
-- gunzip mkrootbin.sh.gz
-- unzip wdtvliveplus_1.06.16_B.zip
- Rename the firmware file to make it compatible with the script
- Follow the steps on the Booting_Original_FW wiki page, ie
-- ./mkrootbin.sh
-- THIS IS SLOW, give it time to finish
- When it is done, ensure you enter the commands it tells you to at the end:
-- config_tool -c ROOT_TAG='104'
-- config_tool -s
-- config_tool -s
-- sync && reboot

Your WDTV should now boot from the USB to stock firmware. When it has, open Netflix, put your reg details in, and play a few titles to make sure it's working. When you're confident it is

- Eject and remove the USB drive
- Reboot the WDTV to the installed WDLXTV firmware
- Open Netflix to ensure it is still working - it should be!

- Insert your USB drive again
+ At this point you may need to verify the IP address as your normal config has been erased (I normally use static and it was now assigned by DHCP)
- Telnet in to the WDLXTV (my SSH did not work after a config wipe) username root with no password
- Navigate to your USB drive, ie
-- cd /tmp/media/usb/USB1/789798-5423423-634554
- Backup the existing and now working config directory
-- tar -zcf conf_working.tar.gz /conf/*
- Unpack your previous conf directory
-- tar -zxf conf_backup.tar.gz
- Copy your config file back to the WDLXTV
-- cp conf/config /conf
- Copy any other relevant config files, ie
-- cp conf/umsp-plugins* /conf
-- cp conf/mt-daapd.conf /conf
- Eject and remove your USB drive (I did this through the TV GUI)
- Now just ensure that the system will always reboot to its internal firmware
-- config_tool -c ROOT_TAG=''
-- config_tool -s
-- config_tool -s
-- sync && reboot

Your previous configuration should now be restored, however now with working Netflix. Huzzah! :mrgreen:
Hwulex
n00b
 
Posts: 3
Joined: Fri Oct 21, 2011 11:43 am
Location: Whistler, Canada

Re: Netflix broken - tried everything (or have I)?   

Postby griswold01 » Thu Jul 21, 2016 1:46 pm

nafrance wrote:Thanks for the input guys.

Just did the following (from the non-working official firmware):

Installed 0.5.1.1
Telnet'd in, rm /conf/*
Powered off
Booted with USB drive with latest official firmware
Installed latest firmware
Factory reset (for good measure)
Netflix setup
WORKED!
...about to now re-install WDLXTV.

Thanks again!


This worked for me!
(I used "rm -rf /conf/*")
After several days of frustration, calls to Netflix, WD, my ISP, upgrading and downgrading to every firmware I had, reading countless faq/help pages, trying every-damn-thing I could think of, and generally beating my head against the wall I finally found this post.
Thank you so much!!!

WD TV Live Plus WDLXTV Netflix aip-701
griswold01
Donor
 
Posts: 1
Joined: Mon Sep 20, 2010 2:37 am

Next

Return to Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron