Page 13 of 13

Re: Youtube3

PostPosted: Mon Jun 18, 2018 12:20 am
by mad_ady
Thanks for your patch. I uploaded it.

Re: Youtube3

PostPosted: Fri Sep 07, 2018 10:39 pm
by nixxo
hi mad_ady,

youtube updated the decrypt function after a long time.

So, the script needed an updated regex,
here is the patch: https://github.com/nixxo/umsp-plugins/c ... ce00.patch
or diff https://github.com/nixxo/umsp-plugins/c ... 8ce00.diff

Re: Youtube3

PostPosted: Sat Sep 08, 2018 9:57 am
by mad_ady
Thank you for the notice. I will merge your patch on tuesday, since I am currently away from my computer

Re: Youtube3

PostPosted: Mon Jun 10, 2019 8:13 am
by nixxo
a little update:
- removed a cople of warningsin the code,
- removed old code that created problems with some videos (youtube-dl is no longer used)

diff: https://github.com/nixxo/umsp-plugins/c ... b544d.diff
or patch: https://github.com/nixxo/umsp-plugins/c ... 544d.patch

Re: Youtube3

PostPosted: Fri Jul 05, 2019 11:08 pm
by nixxo
- signature to sig parameter in url creation

the update of 1 month ago was because youtube started to change the video url, now it seems they completed the transition and everything uses the "sig" parameter in the url instead of "signature". Some videos work with both. Music videos and such require the "sig" parameter, other videos work with both.

I changed to sig so everything woorks. (Until the next update ;-) )

patch: https://github.com/nixxo/umsp-plugins/c ... 890a.patch
diff: https://github.com/nixxo/umsp-plugins/c ... d890a.diff

Re: Youtube3

PostPosted: Sun Jul 07, 2019 10:26 pm
by mad_ady
Thanks!
I updated the plugin (and also incremented its version - see info.php).