Sign up here and you can log into the forum!

Problem with UMSP flv streaming (blank picture on playback)

Discussion, features, plugins--everything about zoster's UMSP UPnP Media Server software

Re: Problem with UMSP flv streaming (blank picture on playba   

Postby Martor » Fri Oct 05, 2012 11:52 am

DEAR ALL, I AM SOLVED!
My issues was missing --live parameter necessary for the RTMP command :) I am fully running without any ffmpeg necessary.

Thanks to all! Hope also you aenbacka will be able to solve your FLV stream.

Good luck!
1.02.21_V_WDLXTV.COM_WDLXTV_LIVE-0.5.1.1
Martor
DLX'er
 
Posts: 98
Joined: Sat Apr 10, 2010 9:58 pm
Location: Czech Republic

Re: Problem with UMSP flv streaming (blank picture on playba   

Postby aenbacka » Sun Oct 07, 2012 9:38 pm

Thank you all for your assistance, FLV streaming is now working ok for me, with both audio and video in sync! :)
aenbacka
n00b
 
Posts: 17
Joined: Sun Jan 23, 2011 10:48 pm

Re: Problem with UMSP flv streaming (blank picture on playba   

Postby Martor » Mon Oct 08, 2012 5:44 am

Excelent aenbacka! :)

I have just last tip regarding parsing HTML pages when searching for right content for UMSP ;)

A simple PHP HTML DOM parser written in PHP5+, supports invalid HTML, and provides a very easy way to handle HTML elements.
http://sourceforge.net/projects/simplehtmldom/

I am using it and it is really great, don't need to bother with regular expression, just include, and parse easily :)

Martin
1.02.21_V_WDLXTV.COM_WDLXTV_LIVE-0.5.1.1
Martor
DLX'er
 
Posts: 98
Joined: Sat Apr 10, 2010 9:58 pm
Location: Czech Republic

Re: Problem with UMSP flv streaming (blank picture on playba   

Postby aenbacka » Mon Oct 08, 2012 10:52 pm

Thanks for the tips, I will look into the HTML parser, could be useful :)
aenbacka
n00b
 
Posts: 17
Joined: Sun Jan 23, 2011 10:48 pm

Re: Problem with UMSP flv streaming (blank picture on playba   

Postby kotgeorgia » Tue Jul 09, 2013 4:08 am

Please help ...
No sound from the site http://online.stepashka.com
Dear professionals, help to fix ...
Firmware 1.02.21_WDLXTV.COM_WDLXTV_LIVE-0.4.7.3
Files attached ..
http://www.mediafire.com/?zgrg65ncnrditzj
Thanks in advance ...
kotgeorgia
n00b
 
Posts: 1
Joined: Thu Feb 07, 2013 12:25 pm

Re: Problem with UMSP flv streaming (blank picture on playba   

Postby jmaraujo » Fri Aug 02, 2013 6:20 pm

Yeah, I'm having the same problem as kotgeorgia. Thanks to Gui's kind help, who pointed me in the right direction, I was able to play FLV files from a umsp plugin I have here. But I'm not getting any audio.

To be fair, those FLV doesn't have audio on my WDTV even when downloaded and played from a pendrive, so I guess it's WDTV's fault and not the plugin/proxy itself. The proxy I'm using is the same Gui postead early in this thread.

Here's an example MediaInfo's data of one of those videos:
Code: Select all
General
Nombre completo                          : H:\wdlxtv.flv
Formato                                  : Flash Video
Tamaño del archivo                       : 3,29MB
Duración                                 : 16seg.
Tasa de bits total                       : 1 633Kbps
hasKeyframes                             : true

Video
Formato                                  : AVC
Formato/Info                             : Advanced Video Codec
Formato del perfil                       : High@L2.1
Ajustes del formato, CABAC               : Si
Ajustes del formato, RefFrames           : 4marcos
ID Códec                                 : 7
Duración                                 : 16seg.
Tasa de bits                             : 1 512Kbps
Ancho                                    : 480pixeles
Alto                                     : 360pixeles
Relación de aspecto                      : 4:3
Modo de velocidad de cuadro              : Constante
Velocidad de cuadro                      : 25,000fps
ColorSpace                               : YUV
ChromaSubsampling                        : 4:2:0
BitDepth/String                          : 8bits
Tipo de exploración                      : Progresivo
Bits/(Pixel*cuadro)                      : 0.350
Tamaño de pista                          : 3,05MB (93%)

Audio
Formato                                  : MPEG Audio
Formato de la versión                    : Version 1
Formato del perfil                       : Layer 3
Format_Settings_Mode                     : Joint stereo
Format_Settings_ModeExtension            : MS Stereo
ID Códec                                 : 2
ID Códec/Pista                           : MP3
Duración                                 : 16seg.
Tipo de tasa de bits                     : Constante
Tasa de bits                             : 128Kbps
Canal(es)                                : 2canales
Velocidad de muestreo                    : 44,1KHz
Tamaño de pista                          : 260Kib (8%)
Librería de codificación                 : LAME3.97

Some have AVC video and MP3 audio, others have AAC audio... :(

Is there any fix for this? Is it possible to change the container on the fly (like to a MKV container, for example)?
User avatar
jmaraujo
WDTVer
 
Posts: 30
Joined: Sun Feb 19, 2012 3:01 pm

Re: Problem with UMSP flv streaming (blank picture on playba   

Postby mad_ady » Sun Aug 04, 2013 9:46 pm

It is possible to change container on the fly, but you'll lose the ability to FF/REW (if you had it), and most likely you'll run into buffering issues.
Here are some references: http://forum.wdlxtv.com/viewtopic.php?f=49&t=4796&start=0
User avatar
mad_ady
Developer
 
Posts: 4570
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Problem with UMSP flv streaming (blank picture on playba   

Postby jmaraujo » Mon Aug 05, 2013 8:14 am

Thanks, mad_ady! ;) Not sure where to go from here... :( :oops:

I've failed to mention on my previous post that I'm a complete noob, altough I was able to write a fully functional plugin (well, almost fully functional :P ), with all the navigation/categories/search parts working like a charm. This damn "no-audio" thing it's just the only thing left to fix.

I've found that there are two types of remote FLV files handled by the plugin:
- Most of them have h.264/AVC video with mp3 audio (those files play fine, but without any audio)
- Some older ones have h.263/FLV1 (Sorenson Spark) video with AAC audio (those files does not play at all, but I don't care - there are only a few of them anyway)



PS: It's not my intention to hijack this topic, since we're still discusing FLV streaming. Otherwise, I have no problem in starting a new topic... ;)
User avatar
jmaraujo
WDTVer
 
Posts: 30
Joined: Sun Feb 19, 2012 3:01 pm

Re: Problem with UMSP flv streaming (blank picture on playba   

Postby mad_ady » Mon Aug 05, 2013 10:09 pm

If you already made a UMSP plugin, surely you can add transcoding support :)
You'll need to write a proxy that handles the transcoding (on the WDTV if no other system is available).

You can get inspiration of such a proxy inside the ipcamera plugin: https://svn.wdlxtv.com/filedetails.php?repname=UMSP&path=%2Fplugins%2Fipcamera%2Fipcamera.php (the proxy code begins after // this is executed when called in proxy mode). Basically a proxy will get as parameters the URL of the file you want transcoded and return the transcoded data (with the appropriate content-type). You'll need to experiment with ffmpeg (have the ffmpeg app.bin installed) and see that you can find the suitable parameters for you (you can get some suggestions in the transcoding thread I gave you). You should be able to do container transcoding but some containers are not well suited for streaming purposes (you'll be streaming the data out of ffmpeg instead of writing it to a file).

The first thing I'd try would be to find a good ffmpeg command that can provide adequate fps so that the video will not stop to buffer every 5 seconds during the conversion. Once you are ok with ffmpeg you can work on the proxy...

Good luck!
User avatar
mad_ady
Developer
 
Posts: 4570
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Problem with UMSP flv streaming (blank picture on playba   

Postby jmaraujo » Tue Aug 06, 2013 3:10 pm

Thanks, mad_ady! ;) I'll se what I can do.
User avatar
jmaraujo
WDTVer
 
Posts: 30
Joined: Sun Feb 19, 2012 3:01 pm

Previous

Return to UMSP Media Server

Who is online

Users browsing this forum: No registered users and 2 guests