Sign up here and you can log into the forum!

Plugin: YouTube Subscriptions + new subscription videos

Discussion, features, plugins--everything about zoster's UMSP UPnP Media Server software

Re: Plugin: YouTube Subscriptions + new subscription videos   

Postby mad_ady » Thu Feb 05, 2015 12:31 am

No, it should be fixed for you as well. I'll have another look...
User avatar
mad_ady
Developer
 
Posts: 4522
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Plugin: YouTube Subscriptions + new subscription videos   

Postby devilagent76 » Thu Feb 05, 2015 1:33 pm

I rebooted again to see any luck, now the umsp plugins dissapear completely like when the Svn server was down a few days ago..maybe I screwed up somewhere...oh well :D
devilagent76
n00b
 
Posts: 10
Joined: Fri Jan 10, 2014 11:36 am

Re: Plugin: YouTube Subscriptions + new subscription videos   

Postby mad_ady » Thu Feb 05, 2015 11:45 pm

Do you have a live or a gen3?
Can you try these commands (from command line)?
Code: Select all
umsp-plugman-web repolist
umsp-plugman-web download youtube-subscriptions
User avatar
mad_ady
Developer
 
Posts: 4522
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Plugin: YouTube Subscriptions + new subscription videos   

Postby devilagent76 » Fri Feb 06, 2015 10:57 am

I have a live.
Using the repolist will get me the full list of umsp plug-ins ( i used putty). Using the download youtube-subscriptions command do load youtube back in, still doesnt load any video, like described before. Rebooting my live disable youtube plugin again, but maybe thats because the way it loaded in the first place.
devilagent76
n00b
 
Posts: 10
Joined: Fri Jan 10, 2014 11:36 am

Re: Plugin: YouTube Subscriptions + new subscription videos   

Postby mad_ady » Sat Feb 07, 2015 4:35 am

Ok, I did some tests, on 1.02-0.5.2.0, rebooted (and downloaded youtube-subscriptions fresh), and it plays without issues...
I'm using:
Code: Select all
YOUTUBE_QUALITY='360P'


If after a reboot it still doesn't work for you, please try these (like the wiki http://wiki.wdlxtv.com/Youtube_subscriptions#Troubleshooting says):
Code: Select all
     To enable debugging in the proxy, run this command

sed -i 's/$logLevel = L_WARNING;/$logLevel = L_ALL;/' /tmp/umsp-plugins/youtube-subscriptions/youtube-subscriptions-proxy.php



Next, try to play a video, and then paste back/send me the contents of /tmp/umsp-log.txt
User avatar
mad_ady
Developer
 
Posts: 4522
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Plugin: YouTube Subscriptions + new subscription videos   

Postby devilagent76 » Sat Feb 07, 2015 6:42 am

If you actually didn't change any code now I don't know what happend, but after a reboot I was able to download the umsp plug-ins back in webend and youtube is able to load the video's back in, so everything working fine right now, thanks mad_ady for your great support ;)
devilagent76
n00b
 
Posts: 10
Joined: Fri Jan 10, 2014 11:36 am

Re: Plugin: YouTube Subscriptions + new subscription videos   

Postby wildwdlxtv » Thu Mar 19, 2015 5:33 pm

YouTube HD and YouTube subscriptions are not working. Using WDTV live
wildwdlxtv
n00b
 
Posts: 12
Joined: Sun Sep 04, 2011 7:18 pm

Re: Plugin: YouTube Subscriptions + new subscription videos   

Postby mad_ady » Thu Mar 19, 2015 9:08 pm

Thanks for the heads up! I'll have a look
User avatar
mad_ady
Developer
 
Posts: 4522
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Plugin: YouTube Subscriptions + new subscription videos   

Postby mad_ady » Fri Mar 20, 2015 3:11 am

Reboot and try again, please
Code: Select all
adrianp@frost:/media/NewHome/adrianp/development/umsp/plugins/youtube-subscriptions$ svn commit -m "Updated the gdata IP address (tip by recliq)"
Sending        info.php
Transmitting file data .
Committed revision 1323.
User avatar
mad_ady
Developer
 
Posts: 4522
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Plugin: YouTube Subscriptions + new subscription videos   

Postby mad_ady » Fri Apr 03, 2015 6:06 am

Well, I know this day would come, sooner or later...
Dear YouTube Developer,


You are receiving this email because your address is associated with a project that has recently accessed the YouTube Data API (v2), which will soon be shut down. Please disregard this message if you're not associated with such a project. There won't be any further emails.



In March 2014, we announced that the v2 API would be retired on April 20, 2015, and would be shut down soon thereafter. To help you with your migration, we published the migration guide in September. Now, we'd like to provide you with more details on the v2 retirement timeline.


As of April 20, 2015, v2 API endpoints will be shut off with the following exception: We will keep the v2 versions of the comments, captions, and flagging features accessible for a grace period past the shutdown date. These features are still listed as "To be supported" in the migration guide. The grace period is designed to give you time to implement the new v3 versions of these features as they become available. In addition, the v2 API endpoint for uploading videos will also remain open during this time.


If you would like to test your application's reaction to the v2 API shutdown, point it to eol.gdata.youtube.com instead of gdata.youtube.com.


Please migrate your app to the YouTube Data API v3 at your earliest convenience to avoid any outage.


For more information please visit: YouTube Data API v2 Turndown FAQ.


If you have any questions about the YouTube Data API v2 turndown, you can reach us via the this support form.


This means that this plugin will fail starting with 20th April.

Sadly, I've been busy with other projects (I am now working on porting wdlxtv to 1.06), so I didn't have time to look into their API changes (though I've seen they are substantial), and I didn't have time to prepare a replacement plugin. Couple this with a low incentive to do it (I've not used this plugin at home for the past year), and you get this disaster :oops:

Imho, this plugin should get a new lease on live and be rewritten to support the newer API, because WD's implementation in 1.06 is slower than molasses.

Most likely I will revisit it and try to rebuild it (with VEVO support and everything), but I don't know when. Can we have a show of hands of people still using it? Is any developer looking forward to work on this?
User avatar
mad_ady
Developer
 
Posts: 4522
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

PreviousNext

Return to UMSP Media Server

Who is online

Users browsing this forum: No registered users and 2 guests

cron