Sign up here and you can log into the forum!

Dialy Podcasts problem

Discussion, features, plugins--everything about zoster's UMSP UPnP Media Server software

Dialy Podcasts problem   

Postby Mopheus » Sat May 07, 2011 9:58 am

Hi everyone, I'm having an small problem with the Daily Podcasts plugin in latest firmware (based on 1.03). Here's all my info to see if someone could help me:

For the "http://your-wdtv-ip/umsp/umsp-test.php" test for DPoscasts I get:

Fatal error: Class '' not found in /tmp/umsp-plugins/daily-podcasts/daily-podcasts.php on line 15


Here is my daily-podcasts.php file, just in case:

<?php
// Daily Podcasts UMSP plugin by PaulF
// http://forum.wdlxtv.com/viewtopic.php?f=49&t=725

function __autoload($class_name) {
include $class_name . '.php';
}

function _pluginMain($prmQuery) {
$queryData = array();
$prmQuery = stripcslashes($prmQuery);
parse_str($prmQuery, $queryData);
if ($prmQuery != '') {
list($class, $path) = explode('::', stripcslashes($queryData['class']));
$menu = new $class($path);
} else {
$menu = new DailyPodcastMenu();
}
$media = $menu->asUMSP;
foreach($media as &$item){
if(isset($item['upnp:album_art'])){
$item['upnp:album_art'] = 'http://127.0.0.1/plugins/umsp/plugins/daily-podcasts/daily-podcasts.php?image=' .
preg_replace('/ /', '%20', $item['upnp:album_art']);
}
}
return $media;
} #end function _pluginMain
if(isset($_GET['image'])){
$image = $_GET['image'];
$image = preg_replace('/ /', '%20', $image);
$file = file_get_contents($image);
header('Content-type: ');
echo $file;
}

?>


Now my error /var/log/php5/error_log:

[02-Jan-2000 02:00:32] PHP Warning: array_merge() [<a href='function.array-merge'>function.array-merge</a>]: Argument #1 is not an array in /tmp/umsp-plugins/weather/weather.php on line 10
[02-Jan-2000 02:02:24] PHP Fatal error: Class '' not found in /tmp/umsp-plugins/daily-podcasts/daily-podcasts.php on line 15


I also get a similiar error when testing Weather Channel Plugin:

Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /tmp/umsp-plugins/weather/weather.php on line 10


Any ideas ?

Thanks a lot for any help.
Mopheus
WDTVer
 
Posts: 30
Joined: Wed Apr 27, 2011 7:31 am

Re: Dialy Podcasts problem   

Postby PaulF » Sat May 07, 2011 4:15 pm

I have no idea what http://your-wdtv-ip/umsp/umsp-test.php does. I must not follow expected coding of a UMSP php file.

I use http://your-wdtv-ip/umsp/plugins/daily-podcasts/DailyPodcastHTML.php to test my podcasts.
User avatar
PaulF
Developer
 
Posts: 427
Joined: Sat May 08, 2010 8:34 pm
Location: Oregon

Re: Dialy Podcasts problem   

Postby nicandmih » Sat May 07, 2011 9:20 pm

Hi, I have the same problem, I migrate temporary from 1.02.21/0.4.7.2 to 1.03.49_V.vdlxtv 0473, i remove externall hdd, grooveshark start to work but i lose the path for daily podcasts, when i tray this command: http://192.168.1.100/umsp/umsp-test.php i obtain this:
Code: Select all
Warning: DOMDocument::loadXML() [domdocument.loadxml]: Opening and ending tag mismatch: META line 1 and head in Entity, line: 1 in /tmp/umsp-plugins/daily-podcasts/DailyPodcastMenu.php on line 58

Warning: DOMDocument::loadXML() [domdocument.loadxml]: Opening and ending tag mismatch: head line 1 and html in Entity, line: 1 in /tmp/umsp-plugins/daily-podcasts/DailyPodcastMenu.php on line 58

Warning: DOMDocument::loadXML() [domdocument.loadxml]: Premature end of data in tag html line 1 in Entity, line: 2 in /tmp/umsp-plugins/daily-podcasts/DailyPodcastMenu.php on line 58

Warning: DOMXPath::query() [domxpath.query]: Invalid expression in /tmp/umsp-plugins/daily-podcasts/DailyPodcastMenu.php on line 67

Warning: DOMXPath::query() [domxpath.query]: Invalid expression in /tmp/umsp-plugins/daily-podcasts/DailyPodcastMenu.php on line 67

Fatal error: Call to a member function item() on a non-object in /tmp/umsp-plugins/daily-podcasts/DailyPodcastMenu.php on line 67

Warning: DOMDocument::loadXML() [domdocument.loadxml]: Opening and ending tag mismatch: META line 1 and head in Entity, line: 1 in /tmp/umsp-plugins/daily-podcasts/DailyPodcastMenu.php on line 58

Warning: DOMDocument::loadXML() [domdocument.loadxml]: Opening and ending tag mismatch: head line 1 and html in Entity, line: 1 in /tmp/umsp-plugins/daily-podcasts/DailyPodcastMenu.php on line 58

Warning: DOMDocument::loadXML() [domdocument.loadxml]: Premature end of data in tag html line 1 in Entity, line: 2 in /tmp/umsp-plugins/daily-podcasts/DailyPodcastMenu.php on line 58

Warning: DOMXPath::query() [domxpath.query]: Invalid expression in /tmp/umsp-plugins/daily-podcasts/DailyPodcastMenu.php on line 67

Warning: DOMXPath::query() [domxpath.query]: Invalid expression in /tmp/umsp-plugins/daily-podcasts/DailyPodcastMenu.php on line 67

Fatal error: Call to a member function item() on a non-object in /tmp/umsp-plugins/daily-podcasts/DailyPodcastMenu.php on line 67
nicandmih
Donor
 
Posts: 270
Joined: Sun Apr 11, 2010 10:46 am
Location: Romania, Constanta

Re: Dialy Podcasts problem   

Postby PaulF » Sat May 07, 2011 11:55 pm

Could someone please tell why you would run umsp-test.php. What does umsp-test.php do?

I am running:
1.02.21_WDLXTV.COM_WDLXTV_LIVE-0.4.2.2

Does daily=podcast work on the WDTV? Is running umsp-test.php required on the new FW?
User avatar
PaulF
Developer
 
Posts: 427
Joined: Sat May 08, 2010 8:34 pm
Location: Oregon

Re: Dialy Podcasts problem   

Postby nicandmih » Sun May 08, 2011 12:24 am

HI, when i`m running umsp test i can see the plugin on the PC. when apear an error u can see where it is, on the tv apear just "no media", but i resolve the problems was a wrong path.
nicandmih
Donor
 
Posts: 270
Joined: Sun Apr 11, 2010 10:46 am
Location: Romania, Constanta

Re: Dialy Podcasts problem   

Postby recliq » Sun May 08, 2011 3:46 am

I don't see any new plugin published here...

Moving this thread.
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

Re: Dialy Podcasts problem   

Postby mad_ady » Sun May 08, 2011 6:34 am

@PaulF: umsp-test.php is just a way to test/use the plugins via a browser. It is part of the umsp framework (part of the firmware). It provides a faster way to test and debug umsp plugins (the errors go to the browser, not just in a log).
You should upgrade - you are running quite an old version... :)
User avatar
mad_ady
Developer
 
Posts: 4573
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Dialy Podcasts problem   

Postby bagira » Mon May 09, 2011 1:35 am

PaulF wrote:Could someone please tell why you would run umsp-test.php. What does umsp-test.php do?
I am running:
1.02.21_WDLXTV.COM_WDLXTV_LIVE-0.4.2.2
Does daily=podcast work on the WDTV? Is running umsp-test.php required on the new FW?

mad_ady wrote:@PaulF: umsp-test.php is just a way to test/use the plugins via a browser. It is part of the umsp framework (part of the firmware). It provides a faster way to test and debug umsp plugins (the errors go to the browser, not just in a log).
You should upgrade - you are running quite an old version... :)

Umsp-test is my creation for develop and test UMSP plugins via a webbrowser. It was published, and commited to svn in midddle of Oct, 2010.
I already have a newer version (bugfixes, design, better built-in UMSP support), that I tried several time to push into svn, but with no luck. I have no right to commit into wdlxtv-live repo. I (and also mad_ady) have already sent to couple of core WDLXTV developer, but without any luck... If you wish, I can publish the new version on the main thread of umsp-test: http://forum.wdlxtv.com/viewtopic.php?f=49&t=2091
bagira
Beta Tester
 
Posts: 84
Joined: Mon May 03, 2010 10:58 am
Location: Hungary

Re: Dialy Podcasts problem   

Postby Mopheus » Mon May 09, 2011 3:47 am

So no-one has any idea how to address my problem ? I was supposed to be an easy plug-in but it seems not to be working fine for most of the ppl here....
Mopheus
WDTVer
 
Posts: 30
Joined: Wed Apr 27, 2011 7:31 am

Re: Dialy Podcasts problem   

Postby bagira » Mon May 09, 2011 4:11 am

Mopheus wrote:So no-one has any idea how to address my problem ? I was supposed to be an easy plug-in but it seems not to be working fine for most of the ppl here....

The first problem is, that the condition in line 11 is wrong. This is the correct line:
Code: Select all
    if (isset($queryData['class'])) {
And this problem is not belongs to umsp-test, instead this is developing bug.
And of course if you change this line you can get another Errors, Warnings and Notices...
bagira
Beta Tester
 
Posts: 84
Joined: Mon May 03, 2010 10:58 am
Location: Hungary

Next

Return to UMSP Media Server

Who is online

Users browsing this forum: No registered users and 2 guests