Page 1 of 1

would like to use my wireless adapter

PostPosted: Tue Mar 01, 2016 4:46 pm
by EvilWayz
But I'm thinking the driver isn't part of the current software. I have never made or modified firmware, although I do know how to compile a drive from source. Mostly.
So anyways the device in question is a ralink dongle model MT7601U. I run ubuntu 14.04 with the 3.16 kernel and it works there. No idea what kernel this firmware runs.

Re: would like to use my wireless adapter

PostPosted: Wed Mar 02, 2016 12:14 am
by mad_ady
But why a new post?

The firmware runs a variant of 2.6.22 kernel. You can't compile the whole kernel (you can compile it, but you can't sign it to boot it). You can compile new modules in, but the wireless drivers have also a component that is built into DMAOSD, which you can't change. So, if your adapter is not picked up by the latest official firmware it probably won't work on WDLXTV as well. There only a small list of supported dongles that work on WD's site.