Page 1 of 7

What's the problem with GPT (>2 TB) support?

PostPosted: Mon Jan 26, 2015 4:31 am
by mad_ady
Well, I have a (legitimate) question - why don't all the kernels (Live/Plus) support >2TB drives? As far as I know (from folklore), Plus WDLXTV doesn't support large drives.

So, I took a look at the kernel features - and it seems that what a kernel needs is to have CONFIG_EFI_PARTITION=y to be able to understand large drives. I did a diff between all the kernel's configs and:
Code: Select all
adrianp@frost:~/development/kernels-temp$ grep CONFIG_EFI_PARTITION *

... it seems all the kernels support GPT partition tables. So, why don't large drives work on some devices? Why do they work on official 1.05-Plus, but not on WDLXTV 1.05-Plus? What else is missing?

I don't have a >2TB drive to test, but I want to learn...

Re: What's the problem with GPT (>2 TB) support?

PostPosted: Mon Jan 26, 2015 9:08 am
by KAD
I really don't have an answer for you, but my initial thought

maybe it's some difference in the filesystem driver
ie NFTS, EXT3 , etc ..

just because the kernel understands GPT
doesn't mean the filesystem driver can work with >2 TB

but that's just a guess

Re: What's the problem with GPT (>2 TB) support?

PostPosted: Mon Jan 26, 2015 11:33 pm
by mad_ady
Partition size should not be an issue...

NTFS supports maximum 256 TB and ext2/3 supports 4/32TB partitions.

It must be something else... I think I will try with an image with GPT headers and try to mount it as a loop device. It should behave the same way even if the drive is not > 2TB (I was thinking of a 10MB GPT disk :D)

I'll let you know. By the way, KAD, do you have a Plus to run some tests for me?

Re: What's the problem with GPT (>2 TB) support?

PostPosted: Tue Jan 27, 2015 9:10 am
by KAD
10MB lol well at least the test will be quick

sorry no plus here, just an old live

Re: What's the problem with GPT (>2 TB) support?

PostPosted: Thu Jan 29, 2015 3:57 am
by mad_ady
Ok, I did some tests with a 8GB USB stick which I formatted using GPT partition table and a vfat partition. I tried all the live kernels (the older #7, the current #9 and the IPv6 varaint #27), and all of them are able to view and mount the stick (even on 1.02 base firmware).

Code: Select all
EFI GPT found
FirstUsableLBA: 34
PartitionEntryLBA: 2
NumberOfPartitionEntries: 128

So, from my tests large drives (having GPT/EFI partitioning tables) should be supported at least by all the Live firmwares.
Can somebody with a Live and a >2TB drive confirm/infirm what I tested?
Also, can someone with a Plus try out my method (you can use GParted to create a GPT partition table) and see if the disk works on the plus? From what I've read in the kernel config, it should work. I don't know if there is an extra setting that should influence that (e.g. GPT works, but large drives don't work?)...

Re: What's the problem with GPT (>2 TB) support?

PostPosted: Sat Feb 07, 2015 6:08 am
by Big
I've 4TB drive with GPT, single 4TB partition formatted to EXT4 and it works well with my Live and Gen3.

I've had one simple problem with GPT (solved), described here -

Re: What's the problem with GPT (>2 TB) support?

PostPosted: Sat Feb 07, 2015 12:40 pm
by mad_ady
Thanks for the feedback! Can you tell us what firmware are you running on the live? Also, are you willing to flash other kernels to the live (should be perfectly safe) and test plugging your disk again (I can't guarantee data safety though, but I'd love to learn what happens)?

Re: What's the problem with GPT (>2 TB) support?

PostPosted: Wed Aug 12, 2015 6:38 pm
by lovilela
My first post here at the forum. Maybe I should have been more participative before, but it is always time! WDTV is old, but not dead...

Well, let me first tell a story. I have a WD TV Live Plus (since 2010), but just more recently I have been playing around with USB hard drives plugged into it. For years I have used it to read movies from my NAS (a WD My Book World Edition "White Light" 1TB) through a wired network, with no issues whatsoever. Of course, since the very beginning it was also WDLXTVed.

That setup lasted until few months ago when my NAS suffered an "accident" (an overloaded book shelf literally felt just over it, smashing the poor bastard...). So I bought a WD MyPassport with 2TB capacity. That capacity was no coincidence as a read here that WDTVs have issues with large drives. I wasn't much into experimentations, just wanted to play safe.

The WDTV+MyPassport combination worked just fine, as expected. However, I was running out of space in my hard drives (in part due to my new 100mbps internet fiber connection, I guess you understand) and decided to go big. Amazon was selling Seagate Backup Plus USB3.0 5TB HD for $135 and as I was planning a trip to US, so I decided to give it a try.

To be honest, I was prepared to use it in my computer, maybe read some movies there over the network in my WDTV and that's it. From what I read here, no chance a 5TB drive would work on a WDLXTV-Plus firmware.

That until I read this post here. What if I change the 5TB drive partition to GPT and format it using EXT3? Maybe it will work! Let's give it a try then, that would be perfect.

But just before formatting, I though: the drive is empty, no data to lose... so, guess what, I will hook this thing up in WDTV "right from the box" and see what happens. I was prepared for some error message or even not see the drive.

But to my surprise, actually it was recognized and simply worked! The firmware installed is 1.05.04_B.WDLXTV_PLUS-

I entered the Web Frontend and it shows the right size (exactly 4.5TB) and the partition type (NTFS). My final test was copying a movie (i did it through the network, using SMB on the WDTV end) and run it on WDTV. After copying, I rebooted WDTV and, voilĂ , there it was. Just went there and played it. Really flawless...

After the great experience, I wonder if I still should format it to EXT3. I read that WDTV deals better with Linux partitions, using less resources. As I plan now to set it up as a torrent box (using rtorrent), it seems to the right move. I'll also upgrade WDLXTV with the latest versions.

So, case closed? Or maybe these new drives have something that old ones were lacking?

Re: What's the problem with GPT (>2 TB) support?

PostPosted: Wed Aug 12, 2015 9:27 pm
by mad_ady
Hmm, strange. According to all other reports it shouldn't have worked.

Ext3 has better fault tolerance and write performance on the wdtv, but you need a special driver if you hook it up to windows boxes (ext2ifs). Since the drive is empty, you can give it a try.

Report back if you run into problems (corruption) after you fill it with more than 2TB of data.

Re: What's the problem with GPT (>2 TB) support?

PostPosted: Thu Aug 13, 2015 5:43 am
by Big
My personal experience with SMP (Gen3) and >2TB drives is that they work OK until you hit 2TB data limit. I've 4TB WD My Book and it worked this way with factory format of partitions (non-GPT), I've only changed filesystem to EXT4. But it was so until I've filled it with data over 2TB limit. So I decided to backup data, reformat partition table to GPT, create single 4TB partition with EXT4 filesystem and now everything is OK with data over 2TB. So IMHO first check this situation now before having problem to backup data when 2TB limit is reached ;-)