Sign up here and you can log into the forum!

[fixed]svn not working for me

Have a question about devices internals, memory layout, reverse engineering, etc---This is the place for anything so technical that it would cause a n00b's head to 'splode

Re: [fixed]svn not working for me   

Postby mad_ady » Thu Jan 29, 2015 11:47 pm

Yes, the original server has been down from yesterday (no longer accepting https connections). I've spoken to recliq and b-rad and they are in the process of migrating the data to a new server (owned by recliq). The original owner of the svn server (ReMARKable) informed us he wanted to repurpose the server and we should move our stuff asap. He had been providing free service to the community for over 5 years, so let's thank him for that.

Regular service should restart soon, but there is some downtime affecting everybody.

In the mean time I think you can trick it by setting this ip in your hosts file, but don't do any commits until recliq says everything is ready:
Code: Select all
217.70.199.8    svn.wdlxtv.com
User avatar
mad_ady
Developer
 
Posts: 4529
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: [fixed]svn not working for me   

Postby DJArty » Sun Feb 01, 2015 3:41 am

looks like svn up.
But
1) sometimes looks like server have not enough speed to upload all plugins to client WD. (Really after WD reboot in UMSP can see not all plugins, only re-download from WEC can help).
2) about https - around certificates. Some advance user figure-out problem with plugin download if time on WD not setup via NTP. So usually time looks like 1999 and svn server says something like this "...certificate not valid yet.."(think its on 1.02.21 and --trust-server-cert --non-interactive not help). May be need to generate certificate for long term 1999-2017 if its possible to prevent this problem (90% users not setup real time via NTP)

P.S. I check and yes - its BIG problem All 1.02.21 users with not set real date not have any plugins.
Code: Select all
# date --set="1999-01-01 10:00"
Fri Jan  1 10:00:00 UTC 1999
# svn export --trust-server-cert --non-interactive --no-auth-cache --force https://svn.wdlxtv.com/svn/UMSP/russian /tmp/umsp-test2
svn: OPTIONS of 'https://svn.wdlxtv.com/svn/UMSP/russian': Server certificate verification failed: certificate is not yet valid, issuer is not trusted (https://svn.wdlxtv.com)
WD TV Live (1.02.21-WDLXTV-0.4.7.3);
Please Donate PayPal to email: djartyua ( a t ) gmail (d o t) com
WebMoney: WMZ114867333413; WMU219453404899; WMR161810775332
User avatar
DJArty
Developer
 
Posts: 540
Joined: Wed Jul 21, 2010 2:30 am
Location: Ukraine

Re: [fixed]svn not working for me   

Postby mad_ady » Sun Feb 01, 2015 6:15 am

I take it that you are still using 0.4.7.3 (I don't remember why, though), so you download via svn directly, right? Newer versions download via http and don't have this problem... True, a certificate change could fix this.
User avatar
mad_ady
Developer
 
Posts: 4529
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: [fixed]svn not working for me   

Postby DJArty » Sun Feb 01, 2015 7:21 am

I'm really recommend 1.02.21-0.4.7.3 for all who whant to use WDTVExt plugins and IPTVv3 becouse its use WDTVExt engine for TV programm. And 1.02.21-0.4.7.3 f/w load plugin by svn engine - not via http. And as I know svn engine more acceptable than http for server load.
Becouse 1.02.21-0.4.7.3 its finall really best firmware with WDTVExt support - noone else. Only one problem for this fw its mkv with compressed headers. (but normal releasers not use compressed headers in mkv - its mad to save 1mb in 15Gb file)
So please fix certificate to make all 1.02.21-0.4.7.3 peoples happy (Now its all have no UMSP plugins with new server).
WD TV Live (1.02.21-WDLXTV-0.4.7.3);
Please Donate PayPal to email: djartyua ( a t ) gmail (d o t) com
WebMoney: WMZ114867333413; WMU219453404899; WMR161810775332
User avatar
DJArty
Developer
 
Posts: 540
Joined: Wed Jul 21, 2010 2:30 am
Location: Ukraine

Re: [fixed]svn not working for me   

Postby recliq » Sun Feb 01, 2015 9:52 am

Certificate should work fine if you trust it (cmdline option) and your time is correct. Why would you have a 1999 date, just set ntp=on
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

Re: [fixed]svn not working for me   

Postby DJArty » Sun Feb 01, 2015 10:26 am

I say - default 90% users dont know what is ntp. And dont take it.
So just make right certificate. Like was before. Or ask how to do this if its a problem.
I provide sample before how to proof the problem.
If somebody dont know - time on WD without NTP=on, IPUP=on NTP_DELAY etc... always around 2000 year and not 2015 and all plugins dont load on 1.02.21-0.4.7.3 last stable wdlxtv b-rad firmware.
WD TV Live (1.02.21-WDLXTV-0.4.7.3);
Please Donate PayPal to email: djartyua ( a t ) gmail (d o t) com
WebMoney: WMZ114867333413; WMU219453404899; WMR161810775332
User avatar
DJArty
Developer
 
Posts: 540
Joined: Wed Jul 21, 2010 2:30 am
Location: Ukraine

Re: [fixed]svn not working for me   

Postby mad_ady » Sun Feb 01, 2015 10:30 am

Offtopic, but why not upgrade to 1.02-0.5.x.x? Anything broken compared to 0.4.7.3? I know there are some internal changes, but it shouldn't affect your plugins.
User avatar
mad_ady
Developer
 
Posts: 4529
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: [fixed]svn not working for me   

Postby DJArty » Sun Feb 01, 2015 10:41 am

Yes its offtopic.
Someone got descicion to make umspnet compatibly without community.
Someone make descision load plugins via http only and forgot about svn export .... without back compatibility.
(BTW my plugins check "bab code" from new umsp firmwares and work anyway, but many old plugins cant work on new 0.5.x.x becouse someone make this is right descicion).
Just regenerate the https certificate like early for long term... thats all I ask from new server admin. Its more easy do from one side, but not so easy to tell everybody reflash to another firmware. Look e.g. russian forum if not believe how many peoples dont understand why not see any plugins 3 days. And now looks like can got statistic how many peoples use old but stable 1.02.21-0.4.7.3.
(Try to load 1.02.21-0.4.7.3 - its the best in this line - and see UMSP plugins load or not, NTP=off by default)
WD TV Live (1.02.21-WDLXTV-0.4.7.3);
Please Donate PayPal to email: djartyua ( a t ) gmail (d o t) com
WebMoney: WMZ114867333413; WMU219453404899; WMR161810775332
User avatar
DJArty
Developer
 
Posts: 540
Joined: Wed Jul 21, 2010 2:30 am
Location: Ukraine

Re: [fixed]svn not working for me   

Postby mad_ady » Mon Feb 02, 2015 12:10 am

It seems there's a larger russian/eastern european community we know very little of :)

<offtopic, but important>
It would be nice if we could get them inline with the current releases, so that everyone can benefit from the newer changes.

Regarding UMSPNET (I assume you're talking about UMSP_LAN) and the changes made (detailed here): http://wiki.wdlxtv.com/index.php?title=UMSP_plugin_development#Plugins_that_work_with_UMSP_LAN_feature
As described there, the changes were needed to ensure the code generates a valid XML, so takes the precautions to encode all variables. I remember you used to pass URLs as variables (and had ampersands internally). You can get around the problem of having the URLs broken by the decode function by encoding them as base64 for example, and decoding them before using... I remember you complained about the changes, and I offered to accept any patches to do things differently and keep both backward compatibility and keep the XMLs valid at the same time, but I never received anything. You're talking about consulting with the community - well, the development of the feature was done openly, on this forum - yet, apart from you, I never got any negative feedback about it.

I don't know which plugins you refer to as being broken because of the change to 0.5.x.x (are they from a different repo?). I am sure that with a bit of time investment they can be adapted to the new UMSP API (which by the way was only introduced since 0.5.2.x)

Loading plugins via http and not svn export was done because back in the day when 0.4.7.3 was released (2011) we had about ~40 plugins. Fast forward to today when we have ~115 plugins (yay!). Even back then we realized it was a waste of time, memory and bandwidth to download all the plugins at every reboot if the user only used a few of them. That's why the new system was put in place to help with long term scalability. And I personally think it was a good move.

So, changing the certificate to be valid in 1999 would be a quick fix, but what about updating those plugins to be compatible with the newer versions?
You'd need to do some of the work, and also instruct your users to use devtools.app.bin (for rtmp I think), but IMHO, it would be beneficial for everybody if they moved to newer, still supported, versions...
User avatar
mad_ady
Developer
 
Posts: 4529
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: [fixed]svn not working for me   

Postby recliq » Mon Feb 02, 2015 5:05 am

I'll fix the certs...

UPDATE
Certs now begin on 1.1.1999
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

PreviousNext

Return to WDTV Live

Who is online

Users browsing this forum: No registered users and 1 guest