Sign up here and you can log into the forum!

Auto framerate/resolution plugin for WDLXTV

Here is the place to inquire about app.bins--Only currently available apps for sigma 8655 based wdtv's belong in this forum. requests go in 'Application Questions'

Re: Auto framerate/resolution plugin for WDLXTV   

Postby fguy » Fri Mar 01, 2013 4:15 pm

dart wrote:Hello everyone,

Recliq suggested to post this issue on forum, so here it is.
I've got a problem with autores. It seems to be similar to fguy's one.
With 1.02/5.1.1.1 wdlxtv firmware installed I try to make autores work. It starts properly:
Code: Select all
Loading firmware version ...
Waiting for dmaosd ...
Found dmaosd process (2056) ...
Found dmaosd version "WD TV Live 1.02.21", patching ...
All done!

but after starting to playback any movie this comes up in a log file:
Code: Select all
ERROR: current audio output mode 1 1 is invalid, exiting ...

As it really is exiting, it does not make its magic with frame rate/refresh rate.
What I found is these two numbers correspond to AUDIO_OUT and AUTO_AUDIO_OUT values in /conf/config file.
You can find my /etc/autores.conf file here.



hey dart

yes you seem to be having the same problem that i was facing. surprisingly not m/any have experienced the same because after many hours of "detective work" i realised its caused by a issue in the code.

it took me a long time to figure out as i know nothing about programming/linux etc but this is what i came up with & was intending to post for a while but got busy with other things but here is what i did & it seems to be working now so i hope it helps in your case too (keep in mind that my linux knowledge is 0 so if there is a more graceful way of doing this i hope someone else will chime in here) --

as you realised that the issue is that two numbers which correspond to AUDIO_OUT and AUTO_AUDIO_OUT are the cause & its due to this part of the autores code (ie autores.sh file in /usr/bin/autores.sh) on line 320

Code: Select all
current_audio_mode=`cat /conf/config | grep "AUDIO_OUT=" | cut -d \' -f 2`


which give out two values instead of one that the autores code is looking for & causes autores to quit

so what i did is add the following to the code

Code: Select all
| tail -1


which outputted 1 single value

so now line 320 looks like this

Code: Select all
current_audio_mode=`cat /conf/config | grep "AUDIO_OUT=" | cut -d \' -f 2 | tail -1`


so make the change, save & reboot

now if you running the ext3 version of the wdlxtv fw then i dont think you should have to do anything else but i ran into a problem - namely i'm on the flash version which doesnt allow you to edit anything other than /conf folder files. after setting up everything on it (not for the 1st time that too) i really didnt want to switch to the ext3 version so i worked on a workaround which you would also have to do if you are on the non-ext3 fw & dont want to switch

so for flash/non-ext3 firmware you have to -

1) copy the autores.sh file to /conf
2) make the changes to line 320 in the new file at /conf/autores.sh
3) make a S99user-script http://wiki.wdlxtv.com/User_Scripts with the following code

Code: Select all
#!/bin/sh

logger -s -t `basename $0` "executing autores overwrite"
cp /conf/autores.sh /tmp &&
chmod 777 /tmp/autores.sh


4) save & reboot

this should be good enough to solve your problem. lemme know if it works for you too

there are a few issues i havent been able to solve -

1) some AV sync issues with a few files of different formats - mp4 & mov & mkv - which i havent been able to pinpoint the cause of

2) i cant seem to edit the autores options (to say disable autores for .mov files). if i try it from WEC it doesnt get saved & if i try a workaround similar to above ie copy the autores.conf file to /conf, removing .mov from its valid video extension & adding the following to the S99user-script

Code: Select all
cp /conf/autores.conf /tmp &&
dos2unix /tmp/autores.conf &&
chmod 777 /tmp/autores.conf

it replaces the autores.conf with mine but it still does its stuff on .mov file & doesnt exit

so i'm wondering if all the time spent on fixing it wasnt wasted & if it'll be better to leave autores off but for now i've left in on
wdtv live with 1.02.21 v 0.5.0.0 wdlxtv firmware
fguy
WDTVer
 
Posts: 25
Joined: Thu Dec 06, 2012 4:58 pm

Re: Auto framerate/resolution plugin for WDLXTV   

Postby dart » Sat Mar 02, 2013 3:20 am

Great job, fguy!
As I have non-ext3 version as well, your workaround is very helpfull. I made quick test with two mkv files and it seems to work flawlessly. The only thing I've changed is replacing tail command with head, as when you grep config file, AUDIO_OUT variable is in the first line.
I don't think AV sync and mov issues are related to AUDIO options. I will let you know if I experience this.
Anyway, mov file format is not very popular nowadays (I haven't got any), so I wouldn't care so much.
One more thing. Why did you apply dos2unix command in the last script?
dart
n00b
 
Posts: 2
Joined: Thu Feb 28, 2013 11:34 am

Re: Auto framerate/resolution plugin for WDLXTV   

Postby fguy » Mon Mar 04, 2013 5:34 pm

dart wrote:Why did you apply dos2unix command in the last script?


it was the code in the autores.conf
wdtv live with 1.02.21 v 0.5.0.0 wdlxtv firmware
fguy
WDTVer
 
Posts: 25
Joined: Thu Dec 06, 2012 4:58 pm

Re: Auto framerate/resolution plugin for WDLXTV   

Postby wongnog » Sat Mar 23, 2013 5:03 pm

Could someone please explain how the forced subtitle feature works? In the WDTV config screen, I have subtitles set to OFF by default. What I would like autores to do is to automatically turn subtitles on if it detects a Forced flag within the MKV. Is this how it is supposed to work?

Also when I had 1.05.04_V_WDLXTV.COM_WDLXTV_LIVE-0.5.1.1 installed, I found that the WD auto framerate feature worked well in that MKV files with 23.976 framerate would play @24fps on my TV. However after downgrading to 1.02.21_WDLXTV.COM_WDLXTV_LIVE-0.5.1.1 to try this plugin, MKV files with 23.976 framerate play @60fps on my TV. I do have autores enabled in the webend.
wongnog
WDTVer
 
Posts: 31
Joined: Mon May 03, 2010 6:42 am

Re: Auto framerate/resolution plugin for WDLXTV   

Postby wongnog » Sun Mar 24, 2013 7:00 pm

rened77 wrote:Should i turn "ForceHDMI" On or Off?
And what do you have taken in the WD TV Settings -> Video/Audio -> Display settings?
Cause i take Auto and i think thats the problem why everytime the OSD Display was so bad quality when i stop playback.
But when i take 1080p the playback always zaps a little.

I am wondering the same thing. I wish there was a bit more documentation on this plugin. I find there is not much explanation in the WebEnd. For example, ForceHDMI is off by default but I couldn't get this plugin to work until I turned it on.
wongnog
WDTVer
 
Posts: 31
Joined: Mon May 03, 2010 6:42 am

Re: Auto framerate/resolution plugin for WDLXTV   

Postby recliq » Mon Mar 25, 2013 1:48 am

ForceHDMI is for forcing a display mode that is supported my your monitor/tv but not reported by it's EDID. Nothing more.
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

Re: Auto framerate/resolution plugin for WDLXTV   

Postby wongnog » Tue Mar 26, 2013 7:10 pm

wongnog wrote:Could someone please explain how the forced subtitle feature works? In the WDTV config screen, I have subtitles set to OFF by default. What I would like autores to do is to automatically turn subtitles on if it detects a Forced flag within the MKV. Is this how it is supposed to work?

Alright guess nobody wants to help a novice plugin user. Autores treats forced subtitles as I hoped when I turn subtitles off in the WDTV settings menu, i.e. only displays subtitles with the forced flag. Also had to go to web-end and open WDLXTV Configuration, select Main tab, then check off that AUTORES is enabled and also AUTORES_SUBTITLE_SELECT.
wongnog
WDTVer
 
Posts: 31
Joined: Mon May 03, 2010 6:42 am

Re: Auto framerate/resolution plugin for WDLXTV   

Postby supersonic124 » Mon Jun 17, 2013 5:01 pm

Anyone have a download link for this? The one in the first post is dead.
supersonic124
n00b
 
Posts: 2
Joined: Mon Jun 17, 2013 5:00 pm

Re: Auto framerate/resolution plugin for WDLXTV   

Postby recliq » Tue Jun 18, 2013 9:01 am

It's included in WDLXTV since version 0.4.2.1 :ugeek:
http://wiki.wdlxtv.com/Changelog_WDLXTV_Live#0.4.2.1
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

Re: Auto framerate/resolution plugin for WDLXTV   

Postby supersonic124 » Fri Jun 21, 2013 12:17 pm

How do I edit the autores config then? I'm on WDLXTV 0.4.5.3 G2 and there's no autores.conf in the firmware zip or my USB drive...
supersonic124
n00b
 
Posts: 2
Joined: Mon Jun 17, 2013 5:00 pm

PreviousNext

Return to WDLXTV-G2 & WDLXTV-Live/Plus app.bins

Who is online

Users browsing this forum: No registered users and 1 guest