Sign up here and you can log into the forum!

MINIDLNA 1.1.2!!!!! 4/8/2014

Here is the place to inquire about app.bins--Only currently available apps for sigma 8655 based wdtv's belong in this forum. requests go in 'Application Questions'

Re: MINIDLNA 1.1.2!!!!! 4/8/2014   

Postby teddychn » Sat May 03, 2014 5:03 am

Bye the way, I just tried to execute
# minidlna -R

and get the message below:
minidlna: /lib/libjpeg.so.62: no version information available (required by minidlna)

It seems that's something abnromal.
teddychn
Donor
 
Posts: 27
Joined: Tue Jan 25, 2011 10:56 pm

Re: MINIDLNA 1.1.2!!!!! 4/8/2014   

Postby custard » Sun May 04, 2014 11:00 am

IIRC I had something like this happen to me, I'm trying to remember what i did to fix it.
Are your config settings surviving a reboot?

If not, can you try these:
1) Download and install fresh copies ffmpeg and minidlna
2) Make sure you've created a .mnt file in your media directory and use tmp mounts to ensure early mounting.
3) Once settings are saved copy your minidlna.config from tmp/conf to the conf folder

Can't think of anything else at the moment. :roll:

Edit: I just checked and I also get the same message about libjpeg.
custard
Donor
 
Posts: 46
Joined: Wed Dec 29, 2010 1:19 am

Re: MINIDLNA 1.1.2!!!!! 4/8/2014   

Postby teddychn » Sun May 11, 2014 4:26 am

I have tried point 2 & 3 for more than two times. But I don't know how to install fresh
ffmpeg and minidlna. I tried to reflash 1.05.04, even the .ver file been modified to
newer version, I cannot reflash the firmware.

I will report further status if I have time to do more test or get any further information.

Thanks!
Ted
teddychn
Donor
 
Posts: 27
Joined: Tue Jan 25, 2011 10:56 pm

Re: MINIDLNA 1.1.2!!!!! 4/8/2014   

Postby recliq » Sun May 11, 2014 6:15 am

Apps are separate from firmware, updating firmware will change nothing!

To remove the app.bin (residing on your usb drive) simply connect it to a computer and delete the respecting app.bin files, then reconnect to wdtv, reboot and install from WAM the latest versions.
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

Re: MINIDLNA 1.1.2!!!!! 4/8/2014   

Postby petermg » Sat May 17, 2014 4:05 pm

teddychn wrote:Bye the way, I just tried to execute
# minidlna -R

and get the message below:
minidlna: /lib/libjpeg.so.62: no version information available (required by minidlna)

It seems that's something abnromal.


I have always got that error message even with the version from a couple years ago. Still works for me however. I don't know why both versions gave me that error.
petermg
WDTVer
 
Posts: 41
Joined: Sat Jun 04, 2011 6:17 pm

Re: MINIDLNA 1.1.2!!!!! 4/8/2014   

Postby teddychn » Sun May 18, 2014 1:35 am

I think I have tried all I could do for several times except roll back to original 0.5.1.1.
I wished to roll back to original firmware because this situation happened after I
upgrade Minidlna in Addon-Manager.

So far I could only get one blank folder from my harddisk which conatin music database.
But today there's a intresting thing happened. I transfer two folder of music from PC to
the harddisk which connected to WDTV. After the transfer completed, the two folder
could be seen by DLNA client.

Below the my Settings of Minidlna, I wish threre's something wrong..

port=8200
media_dir=A,/tmp/media/usb/USB2/0EC0ED9DC0ED8AF3/Audio

friendly_name=WDLXTV MiniDLNA Server
db_dir=/tmp/minidlna/
log_dir=/tmp/minidlna/
log_level=general,artwork,database,inotify,scanner,metadata,http,ssdp,tivo=warn
album_art_names=Cover.jpg/cover.jpg/AlbumArtSmall.jpg/albumartsmall.jpg/AlbumArt.jpg/albumart.jpg/Album.jpg/album.jpg/Folder.jpg/folder.jpg/Thumb.jpg/thumb.jpg
inotify=yes
enable_tivo=no
strict_dlna=no
notify_interval=900
model_number=1
root_container=.
teddychn
Donor
 
Posts: 27
Joined: Tue Jan 25, 2011 10:56 pm

Re: MINIDLNA 1.1.2!!!!! 4/8/2014   

Postby custard » Thu May 22, 2014 2:30 pm

I can't see anything in your settings which point to a video directory...
Your settings are for audio files only.

I think you will either need to add an extra line pointing to the video directory or if audio and video are in the same folder then use one universal directory without 'media_dir=A' like mine below.

Your datatabase and logfile should also not be pointing at tmp/minidlna as you will use up memory on the wdtv.

Code: Select all
port=8200
media_dir=/tmp/mnt/506C936D6C934D1A
friendly_name=WDLXTV MiniDLNA Server
db_dir=/tmp/mnt/506C936D6C934D1A
log_dir=/tmp/mnt/506C936D6C934D1A
log_level=general,artwork,database,inotify,scanner,metadata,http,ssdp,tivo=warn
album_art_names=Cover.jpg/cover.jpg/AlbumArtSmall.jpg/albumartsmall.jpg/AlbumArt.jpg/albumart.jpg/Album.jpg/album.jpg/Folder.jpg/folder.jpg/Thumb.jpg/thumb.jpg
inotify=yes
enable_tivo=no
strict_dlna=no
notify_interval=895
model_number=WDTV
root_container=.
custard
Donor
 
Posts: 46
Joined: Wed Dec 29, 2010 1:19 am

Re: MINIDLNA 1.1.2!!!!! 4/8/2014   

Postby teddychn » Tue Jun 03, 2014 4:57 am

Yes, I only use DLNA for music playing. I play video files with remote controller
or via NFS network sharing.
teddychn
Donor
 
Posts: 27
Joined: Tue Jan 25, 2011 10:56 pm

Re: MINIDLNA 1.1.2!!!!! 4/8/2014   

Postby custard » Tue Jun 03, 2014 11:29 am

I see, I mistakenly thought that you could not access videos.

In that case i can only think that the minidlna is not carrying out a rebuild at start time due to you using tmp/media/usb instead of tmp/mnt.
Also the use of tmp/mindlna for your database probably means that the database is being deleted each time you reboot.

I would advise:
1) Make sure 'force minidlna rebuild' is selected
2) Change your audio directory to using tmp/mnt/.....
3) create a mnt. file in that directory from the webend
4) Change the storage of the db to tmp/mnt/........
5) reboot
custard
Donor
 
Posts: 46
Joined: Wed Dec 29, 2010 1:19 am

Re: MINIDLNA 1.1.2!!!!! 4/8/2014   

Postby teddychn » Sat Jun 07, 2014 5:48 pm

I tried all the steps, but the issue is still there. Actually, I have tried these
countermeasures several times.

Before I updated the minidlna, all the folder could be found on DLNA clinet's
file browser. But now, mostly only one or two folder could be seen. And all
the flac fies didn't be listed.

I found some strange things, but cannot get any conclusion:
1. run "minidlna -R" will get "minidlna: /lib/libjpeg.so.62: no version information available (required by minidlna)" message
2. Some time, there's "received signal 15" message as below. But even I tried to scan some folder without this message.
I still could get only one folder listed.
[2014/06/08 08:55:29] minidlna.c:354: warn: Creating new database at /tmp/mnt/0EC0ED9DC0ED8AF3/.minidlna_data/files.db
[2014/06/08 08:55:30] minidlna.c:1039: warn: HTTP listening on port 8200
[2014/06/08 08:55:34] scanner.c:702: warn: Scanning /tmp/mnt/0EC0ED9DC0ED8AF3/Audio/MUSIC_HQ/[ CLASSICAL ]
[2014/06/08 09:07:52] minidlna.c:153: warn: received signal 15, good-bye

3. I tried to scan a category folder with all mp3 files. It's fine.
4. I tried to scan a mp3 category folder which named with brackets "[ ]" without success. But it worked fine if I remove the brackets.
5. One folder with unicode folder name couldn't be scanned successfully. It could be resolved with renaming the folder name to normal character,
although the sub-directory names and files are named with unicode.
6. Although the unicode named folder/subfolder could be browsed on DLNA client, the filenames are still browsed with scrambled code. But they
could be played well.

The above are the all that I noticed.
Last edited by teddychn on Sat Jun 07, 2014 9:38 pm, edited 1 time in total.
teddychn
Donor
 
Posts: 27
Joined: Tue Jan 25, 2011 10:56 pm

PreviousNext

Return to WDLXTV-G2 & WDLXTV-Live/Plus app.bins

Who is online

Users browsing this forum: No registered users and 2 guests