Page 22 of 23

Re: **UPDATE-Transmission 2.20 standard/lightweight

PostPosted: Sun Apr 12, 2015 12:29 pm
by recliq
Link to repository? No problem: LINK
But what about installing from WAM, that's what the repository is for... :mrgreen:

Re: **UPDATE-Transmission 2.20 standard/lightweight

PostPosted: Tue Apr 14, 2015 8:51 am
by kroetkroet
Haha, I completely forgot about the WAM! What a nice stuff is there!

Unfortunately, this n00b didn't succeed in installing 2.84:

Installing Transmission v2.84 from Main on sdb1... Loading FAILED!


That's all I got from the WAM - trying manual install on USB, long live old skool :lol:

Re: **UPDATE-Transmission 2.20 standard/lightweight

PostPosted: Tue Apr 14, 2015 9:12 am
by recliq
I have to admit I haven't tested installing from WAM... :oops: Will check that if I find some time.

I reproduced it here, most likely you get the "failed" message when transmission is not enabled yet in config... I will try to change that.
However the app is loaded, just transmission fails to start, so the WAM message is misleading...

I noticed nother bug in the init script, it doesn't activate the webend plugin correctly as it seem, you need to execute load.webplugins on shell or reboot, will fix that as well.

Re: **UPDATE-Transmission 2.20 standard/lightweight

PostPosted: Tue Apr 14, 2015 11:52 pm
by kroetkroet
That's why you'd have a bunch of idiotproof betatesters at your disposal :lol:

Indeed, I got it working too by twerking some bits around - the "failed" should indeed have been replaced by a "warning: please set transmission_workingdir in webend". :ugeek: The installation worked flawless, but starting the service was more painful :mrgreen:

In the end, transmission worked fine, speed seems better than rtorrnent, but I definitely like the "black list" and "scheduling" features!

Thanks recliq, you made my day :D

Re: **UPDATE-Transmission 2.20 standard/lightweight

PostPosted: Mon Apr 27, 2015 9:56 pm
by fguy
hi recliq
thanks for this. i've just updated from the transmission 2.03 to the 2.84 version & have come across a small bug.

in the settings i want to disable the incomplete downloads directory but whatever i do it gets re-enabled after the transmission daemon is restarted (i have setup my wdtv to turn off the daemon when i watch movies as it would freeze up if i left it on. so i turn on/off the transmission daemon often). strange thing is that is the only setting that doesnt stick. i have changed port/dht etc & they all stick but not this setting. i also tried manually editing the "incomplete-dir-enabled" setting to false in the settings.json but no go.

would appreciate your help in this matter

thanks

i'm on 1.02.21 0.5.0.0 flashed version btw

Re: **UPDATE-Transmission 2.20 standard/lightweight

PostPosted: Tue Apr 28, 2015 8:45 am
by recliq
I think it might be related to the init script I supplied, it starts transmission explicitly with --incomplete-dir
I guess that's what overrides your config changes on each restart...
Code: Select all
<snip>
            CONF_DIR="${TRANSMISSION_DIR}/.config"
            TEMP_DIR="${TRANSMISSION_DIR}/download"
            DOWN_DIR="${TRANSMISSION_DIR}/complete"
            WATCH_DIR="${TRANSMISSION_DIR}/watch"
<snip>
/apps/transmission/bin/transmission-daemon --allowed $ALLOWED --pid-file /tmp/transmission.pid --logfile /tmp/transmission.log $LOG --watch-dir $WATCH_DIR --incomplete-dir $TEMP_DIR --download-dir $DOWN_DIR --config-dir $CONF_DIR
<snip>

So, it's not a bug more a feature, you just configure your transmission dir and the app assumes to use the subdirs complete, incomplete and watch. Otherwise users would have to set three config entries instead of one now and it's not that "noob-proof".

Is there a reason why you don't want to use the incomplete dir atall? Maybe I will add a config option to enable/disable incomplete dir...
another option would be to start transmission only with the --conf-dir setting if a config file already exists, I think that would be the best solution, so can edit your config file to suit your needs once it is created with the relevant defaults.

Re: **UPDATE-Transmission 2.20 standard/lightweight

PostPosted: Tue Apr 28, 2015 9:21 am
by fguy
Is there a reason why you don't want to use the incomplete dir atall?


my hdd is partitioned & most are always full near capacity :oops: so i put things to download in different partitions depending on the size of the torrent i'm downloading. with the incomplete dir setting it always downloads to that folder while i'd rather it download to particular folders

Maybe I will add a config option to enable/disable incomplete dir... another option would be to start transmission only with the --conf-dir setting if a config file already exists, I think that would be the best solution, so can edit your config file to suit your needs once it is created with the relevant defaults.


how would i go about doing that ? coz the all the transmission app files are non-editable right?

Re: **UPDATE-Transmission 2.20 standard/lightweight

PostPosted: Tue Apr 28, 2015 2:51 pm
by fguy
i tried a few work arounds to start transmission with the --conf-dir setting but since the /apps/transmission/etc/init.d/S99transmission is in a read only FS & always overwrites the config file on startup havent been able to figure it out

does the 2.52 version have the same issue?

Re: **UPDATE-Transmission 2.20 standard/lightweight

PostPosted: Wed Apr 29, 2015 9:13 am
by kroetkroet
Recliq, found an inconsistancy in naming convention regarding transmission - I wanted to connect with another pc to the transmission webend: got an rpc-whitelist setting error (in settings.json). Hardcare as I am, updated the file with the new ip address, poofff, got reset by something, which seemed to be the (du'h) /conf/config. In there, someone used the name "TRANSMISSION_ALLOWED", I think it would be more fun to have it named TRANSMISSION_RPC_WHITELIST or something similar.
What do you think?
Kr!
KK

Re: **UPDATE-Transmission 2.20 standard/lightweight

PostPosted: Wed Apr 29, 2015 9:22 am
by recliq
I think so, since it was built by me as well...

It's not that easy to change for you, you would have to copy the init script to usb, modify it and bind mount it over the existing one on every boot...

but check out WAM, there should be an update available... :mrgreen:

Let me know if this fix helps.
:ugeek: