Sign up here and you can log into the forum!

**UPDATE-Transmission 2.20 standard/lightweight

Here is the place to inquire about app.bins--Only currently available apps for sigma 8655 based wdtv's belong in this forum. requests go in 'Application Questions'

**UPDATE-Transmission 2.20 standard/lightweight   

Postby player_sct » Tue May 04, 2010 9:24 am

Hello to all

First - sorry for my english.

I upgrade "playdude" Transmission pack from 1.7 to 1.92 and try add to web frontend. You can start/stop daemon from Plugin Daemon's section. Unfortunatelly after click on transmission icon web gui is not work. Main screen started and after that stop with "connection failed" .Details of this error is 404. My knowledge about html and php is near zero and i need help from you guys to repair this. Tested with 0.4.2.0 version of firmware and ext3 version.

Installation:
Put transmission.app.bin in the root of a USB hard drive or flashdrive, restart your wd tv live and transmission should
start at boot time.

To access transmission web gui, use this link:

http://WDTV-IP-ADDRESS:9091

Replace WDTV-IP-ADDRESS with the real IP address of your wdtv.

Remember to change download path in settings!!!

Download Transmission 1.92 and info -> http://szkielkoioko.xsk.pl/transmission-1-92-dla-wd-tv-live/

20.06.2010

Download new Transmission 2.0

07-08-2010

Download new Transmission 2.03

02-01-2011

Download new Transmission 2.13

02-02-2011

Download new Transmission 2.20 beta 3
Read info about it http://forum.wdlxtv.com/viewtopic.php?f=40&t=344&start=70#p27180

17-02-2011

Download new Transmission 2.20 Standard/Lightweight
Read info about it http://forum.wdlxtv.com/viewtopic.php?f=40&t=344&p=28374#p28374
Last edited by player_sct on Thu Feb 17, 2011 9:10 am, edited 12 times in total.
User avatar
player_sct
Beta Tester
 
Posts: 90
Joined: Sun Apr 11, 2010 6:29 am
Location: Poland

Re: Transmission 1.92   

Postby derlinuxer » Mon May 10, 2010 5:48 am

Hi player_sct,

nice work!
Here a quick and dirty solution:

add a index.php in the web directory for your small problem with web integration:
Code: Select all
<?php
$SERVER_IP=$_SERVER['SERVER_ADDR'];
header("Location: http://$SERVER_IP:9091/");
exit;
?>


and change webend.conf (TARGET) to index.php.

derlinuxer
User avatar
derlinuxer
Developer
 
Posts: 66
Joined: Thu Apr 15, 2010 5:01 am

Re: Transmission 1.92   

Postby player_sct » Mon May 10, 2010 10:59 am

Derlinuxer you are great!!!

Tomorrow in work i upgrade transmission to from 1.92 to 1.93 and include your index.php.

Thanks!!!!
User avatar
player_sct
Beta Tester
 
Posts: 90
Joined: Sun Apr 11, 2010 6:29 am
Location: Poland

Re: Transmission 1.92   

Postby derlinuxer » Mon May 10, 2010 11:56 am

you are welcome! :D
User avatar
derlinuxer
Developer
 
Posts: 66
Joined: Thu Apr 15, 2010 5:01 am

Re: Transmission 1.92   

Postby derlinuxer » Mon May 10, 2010 12:09 pm

small another think I found.
If you stop the daemon via webend the daemon status (left side) will
not be updated (go to red icon) if you close small window to fast. Web side will be reloaded on closing the small window.
If the daemon already running at this time the status icon will be still green.
If you add the sleep line below, the stop request will return later.
5 sec should be enough.

Code: Select all
.. 
  killall transmission-daemon           
  sleep 5                               
else
..
User avatar
derlinuxer
Developer
 
Posts: 66
Joined: Thu Apr 15, 2010 5:01 am

Re: Transmission 1.92   

Postby player_sct » Fri May 14, 2010 10:20 am

Transmission 1.93 is ready

Changes:

- upgrade transmission to version 1.93
- remove useless libraries
- enable and add level1 ip blocklist
- add sleepline to init script (thx to derlinuxer)

Unfortunatelly webend integration still not work :( This version was tested under 0.4.2.0 B-rad's firmware.

Derlinuxer - your index.php don't work :( After modyfication webend.conf and add index.php - if I click in transmission icon in mozilla, new window will open stay clear and nothing happen.

Download: http://szkielkoioko.xsk.pl/wp-content/uploads/2010/05/transmission193.zip
User avatar
player_sct
Beta Tester
 
Posts: 90
Joined: Sun Apr 11, 2010 6:29 am
Location: Poland

Re: Transmission 1.92/1.93   

Postby derlinuxer » Fri May 14, 2010 12:31 pm

hi player_sct,

mmmm... sounds crazy.
My modifications working fine here with your new version too.
I send you modified app.bin so you can test it on your system.
I'll send you download link via PM.
User avatar
derlinuxer
Developer
 
Posts: 66
Joined: Thu Apr 15, 2010 5:01 am

Re: Transmission 1.92/1.93   

Postby player_sct » Sun May 16, 2010 11:27 am

Fast fix from Derlinuxer :)

Now web frontend integration fully work :) Big thanx to derlinuxer for his help :))

Download: Transmission 1.93.1
User avatar
player_sct
Beta Tester
 
Posts: 90
Joined: Sun Apr 11, 2010 6:29 am
Location: Poland

Re: Transmission 1.92/1.93   

Postby derlinuxer » Thu May 20, 2010 1:09 am

hi player_sct,

the open issue with stopping daemon via webend:
you can change the stop section in init script like this:
Code: Select all
stop)                                                                       
if [ -n "$PID" ]; then                                                       
  echo "stopping transmission-daemon..."                                     
  killall transmission-daemon                                               
  for i in `seq 1 30` ; do                                                   
      [ -z "`pidof transmission-daemon`" ] && exit 0                                     
      sleep 3                                                               
  done                                                                       
else                                                                         
  echo "transmission-daemon not running."           
fi                                                 
;;

So stop request will return if the process is really gone.
It's just a cosmetic, not needed to create a new package now.

derlinxer
User avatar
derlinuxer
Developer
 
Posts: 66
Joined: Thu Apr 15, 2010 5:01 am

Re: Transmission 1.92/1.93   

Postby derlinuxer » Fri May 21, 2010 2:55 am

Hi,

transmission-deamon brings dmaosd in trouble.
After some times start playing video or audio files isn't possible.
OSD shows the same behavior like changing system time after start dmaosd.

Can anyone (OSD-Crack) say if something of following actions of transmission brings osd to give up.

Code: Select all
Jan  1 01:11:47 WDTVLIVE daemon.info transmission-daemon: Blocklist "level1.bin" updated with 224589 entries (blocklist.c:315)
Jan  1 01:11:47 WDTVLIVE daemon.info transmission-daemon: Blocklist "level1.bin" contains 224589 entries (blocklist.c:110)
Jan  1 01:11:47 WDTVLIVE daemon.info transmission-daemon: Transmission 1.93 (10621) started (session.c:609)
Jan  1 01:11:47 WDTVLIVE daemon.info transmission-daemon: RPC Server Adding address to whitelist: *.*.*.* (rpc-server.c:772)
Jan  1 01:11:47 WDTVLIVE daemon.info transmission-daemon: RPC Server Serving RPC and Web requests on port 9091 (rpc-server.c:945)
Jan  1 01:11:47 WDTVLIVE daemon.info transmission-daemon: RPC Server Whitelist enabled (rpc-server.c:949)
Jan  1 01:11:47 WDTVLIVE daemon.info transmission-daemon: DHT Reusing old id (tr-dht.c:365)
Jan  1 01:11:47 WDTVLIVE daemon.info transmission-daemon: DHT Bootstrapping from 49 nodes (tr-dht.c:146)
Jan  1 01:11:47 WDTVLIVE daemon.info transmission-daemon: Port Forwarding (NAT-PMP) initnatpmp succeeded (0) (natpmp.c:67)
Jan  1 01:11:47 WDTVLIVE daemon.info transmission-daemon: Port Forwarding (NAT-PMP) sendpublicaddressrequest succeeded (2) (natpmp.c:67)
Jan  1 01:11:47 WDTVLIVE daemon.info transmission-daemon: Using settings from "/apps/transmission/config" (daemon.c:425)
Jan  1 01:11:47 WDTVLIVE daemon.info transmission-daemon: Saved "/apps/transmission/config/settings.json" (bencode.c:1651)
Jan  1 01:12:55 WDTVLIVE daemon.info transmission-daemon: Port Forwarding State changed from "Not forwarded" to "Starting" (port-forwarding.c:87)
Jan  1 01:12:55 WDTVLIVE daemon.info transmission-daemon: Port Forwarding State changed from "Starting" to "???" (port-forwarding.c:87)
Jan  1 01:13:04 WDTVLIVE daemon.info transmission-daemon: Blocklist "level1.bin" contains 224589 entries (blocklist.c:110)

User avatar
derlinuxer
Developer
 
Posts: 66
Joined: Thu Apr 15, 2010 5:01 am

Next

Return to WDLXTV-G2 & WDLXTV-Live/Plus app.bins

Who is online

Users browsing this forum: No registered users and 2 guests