Page 7 of 22

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)

PostPosted: Fri Jan 14, 2011 8:15 am
by Tim
I have now tryed mlpayer lite and others and it does the exact same thing as plugplayer, so i just thought the folder orienation
had something to do with mini dlna.

This is one of my directories /tmp/media/usb/USB2/Ser#/Movies. In the configuration of minidlna.
Works great but when i put a bunch of differnet directories it just combines all of them.

When clicking folders on my controller it just shows all shows. Anyone had the same problem ?

Thanks

Tim

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)

PostPosted: Fri Jan 14, 2011 6:17 pm
by RMerlin
I just tried with MLPlayerLite with my ipod Touch, and all my videos are still in their hierarchical folder organization. I shared a folder called Live on my desktop, which contains two folders (COmedy and Music). Music contains sub-folders for some shows as well as some other shows inside itself.

At the root:
Image
Inside Video:
Image
Inside Folders:
Image
Inside Music
Image

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)

PostPosted: Fri Jan 14, 2011 6:27 pm
by Tim
Wow thanks for researching this !

You know i can do exactly the same steps and when i click on folders it list everything i have in the minidlna directory san box
all movies from all the folders on the usb drives in one big file , no folders or sub folders.

So crazy. I am trying to get it figured.

I have a movie folder, western folder on the usb drives etc. etc..

But when viewing under folders it shows everything just like i selected all video.

Tim

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)

PostPosted: Fri Jan 14, 2011 7:05 pm
by Tim
Ok so now i selected my computer instead of the wdlxtv minidlna server and yes it works fine with that, so i do believe it is in the minidlna server, do
you think i am missing a setting or something, obviously it reads all my directories from the usb drives fine.

Thanks

Tim

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)

PostPosted: Fri Jan 14, 2011 8:09 pm
by RMerlin
Tim wrote:Ok so now i selected my computer instead of the wdlxtv minidlna server and yes it works fine with that, so i do believe it is in the minidlna server, do
you think i am missing a setting or something, obviously it reads all my directories from the usb drives fine.

Thanks

Tim


You could try forcing it to rebuild your video database (it's an option on the MiniDLNA config page) in case your database somehow has the wrong path information.

Otherwise, there's not much to be configured. I only entered one test path in my config, without specifying the media type.

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)

PostPosted: Fri Jan 14, 2011 10:50 pm
by Tim
You could try forcing it to rebuild your video database (it's an option on the MiniDLNA config page) in case your database somehow has the wrong path information.

Otherwise, there's not much to be configured. I only entered one test path in my config, without specifying the media type.



I actually do have that setting on. And i do not specify media type either, i just put in lines like these /tmp/media/usb/USB1/Ser#/Movies
/tmp/media/usb/USB2/Ser#/Westerns
And those names movies,westerns etc.. will not come up in the folders option.

Oh well, thanks very very much. I will continue working on this issue. If i cannot resolve i will have to live with it. Sucks though
because tv shows,movies,etc. etc.. is blended in one big folder, i am surprises no one else has had this problem.

Take Care

Tim

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)

PostPosted: Mon Jan 17, 2011 11:48 am
by mwennervaldt
I got an odd problem with this app using FW 1.02.21-WDLXTV-Live-0.4.5.3 [flash]

Using Zappo tv as client all my movies shows up with a video file icon but it says the format is jpg. When loading the movie it just shows the movie's thumbnail.
For my dvd rips (Video_ts folder) the thumbnail is at the same folder level as the video_ts, and therefore not in same folder as the actually movie vob fileset. And these show up with video file icon and as mpeg files and plays just fine.
So i tried deleting the thumbnails of some movies, and after a miniDLNA reboot the movies show up with the correct format and plays just fine.
I Guess for me that this problem is due to the two files has the same name ex. 300.avi - 300.jpg
Exactly the same issue with other clients as 8player and Media Link player Lite.

Anybody else experiencing this problem.? any solution/workaround.?

And also thanks so much for this app. :D It's great for my music.

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)

PostPosted: Tue Jan 18, 2011 8:09 am
by Tim
I actually do have that setting on. And i do not specify media type either, i just put in lines like these /tmp/media/usb/USB1/Ser#/Movies
/tmp/media/usb/USB2/Ser#/Westerns
And those names movies,westerns etc.. will not come up in the folders option.

Oh well, thanks very very much. I will continue working on this issue. If i cannot resolve i will have to live with it. Sucks though
because tv shows,movies,etc. etc.. is blended in one big folder, i am surprises no one else has had this problem.



Well after a few days of brain storming i figured it out, i guess i did not get it. Now i understand that the folders on the usb drives are not really seen as folders to minidlna, they are more like directories. Once i created folders within them they came up instantly on my iphone, it is fantastic. Solved my own problem.

Take Care

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)

PostPosted: Thu Feb 03, 2011 12:53 pm
by worm9110
Thanks RMerlin for this little gift. I went this route because I was having problems using network shares with Samba between 2 WDLX live boxes. Unfortunately I am running into a little trouble and was hoping you or someone can help me out. My log is posted below, if you look at the end the .../Music directory never completes thus I do not see all my songs. I have let it run for hours and still no completion. I only have about 100 songs in the directory, some .mp3, .wav, .flac files. Also I have another directory that contains a lot of videos files, when I add it to be scanned after 1 minute or so my whole WDLX freezes and I have to reboot by pulling the power cord out. Any thoughts.

[2000/01/01 00:26:39] minidlna.c:770: warn: Starting MiniDLNA version 1.0.18.2 [SQLite 3.5.9].
[2000/01/01 00:26:39] minidlna.c:793: warn: Creating new database...
[2000/01/01 00:26:39] minidlna.c:858: warn: HTTP listening on port 8200
[2000/01/01 00:26:39] scanner.c:724: warn: Scanning /tmp/mnt/EE7EB0C67EB0893B/TV
[2000/01/01 00:27:10] scanner.c:792: warn: Scanning /tmp/mnt/EE7EB0C67EB0893B/TV finished (24 files)!
[2000/01/01 00:27:10] scanner.c:724: warn: Scanning /tmp/mnt/EE7EB0C67EB0893B/Music

EDIT: Found this thread and it looks to be a problem. Don't know if this helps or not.
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=84881&postdays=0&postorder=asc&start=30

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)

PostPosted: Thu Feb 03, 2011 5:03 pm
by RMerlin
ffmpeg's code is known to be poorly resilient to malformed/corrupted files. Can you see if you can isolate which file is causing it to crash (try by splitting your scanning in half, until you can narrow it down)?

I might eventually recompile MiniDLNA with newer ffmpeg code (I don't remember which version I used back then), see if it helps with those specific files.

Also, make sure your database is located on a USB disk, and not in /tmp or /conf.