Page 20 of 22

Re: MiniDLNA 1.0.24 - 1.7 (18-Feb-2012)

PostPosted: Tue Jun 26, 2012 6:18 am
by wassup
Hi people,

I seem to be having some issues with miniDLNA again. Running Using 1.05.04-Live-0.5.1.1. Getting the below error.

Code: Select all
Starting minidlna
sh: /tmp/media/usb/USB1/ED79-DDD6/.minidlna_data: unknown operand
ln: /tmp/minidlna: File exists
ln: /tmp/minidlna: File exists
Starting MiniDLNA...
/apps/minidlna/bin/minidlna: /lib/libjpeg.so.62: no version information available (required by /apps/minidlna/bin/minidlna)
[1999/12/31 16:06:50] utils.c:260: warn: make_dir: cannot create directory '/tmp/minidlna'
[1999/12/31 16:06:50] minidlna.c:527: fatal: Database path not accessible! [/tmp/minidlna]
config saved val:key => (PLUGIN_WEBDIRS,nzbgetweb|/usr/share/nzbgetweb,rtorrent|/usr/share/rutorrent,umsp|/usr/share/umsp)
config saved val:key => (PLUGIN_WEBDIRS,nzbgetweb|/usr/share/nzbgetweb,rtorrent|/usr/share/rutorrent,umsp|/usr/share/umsp,minidlna|/apps/minidlna)
Done

Re: MiniDLNA 1.0.24 - 1.7 (18-Feb-2012)

PostPosted: Thu Jun 28, 2012 4:25 am
by wassup
Anybody there? Help please?? I really want this to work. :(

Re: MiniDLNA 1.0.24 - 1.7 (18-Feb-2012)

PostPosted: Thu Jun 28, 2012 5:57 am
by RMerlin
wassup wrote:Anybody there? Help please?? I really want this to work. :(


Read the first post, first line under "Known issues".

Re: MiniDLNA 1.0.24 - 1.7 (18-Feb-2012)

PostPosted: Thu Jun 28, 2012 10:30 am
by wassup
The first line of known issues says

"You CANNOT use a location in /tmp/media/usb/USB* if you expect this to start at boot. You MUST enable early mounting (.mnt) from the webend."

I believe this mentions about the location of my media? But I'm unable to start miniDLNA. After I download it from the addons manager, I try to start it by clicking under plugin daemons, but receive the error mentioned in my previous post. And when I reboot wdlxtv, then I see this in the webend page of WDLXTV configuration under Installed apps tab.

Code: Select all
Installed applications:
ffmpeg <unknown version>
minidlna <unknown version>


Also, I did enable early mounting of my drives and use the location /tmp/mnt/* for my media.

Thanks for your patience and suggestions but please let me know what I'm doing wrong.

Re: MiniDLNA 1.0.24 - 1.7 (18-Feb-2012)

PostPosted: Thu Jun 28, 2012 1:59 pm
by RMerlin
Code: Select all
sh: [b]/tmp/media/usb/USB[/b]1/ED79-DDD6/.minidlna_data: unknown operand


You have something using that path. Could be your database location.

Re: MiniDLNA 1.0.24 - 1.7 (18-Feb-2012)

PostPosted: Fri Jun 29, 2012 6:31 pm
by wassup
Hmm.. I did not understand what you said. But I changed the USB flash drive in which the apps were loaded. I plugged in another HDD and its now starting flawlessly. So the issue seems to be with the flash drive. Any workaround for this? I can't keep this HDD plugged in at all times, so it would be very helpful if I can get the flash drive working. I even tried formatting the flash drive but did not work.

Re: MiniDLNA 1.0.24 - 1.7 (18-Feb-2012)

PostPosted: Tue Jul 03, 2012 12:24 pm
by ssfcu
I just want to say thanx, love the addon, works smooth on android and ipad also.

Re: MiniDLNA 1.0.24 - 1.7 (18-Feb-2012)

PostPosted: Tue Dec 11, 2012 8:14 pm
by crrrum
Hello merlin (or someone just as knowledgeable),

I've been running one of the older firmwares and older version of minidlna for some time. Things kind of stopped working recently, thought perhaps it was related to some new files I added in my video directory.

I've upgraded to 0.5.1.1 and upgraded minidlna through the add-on manager (including ffmpeg). When I browse to my specified ip for wdlxtv http://192.168.1.50:8200 I get the main page specifying number of pictures, videos and music as expected. However I can't get any devices to recognize that wdlx is on the network and has minidlna running on it. I use Skifta on my android and thats not picking it up but its picking up the video on my Windows box no problem.

I do see that if I do not specify video only for my dir I do get this on minidlna startup (but not in minidlna.log):
/apps/minidlna/bin/minidlna: /lib/libjpeg.so.62: no version information available (required by /apps/minidlna/bin/minidlna)

Are there any simple troubleshooting steps I can take? Is minidlna actually running? or is the above ip and port informational only? I'm pretty sure my uPnP is working as I believe my Verizon wireless router for FIOS has it on by default and I've checked to see that its enabled.

Any help obviously greatly appreciated! And thanks for an awesome app!

crrrum

Re: MiniDLNA 1.0.24 - 1.7 (18-Feb-2012)

PostPosted: Tue Dec 11, 2012 8:23 pm
by crrrum
ugh, never mind found the issue is with the verizon router. It auto-updated on me and made some changes to its defaults.

Re: MiniDLNA 1.0.24 - 1.7 (18-Feb-2012)

PostPosted: Mon Apr 22, 2013 9:56 am
by sonic_blue
Hello

Is there any way to stop MiniDLNA from rebuilding files.db on every boot? I have unchecked the box on WEC, and I've tried changing the MINIDLNA_DBPATH to /tmp/mnt/562807EF2807CCC5/.minidlna_data_2 , but it keeps getting deleted and rebuilt on every reboot, which takes about 10 minutes to rebuild the files.db file, because I have around 10,000 audio files to share. I am running 1.02.21 0.5.1.1 flash.

Code: Select all
1999/12/31 16:01:19] minidlna.c:889: warn: Starting MiniDLNA version 1.0.24 [SQLite 3.5.9].
[1999/12/31 16:01:20] minidlna.c:912: warn: Creating new database...
[1999/12/31 16:01:27] minidlna.c:927: warn: Failed to clean old file cache.
[1999/12/31 16:01:28] minidlna.c:989: warn: HTTP listening on port 8200
[1999/12/31 16:01:28] scanner.c:727: warn: Scanning /tmp/mnt/562807EF2807CCC5/Audio


It seems the problem is "failing to clean old file cache". Any ideas what could be causing this?