Sign up here and you can log into the forum!

MiniDLNA 1.0.24 - 1.7 (18-Feb-2012)

Here is the place to inquire about app.bins--Only currently available apps for sigma 8655 based wdtv's belong in this forum. requests go in 'Application Questions'

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)   

Postby RMerlin » Tue Nov 23, 2010 6:56 am

MiniDLNA doesn't generate thumbnails from videos. It merely look for the existence of one of the supported thumbnail files (folders.jpg, etc...) and links to it, therefore it doesn't require much CPU.

Crashing while scanning is a common problem with many DLNA servers. It's usually caused by a corrupted file that causes the ffmpeg library to crash. You will have to locate the file and remove it.
WDLXTV Webend maintainer. Visit http://www.lostrealm.ca/wdlxtv to see my other WDLXTV projects.
If you like my work, please consider donating.
User avatar
RMerlin
WDLXTV Team
 
Posts: 3236
Joined: Sat Jun 26, 2010 9:25 am
Location: Montreal, Canada

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)   

Postby extremedigital » Tue Nov 23, 2010 12:27 pm

nice work as soon as i am done playing with the new 1.04.10 firmware and revert back this is first on my list to try out.....thank you
extremedigital
Global Moderator
 
Posts: 218
Joined: Thu Apr 08, 2010 7:48 am

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)   

Postby mrp1234 » Sat Dec 04, 2010 1:34 pm

Hello RMerlin,
MiniDLNA works ok for me, I use as a client a Sony TV. Unfortunately I have to start the program after each boot manually. I’m not able to figure out why rcS during boot is not able to start the init.d/S75minidlna (I'm on 4.3.1. and I have enabled the app for next reboot). Also It does not appear in messages.txt.
Any idea?
mrp1234
WDTVer
 
Posts: 20
Joined: Fri Jun 11, 2010 4:36 am

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)   

Postby RMerlin » Sat Dec 04, 2010 1:57 pm

Maybe you are trying to serve content from a disk that isn't mounted yet. Try creating an empty .mnt file on the location of your medias, and make sure you access it through its correct path - that could help.

You can confirm whether minidlna is running or not by checking through the webend.
WDLXTV Webend maintainer. Visit http://www.lostrealm.ca/wdlxtv to see my other WDLXTV projects.
If you like my work, please consider donating.
User avatar
RMerlin
WDLXTV Team
 
Posts: 3236
Joined: Sat Jun 26, 2010 9:25 am
Location: Montreal, Canada

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)   

Postby mrp1234 » Mon Dec 06, 2010 12:17 pm

@RMerlin
OK, you are absolutely right. I changed the app.bin to another media and now it starts up at boot time :)
What I observed is that during the creation of the Album Artwork cache sometimes the directory structure or the created files gets corrupt. It’s not possible to remove the files via “rm”. I have to detach the drive (NTFS) and delete them with the PC. This happens with specific MP3 files, after removing them from the path to be scanned, then the art work cache is created fine. (MiniDLNA rebuilds the cache and is able as the first step to remove the art_cache directory with success.)
If you like I can pass you a mp3 file which provokes this behavior.
Regards.
mrp1234
WDTVer
 
Posts: 20
Joined: Fri Jun 11, 2010 4:36 am

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)   

Postby RMerlin » Mon Dec 06, 2010 12:37 pm

What happens when you try to remove such a file with "rm"?

I bet it has to do with some special characters part of the filename that require escaping when trying to delete from the shell, which is normal.
WDLXTV Webend maintainer. Visit http://www.lostrealm.ca/wdlxtv to see my other WDLXTV projects.
If you like my work, please consider donating.
User avatar
RMerlin
WDLXTV Team
 
Posts: 3236
Joined: Sat Jun 26, 2010 9:25 am
Location: Montreal, Canada

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)   

Postby mrp1234 » Tue Dec 07, 2010 11:51 am

Unfortunately I’m not able to reproduce. Of course, the filename had some special characters, like “[“. I ran a bulk rename tool over my music collection. Hope that this helps. I will continue trying the app, in case of errors I will report.
Anyway, thanks for your quick reply, regards…
mrp1234
WDTVer
 
Posts: 20
Joined: Fri Jun 11, 2010 4:36 am

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)   

Postby RMerlin » Tue Dec 07, 2010 2:27 pm

Then this is normal. [ is a special character in Linux/UNIX, and has to be escaped if you want to do any file manipulation on a file having such a character in its name.
WDLXTV Webend maintainer. Visit http://www.lostrealm.ca/wdlxtv to see my other WDLXTV projects.
If you like my work, please consider donating.
User avatar
RMerlin
WDLXTV Team
 
Posts: 3236
Joined: Sat Jun 26, 2010 9:25 am
Location: Montreal, Canada

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)   

Postby bloodflower » Mon Jan 03, 2011 3:33 am

Hi RMerlin,

I've installed the app.bin but I can't access it through webend..
btw..the access is http://ip_addresswdtv:8200 ..right?

I have FW 0.4.5.3 and I put the app bin in the hard disk attached.
Then I have this config:
- enable MINIDLNA
- Force MiniDLNA to rebuild db at start time.
MINIDLNA_DIRS --> /tmp/media/usb/USB2/325220A852207331/Musica/
MINIDLNA_DBPATH --> /tmp/minidlna
MINIDLNA_LOGPATH --> /tmp/minidlna
the others parameters as default

Thanks for the help!
bloodflower
DLX'er
 
Posts: 96
Joined: Thu May 20, 2010 10:08 pm

Re: MiniDLNA 1.0.18.2_CVS-1.1 (22-Nov-2010)   

Postby RMerlin » Mon Jan 03, 2011 9:02 am

MiniDLNA has no enduser web interface. That URL is used by media devices to communicate through UPNP, not for use through a web browser.
WDLXTV Webend maintainer. Visit http://www.lostrealm.ca/wdlxtv to see my other WDLXTV projects.
If you like my work, please consider donating.
User avatar
RMerlin
WDLXTV Team
 
Posts: 3236
Joined: Sat Jun 26, 2010 9:25 am
Location: Montreal, Canada

PreviousNext

Return to WDLXTV-G2 & WDLXTV-Live/Plus app.bins

Who is online

Users browsing this forum: No registered users and 1 guest

cron