Page 2 of 2

Re: OPENSSH - openssh.app.bin

PostPosted: Thu Sep 08, 2016 2:02 pm
by davo_x1
How to make these work correctly ? I copied to the external USB root folder but after I reboot the SSH daemon seems to be stopped. I can enable it from the config and I see 5.5 as version so it is correctly loading.

Code: Select all
ssh -V
OpenSSH_5.5p1 Debian-5+b1, OpenSSL 0.9.8o 01 Jun 2010


How to enable the SSHD to start automatically after reboot ?

When I reboot I see this line:

Code: Select all
config saved val:key => (SSHD,OFF)

IS this supposed to be there ?

Re: OPENSSH - openssh.app.bin

PostPosted: Thu Sep 08, 2016 10:16 pm
by mad_ady
You can use the webend to turn SSHD on, or via command line:
Code: Select all
config_tool -c SSHD=ON
config_tool -s
config_tool -s

Re: OPENSSH - openssh.app.bin

PostPosted: Fri Sep 09, 2016 8:02 am
by davo_x1
I can enable again the SSH, the only thing is that when I am using the app.bin when I reboot these commands are launched:

Stopping UMSP: done
config saved val:key => (SSHD,OFF)

Stopping UMSP: done
config saved val:key => (SSHD,OFF)
Generating public/private rsa key pair.
open /etc/ssh/ssh_host_rsa_key failed: Read-only file system.
Saving the key failed: /etc/ssh/ssh_host_rsa_key.
shutdown: Saving config...
write to block file OK.

write to block file OK.

Code: Select all
shutdown: Unmounting all overlayed OSD xml & images...
shutdown: Unmounting app.bins / osd.bin / opt.bin / custom images...
shutdown: /apps/virtualkeyboard unmount failed
shutdown: Turning off swapfile...
losetup: /dev/loop11: Device or resource busy
shutdown: loopback destruction failure: /dev/loop11: /tmp/mnt/3d93e48f-8d8d-4cf1-91de-71f790cd87fd/virtualkeyboard.app.bin
losetup: /dev/loop14: No such device or address
shutdown: loopback destruction failure: /dev/loop14: /tmp/mnt/3d93e48f-8d8d-4cf1-91de-71f790cd87fd/.swapfile
shutdown: umount usb based /tmp/media/usb/* & /tmp/media/usb/USB*/*
shutdown: umount /tmp/mnt/*
shutdown: /tmp/mnt/3d93e48f-8d8d-4cf1-91de-71f790cd87fd unmount failed
shutdown: Unmounting all remaining attached devices...
shutdown: Flushing all disk writes...
shutdown: Stopping / spinning down all attached devices...
    /dev/sda: Toshiba   External USB 3.0  0   
Rebooting now!
# Stopping dropbear SSH server: Connection to wdlive closed by remote host.


So it writes the "disable SSH" in the config and then switch off.

I imagine that this is done to prevent a probable conflict between the internal SSH [dropbear ?] and the one external in the app.bin

Is the solution is to re-enable the SSH on each boot via a script ?

Re: OPENSSH - openssh.app.bin

PostPosted: Wed Sep 14, 2016 12:20 am
by mad_ady
To be frank I've never used it and don't know what it tries to do... If you can enable it in S00custom-options, then, sure...