Sign up here and you can log into the forum!

Beta firmwares available (0.5.2.1) - Beta testers needed!

General homebrew discussion area

Re: Beta firmwares available (0.5.2.1) - Beta testers needed   

Postby mad_ady » Thu Jan 08, 2015 11:13 pm

The content of the links is changed, so redownload please. Let me know if there are problems with the usual things you use.
User avatar
mad_ady
Developer
 
Posts: 4564
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Beta firmwares available (0.5.2.1) - Beta testers needed   

Postby kroetkroet » Fri Jan 09, 2015 10:37 am

So far so good, rtorrent works, (some) UMSPs work (don't know if they were broken in previous version or not), moviesheets work, and unit responses fast & stable.

Will let it run for the night doing some housekeeping.

PS. for an unknown reason, video-output got reset to composite output, luckily I still had hdmi output and fixed it back to 1080p 50Hz. I remember that one of b-rad's first drops like 5 years ago reset the config file (thus forcing ssh'ing and manually changing the video output) - no idea why it happened now.
WDLXTV-fan! - In case you need further assistance: read our WIKI, search our Forum and most of all: donate 'something' to b-rad for his great efforts!!!
User avatar
kroetkroet
Beta Tester
 
Posts: 1010
Joined: Mon Apr 05, 2010 11:53 pm

Re: Beta firmwares available (0.5.2.1) - Beta testers needed   

Postby mad_ady » Sat Jan 10, 2015 1:43 am

Thanks for the feedback. Are you using wdtvext=on, or off?
I don't know about hdmi output... I'm still on composite :). It shouldn't have changed...
User avatar
mad_ady
Developer
 
Posts: 4564
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Beta firmwares available (0.5.2.1) - Beta testers needed   

Postby distrata » Sat Jan 10, 2015 2:27 am

Hi,
I Just flashed my WD Live withe the beta firmware. I was hoppnig to help you out with the CA Certificates in rtorrent. The box does not boot anymore only the initial screen with the blue WD logo then No hdmi signal, then for a second the wdlxtv firmware is loading and then blank screen. Nothing seems to work from the attached HD or flash drives to the wireless adapter. Any suggestions on how to make it boot again?

Dimitris
User avatar
distrata
WDTVer
 
Posts: 45
Joined: Mon Sep 30, 2013 5:13 am

Re: Beta firmwares available (0.5.2.1) - Beta testers needed   

Postby mad_ady » Sat Jan 10, 2015 3:21 am

Sorry to hear that. I will need more info:
1. Did the flashing procedure go all the way (did you see the progress bar)?
2. Can you ping the box?
3. Can you try booting with no other disks/sticks attached?
4. If using hdmi, can you try with composite?
5. You can try a config wipe by pressing the pin-hole button at startup
6. Do you have a serial adapter?
I hope one of these steps will work so there is no need for serial...
Good luck and thanks for testing.

Ps. Which exact firmware file did you flash?
User avatar
mad_ady
Developer
 
Posts: 4564
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Beta firmwares available (0.5.2.1) - Beta testers needed   

Postby distrata » Sat Jan 10, 2015 4:59 am

Thanks for quick reply.
1. No proggress bar.
2. No ping.
3. I am trying to built a bootable flash at the moment. But I am not sure about it if I format a drive to ext3 and copy paste the ext firmware the box is going to boot?
4. Composite will not make any difference because the box is freezed. The remote control not working. But to make sure I will try later and come back with the result.
5. I have tried this one and nothing happened.
6. I do not have a serial adapter.

I flashed 1.05.04_V.WDLXTV_LIVE-0.5.2.1 the last link from the first post.
Hope to restore it some way.
User avatar
distrata
WDTVer
 
Posts: 45
Joined: Mon Sep 30, 2013 5:13 am

Re: Beta firmwares available (0.5.2.1) - Beta testers needed   

Postby madgarth » Sat Jan 10, 2015 5:57 am

First of all, thanks for your great work.
I have the same problem after installing 1.05.04_V.WDLXTV_LIVE-0.5.2.1. A black screen and the box is not responding. The firmware was completely installed, the progress bar up to 100%, and after the first reboot the black screen.
I've managed to boot with a pendrive and roll back to 1.02 firmware.
madgarth
Donor
 
Posts: 5
Joined: Sat Apr 17, 2010 9:20 am

Re: Beta firmwares available (0.5.2.1) - Beta testers needed   

Postby kroetkroet » Sat Jan 10, 2015 6:11 am

mad_ady wrote:Thanks for the feedback. Are you using wdtvext=on, or off?
I don't know about hdmi output... I'm still on composite :). It shouldn't have changed...


WDTVEXT='OFF'

Lol, I guess your "composite" setting propagated into mine.

Maybe a remnant of an old firmware:

FORCEHDMI='OFF'
HDMI_FORCE_OUTPUT='0'

I would suggest to the "others" with failing firmware to wipe the config (either factory reset) and then flash again.
WDLXTV-fan! - In case you need further assistance: read our WIKI, search our Forum and most of all: donate 'something' to b-rad for his great efforts!!!
User avatar
kroetkroet
Beta Tester
 
Posts: 1010
Joined: Mon Apr 05, 2010 11:53 pm

Re: Beta firmwares available (0.5.2.1) - Beta testers needed   

Postby distrata » Sat Jan 10, 2015 6:26 am

@madgarth

How did you managed to boot it again?
User avatar
distrata
WDTVer
 
Posts: 45
Joined: Mon Sep 30, 2013 5:13 am

Re: Beta firmwares available (0.5.2.1) - Beta testers needed   

Postby madgarth » Sat Jan 10, 2015 6:38 am

@distrata

Just unzip the version 1.02.21_V.EXT3-BOOT_LIVE-0.5.2.1 in a FAT32 pendrive and boot the box with this pendrive conected. I've placed the firmware 1.02.21 in another pendrive and updated the firmware from the second pendrive. In the reboot quickly disconnect the first pendrive with the ext3-boot firmware.

@kroetkroet

I've reset the box to factory defaults and reflash the firmware and still have the same problem.
madgarth
Donor
 
Posts: 5
Joined: Sat Apr 17, 2010 9:20 am

PreviousNext

Return to WDTV G2 & WDTV Live homebrew discussion

Who is online

Users browsing this forum: No registered users and 1 guest