[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 379: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4326: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3501)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4328: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3501)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4329: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3501)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4330: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3501)
forum.wdlxtv.com • Beta firmwares available (0.5.1.9) - Beta testers needed!
Page 4 of 5

Re: Beta firmwares available (0.5.1.9) - Beta testers needed

PostPosted: Mon Oct 27, 2014 2:39 am
by mad_ady
Ok, regaring the crashing lld2d issue, I have three options:
1. Add a configuration option in the webend and kill lld2d only if the user chooses to. This would be the "safe" option
2. Recompile lld2d from microsoft's sources and hope it doesn't crash or bind to /dev/ir anymore
3. Disable lld2d alltogether (by mapping it to /bin/true for instance). This would have the "adverse" effect of not showing an icon in Windows Control panel network map...

I've tested #3 and it seems to work, but I'll try #2 as well. I'll be asking for volunteers to try out some changes later.

Re: Beta firmwares available (0.5.1.9) - Beta testers needed

PostPosted: Mon Oct 27, 2014 3:31 am
by mad_ady
Option #2 looks fine as well. I will try it in a firmware soon...

Re: Beta firmwares available (0.5.1.9) - Beta testers needed

PostPosted: Mon Oct 27, 2014 7:36 am
by mad_ady
Ok, I packed a new beta but only based on 1.05-live. It's called 0.5.1.7, lower than 0.5.1.9, but newer :)



If anybody wants to test this, I'm interested in the following thing:
- before upgrading see how the WDTV is seen in Windows -> Network Map (http://windows.microsoft.com/en-us/windows-vista/use-network-map-to-manage-and-troubleshoot-networked-devices-from-windows-vista-inside-out) (I don't have windows and I can't test this)
- after upgrade see if there is any difference there. I will test the shutdown code to see if I get any more kernel panics.


The change to the previous betas is that I recompiled lld2d and now hopefully it's no longer tied to /dev/ir. I am not killing it on DMAOSD shutdown, thus preventing any possible lockups (hopefully).

Report back with info (good or bad).

Re: Beta firmwares available (0.5.1.9) - Beta testers needed

PostPosted: Mon Oct 27, 2014 10:53 am
by maros306604
is the same process of upgrading like original firmware ?

Re: Beta firmwares available (0.5.1.9) - Beta testers needed

PostPosted: Mon Oct 27, 2014 10:54 pm
by mad_ady
Yes. It's just like an official firmware but without being official :D

Re: Beta firmwares available (0.5.1.9) - Beta testers needed

PostPosted: Tue Oct 28, 2014 12:32 am
by mad_ady
Hmm, so I've tried the newest build (0.5.1.8), but I still get that crash even with the custom built lld2d. Also, when it's started by dmaosd it opens /dev/ir for some weird reason and this causes problems on DMAOSD restart... I will try to start it as an independent process and let dmaosd start a dummy instead. This way you should still get an icon in the network map and avoid a crash on DMAOSD restart... yet a new beta will be available soon...

Edit: Added the link to the new beta firmware a few posts above: http://forum.wdlxtv.com/viewtopic.php?f=38&t=8973&p=71962#p71962

Re: Beta firmwares available (0.5.1.9) - Beta testers needed

PostPosted: Wed Oct 29, 2014 7:55 am
by maros306604
@mad_ady: hallo my friend, is possible do it in new firmware , than is possible choice in set up subtitles color of subtitles, yellow and white ??? It was be perfect for us ,

Re: Beta firmwares available (0.5.1.9) - Beta testers needed

PostPosted: Wed Oct 29, 2014 11:13 pm
by mad_ady
Sorry, those settings are part of the binary-only DMAOSD. I can't make changes there... :(

Re: Beta firmwares available (0.5.1.9) - Beta testers needed

PostPosted: Fri Nov 21, 2014 6:36 am
by mad_ady
Guys, I need your help again. There's a new beta version to test: http://forum.wdlxtv.com/viewtopic.php?f=38&t=9027&p=72160#p72160
This time with WDTVExt support (live only)

Re: Beta firmwares available (0.5.1.9) - Beta testers needed

PostPosted: Thu Jul 16, 2015 7:52 pm
by raphaelschmeer
Regarding wdtvext for 1.05 - it will be the same thing pibos left us in 1.05.