[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4326: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3501)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4328: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3501)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4329: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3501)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4330: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3501)
forum.wdlxtv.com • The curl package needs updating/checking
Page 1 of 2

The curl package needs updating/checking

PostPosted: Sat Nov 13, 2010 11:57 am
by mad_ady

Re: The curl package needs updating/checking

PostPosted: Sat Nov 13, 2010 1:18 pm
by b-rad.cc
figure out what certificate its using, forward it to me, and i'll put it in the right spot in the fw. :geek:

Re: The curl package needs updating/checking

PostPosted: Sun Nov 14, 2010 12:15 am
by mad_ady

Re: The curl package needs updating/checking

PostPosted: Sun Nov 14, 2010 1:59 am
by mad_ady

Re: The curl package needs updating/checking

PostPosted: Fri Dec 26, 2014 12:54 am
by mad_ady
Sorry to revive this really old thread, but I think I fixed the issue (took only ~5 years) :)

I added the cacert.pem file and pointed curl to it (through .curlrc).

The issue should be fixed starting with firmwares larger than 0.5.2.0.

Re: The curl package needs updating/checking

PostPosted: Mon May 11, 2015 5:37 pm
by workingman
Hey mad_ady,

I just tried to add an https rss feed and am not getting any joy. I think it's curl related but don't know for sure yet.

Re: The curl package needs updating/checking

PostPosted: Mon May 11, 2015 5:39 pm
by workingman
Oh ya and running latest AFAIK...

Device: WDLXTV_LIVE
Current version: 0.5.2.2

Re: The curl package needs updating/checking

PostPosted: Mon May 11, 2015 6:59 pm
by workingman
Of course I should have mentioned this was via rutorrent front end - but you knew that right mad_ady ;)

Think the problem has nothing to do with certs or https or anything tricky. Path to curl is hardcoded wrong.

# which curl
/bin/curl
# grep curl /var/www/plugins/rutorrent/conf/config.php
"curl" => '/usr/bin/curl', // Something like /usr/bin/curl. If empty, will be founded in PATH.

In the old app I built I just left it blank.

# grep curl /tmp/rt/work/app-build/src/rtorrent-0.9.2/var/www/rutorrent-3.4/conf
/config.php
"curl" => '', // Something like /usr/bin/curl. If empty, will be found in PATH.

In fact the only thing I defined was php-cgi as the php to use:

$pathToExternals = array(
"php" => '/usr/bin/php-cgi', // Something like /usr/bin/php. If empty, will be found in PATH.
"curl" => '', // Something like /usr/bin/curl. If empty, will be found in PATH.
"gzip" => '', // Something like /usr/bin/gzip. If empty, will be found in PATH.
"id" => '', // Something like /usr/bin/id. If empty, will be found in PATH.
"stat" => '', // Something like /usr/bin/stat. If empty, will be found in PATH.
);

I setup another box with rutorrent and created the rss feed then just copied over the file into /var/www/plugins/rutorrent/share/users/wdlxtv/settings/rss/cache/ and it worked fine.

Re: The curl package needs updating/checking

PostPosted: Mon May 11, 2015 10:12 pm
by mad_ady
Thanks for reporting the problem. I'll try to fix it but my development HDD is down :(

Re: The curl package needs updating/checking

PostPosted: Tue Jun 02, 2015 10:48 pm
by ikoiicmz1989
I'm having the same problem. :(