Sign up here and you can log into the forum!

WDLXTV_G2-0.4.5.3 No WIFI on arusb_lnx

The place for WDLXTV-G2 bugs

WDLXTV_G2-0.4.5.3 No WIFI on arusb_lnx   

Postby Iridium » Sat Apr 30, 2011 10:25 am

Hi,

I have a WDTV Gen 2 running 1.01.77-WDLXTV-G2-0.4.5.3 [flash] firmware, and a TP-Link TL-WN821N Ver:2.8 USB Wifi Dongle with VID/PID v0CF3p1002 (listed as supported by the arusb_lnx driver). I have created a net.config and placed it on the root of a 8GB FAT32 USB stick, net .config is as follows:

Code: Select all
WIRELESS=TRUE
modprobe arusb_lnx
SSID=Iridium
AUTHMODE=WPAPSK
ENCRYPTION_TYPE=TKIP
ENCRYPTION_KEY=12345_67890
DHCP=no
IP=192.168.0.55
GW=192.168.0.1
NM=255.255.255.0
DNS1=192.168.0.1
DNS2=205.171.3.65
MTU=9000


At the start the Wifi stick turns on the green led (solid light) and after a few seconds the led starts flashing but It never links to my AP (Dlink DWL-2000AP+ Firmware Version: 2.12). I have seen the AP's Log and the Wifi stick doesn't try to link or to negotiate with the AP never. I have tried the same wifi stick in a PC running Ubuntu 10.10 and It works perfect, good quality signal, good speed and a stable connection. I have also tried with "network-device-detector" and with "DHCP=yes" but I get the same results.

I need help with this, I haven't more ideas to try.

Can anybody help me?

Thank you in advance (and sorry for my bad english).

Agustin.
Thanks,
User avatar
Iridium
n00b
 
Posts: 2
Joined: Sat Apr 30, 2011 8:43 am

Re: WDLXTV_G2-0.4.5.3 No WIFI on arusb_lnx   

Postby Socram » Mon May 02, 2011 12:56 am

Not a big help, but I want to say that I'm with you since I'm having the same problem with a different dongle ;)
Socram
DLX'er
 
Posts: 110
Joined: Thu Apr 15, 2010 1:23 am

Re: WDLXTV_G2-0.4.5.3 No WIFI on arusb_lnx   

Postby Iridium » Sat Jun 11, 2011 9:13 am

Does anybody know any Wifi USB dongle which works perfect in WDLXTV_G2-0.4.5.3 ?

Thank you in advance.
Sega forever
User avatar
Iridium
n00b
 
Posts: 2
Joined: Sat Apr 30, 2011 8:43 am

Re: WDLXTV_G2-0.4.5.3 No WIFI on arusb_lnx   

Postby sgreci » Sun Oct 23, 2011 10:45 am

Hello,
i've basically the same problem: same wdtv g2 and wifi dongle but newer firmware 0.4.7.3 . I have no chance to check if my AP get the DHCP broadcast signal from the usb stick, but the behavior is the same: led on usb device is blinking but no ip address is released from AP.

This is my net.config file (i use ext3-boot firmware):

Code: Select all
WIRELESS=TRUE
modprobe arusb_lnx
DHCP=yes
SSID=mySSID
AUTHMODE=WPA2PSK
ENCRYPTION_TYPE=AES
ENCRYPTION_KEY=myPassword
NETWORKTYPE=Infra


I tried to change several parameters on my config file but didn't work.

Thanks for help!
sgreci
Donor
 
Posts: 1
Joined: Sat Oct 22, 2011 1:25 pm


Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron