Sign up here and you can log into the forum!

WDTV G2 won't pull an IP address

General WDLXTV-G2 forum

WDTV G2 won't pull an IP address   

Postby AtmaWeapon » Sat Sep 10, 2011 5:07 am

Hey guys.

I'm looking for a little help here. I'm trying to set up my G2 with 1.01.77-WDLXTV-G2-0.4.7.3 installed. I'm using a wired ASIX AX88178 ethernet adapter, which WDLXTV seems to set up correctly (I'm getting a LINK and ACT LEDs on) but for some reason it doesn't seem to get an IP address from my DHCP-enabled Linksys WRT54Gv8 router with DD-WRT. I already tried the adapter on my PC and it works just fine. net.config I'm using is shown below. Any ideas?

Code: Select all
##
## Network configuration file
##
## This file is sourced multiple times
## it SHOULD NOT contain commands whose
## effect would be adverse/detrimental
## if executed more than once
##
## To enable a line remove the hash '#'
##

## ********* enable Wireless *********
## must set to FALSE for wired ethernet
#
WIRELESS=FALSE

## ********* !!!!!! NEW !!!!!! *********
##  if you do not know what driver your network device uses
##  then uncomment the line below and the driver will
##  be automagically detected. You still *HAVE TO* set
##    WIRELESS=TRUE  or  WIRELESS=FALSE
##  along with any network settings you require
#
#network-device-detector

## *************************************
## to load a network driver manually if you know its driver
## enter the modprobe statement below
## to find which driver network-device-detector selected for you
## grep net.config /tmp/messages.txt
## options are: 8192cu,8712u, arusb_lnx, rt2570, rt3370sta,
## rt3572sta, rt73, rtl8150, rtl8187, zd1201, zd1211rw
#modprobe __________

#######################################################
#######################################################
############# WIRELESS SETTINGS #######################
#######################################################
#######################################################

## SSID:
#SSID=mySSID

## your auth mode:
#AUTHMODE=WEP
#AUTHMODE=WPAPSK
#AUTHMODE=WPA2PSK

## your encryption (WPA[2]/PSK only) type:
#ENCRYPTION_TYPE=TKIP
#ENCRYPTION_TYPE=AES

## WEP / WPA-PSK key
#ENCRYPTION_KEY=myKey

#######################################################
#######################################################
################ WIRED SETTINGS #######################
#######################################################
#######################################################

## Enable ONE driver below depending on your wireless adapter

## ASIX compatible adapters:
modprobe asix

## Pegasus compatible adapters:
#modprobe pegasus

## rtl8150 compatible adapters:
#modprobe rtl8150

## net1080 compatible adapters:
#modprobe net1080

## kaweth compatible adapters:
#modprobe kaweth

#######################################################
#######################################################
################# GENERAL SETTINGS ####################
##
## Dynamic IP Configuration:
DHCP=yes

##
## Static IP Configuration:  (only if not DHCP)
#DHCP=no
#IP=192.168.0.10
#GW=192.168.0.1
#NM=255.255.255.0
#DNS1=192.168.0.1
#DNS2=205.171.3.65

## attempt to set jumbo frames
MTU=9000

##
## Optional:
AtmaWeapon
n00b
 
Posts: 4
Joined: Fri Sep 09, 2011 4:23 pm

Re: WDTV G2 won't pull an IP address   

Postby winbugblue » Sat Mar 02, 2013 4:48 pm

Hello,
I am having exactly same problem with same device. I already spent many hours trying to solve without success... :cry:

I use WDLXTV [Gen2] version [1.01.77_WDLXTV.COM_WDLXTV_G2-0.4.7.3]
For ethernet I use USB Trendnet TU2-ETG (which use ASIX 88178)
Seems the device is recognized by WDTV because LEDs are blinking.
But for some reason cannot get IP address (DHCP is enabled in the router).
I have some other devices (wifi and wired) and no problem at all to connect with router using DHCP.

Any ideas?

Next are files that I have on my USB memory root:
Code: Select all
net.config
net.mounts
s00custom-options


And next is net.config file:
Code: Select all
   ##
   ## Network configuration file
   ##
   ## This file is sourced multiple times
   ## it SHOULD NOT contain commands whose
   ## effect would be adverse/detrimental
   ## if executed more than once
   ##
   ## To enable a line remove the hash '#'
   ##

   ## ********* enable Wireless *********
   
WIRELESS=FALSE

   ## ********* !!!!!! NEW !!!!!! *********
   ## if you do not know what driver your network device uses
   ## then uncomment the line below and the driver will
   ## be automagically detected. You still *HAVE TO* set
   ## WIRELESS=TRUE or WIRELESS=FALSE
   ## along with any network settings you require

network-device-detector

   #######################################################
   #######################################################
   ################# GENERAL SETTINGS ####################
   ##
   ## Dynamic IP Configuration:
   
DHCP=yes

   ##
   ## Static IP Configuration: (only if not DHCP)
   #DHCP=no
   #IP=192.168.0.10
   #GW=192.168.0.1
   #NM=255.255.255.0
   #DNS1=192.168.0.1
   #DNS2=

   ## attempt to set jumbo frames

MTU=1500



Thanks in advance for your help!
winbugblue
n00b
 
Posts: 1
Joined: Sat Mar 02, 2013 1:41 pm

Re: WDTV G2 won't pull an IP address   

Postby shazam » Sun Jun 23, 2013 6:14 pm

Is Asix AX88772A supported in 1.01.77_WDLXTV.COM_WDLXTV_G2-0.4.7.3 ?

Daer all, 1.01.77_WDLXTV.COM_WDLXTV_G2-0.4.7.3 is installed on my G2.
I want to hard wire an ethernet cable using an USB LAN adapter equipped with ASIX AX88772A chipset.
But No IP is showed when G2 started nor IP can be found under About /System Setting.

Here's what I have enabled under net.config

WIRELESS=FALSE
HOST=wdtv
network-device-detector
##ASIX compatible adapters:
modprobe asix
MTU=9000
DHCP=yes

After a little searching from internet, the asix-gigabit-drivers.app is downloaded into my USB disk
and net.config is amended as follows

LOAD=asix_updated
SUPPRESS_OTHERS=yes
##network-device-detector
##ASIX compatible adapters:
##modprobe asix
MTU=9000
DHCP=yes

But there is still no IP assigned as no network is detected.

Can anyone instruct me what to do next step ?

Thanks.
shazam
n00b
 
Posts: 8
Joined: Tue May 25, 2010 6:34 pm


Return to Discussion

Who is online

Users browsing this forum: No registered users and 2 guests