Page 1 of 1

Network shares

PostPosted: Mon Oct 16, 2017 9:51 pm
by rosie2417
Hello, I have been using my live for years with no problems. Until now. When u scroll through “my video” to network shares all of my home computers have disappeared. The only devices I can see are other WDTV’s. I am not sure when this happened probably within the last couple months. I tried other WDTV devises in the house and all the same. My gues is windows took an update and changed something but what. And more importly how can I get my Live to see and share files on other computers on my home network. And suggestion would be helpful. Thanks.

Re: Network shares

PostPosted: Tue Oct 17, 2017 11:04 pm
by mad_ady
Well, that's odd. Unfortunately, there aren't many people around left, and I no longer have an active WDTV, nor a windows PC which I could use to test this, but it seems that a windows update has changed the way windows shares work.
You could try to mount the share manually with XMounts (http://wiki.wdlxtv.com/Net.mounts) and browse it from Local files, or switch to using NFS on windows, by using HaneWin or FreeNFS: http://wiki.wdlxtv.com/How_to_setup_NFS ... ng_FreeNFS

Re: Network shares

PostPosted: Thu Oct 19, 2017 1:55 am
by RevDrew
Taken from another site, yes it says win 7 and vista but it should work on 10 also.
I never had to do the registry tweaks.

Win7 (and Vista) has some issues broadcasting its availability on a network.
You could try these changes to your Win7 box:-

Firstly, configure Sharing and Discovery:

1. Navigate to the Network and Sharing Center via the Control Panel
1a. click on Change advanced sharing settings
2. Click on the down arrow icons and select ON/OFF as follows:
Network Discovery - ON
File Sharing - ON
Public Folder Sharing - OFF
Printer Sharing - ON
Password Protected Sharing - OFF
Media Sharing - OFF


Next, configure the folder you want to share:

1. Select the folder
2. Right-click and choose 'Share' from the menu
3. From the drop-down box select the Everyone (All users in this list) account, making sure permissions are set to 'Reader'
4. Click the buttons Add, Share and Done.



Here are some further registry 'tweaks' if this doesn't work:

WARNING: This requires editing your PC's registry which, if edited incorrectly, can cause Windows systems to become unstable and unusable. So, follow the instructions below at your own risk. - we are not responsible for any damage caused by following these steps.

1. Navigate to the following location in the registry editor.
MACHINE\System\CurrentControlSet\Control\Lsa\
2. On the right side, double-click on 'everyoneincludesanonymous' and change the 'Value data' from '0' to '1'
3. Double-click on 'NoLmHash' and change the 'Value data' from '1' to '0'
4. Navigate to the following location in the registry editor:
MACHINE\System\CurrentControlSet\Services\LanManServer\Parameters
5. Double-click on 'restrictnullsessaccess' and change the 'Value data' from '1' to '0'
6. Close the registry editor


Finally, restart your PC.

Re: Network shares

PostPosted: Thu Oct 19, 2017 9:59 pm
by mad_ady
Nice to see you're still around RevDrew!

Re: Network shares

PostPosted: Mon Oct 23, 2017 2:04 am
by RevDrew
Thanks, you as well.
This was a thriving community and I keep popping in from time to time, I miss the fun of playing with these boxes.

However the wife likes how Kodi just works.

Re: Network shares

PostPosted: Wed Oct 25, 2017 6:27 am
by paul0607
I had the same problem. There was a windows update that turned samba 1 off which is insecure which the wd requires. You have to go into control panel --> programs and features --> turn windows features on and off --> check SMB CIFS and restart