Sign up here and you can log into the forum!

Moviesheets Problems

The place for n00b questions, anything goes...no n00b too n00bish.

Moviesheets Problems   

Postby fiendz138 » Thu Sep 18, 2014 9:03 pm

I am having issues with moviesheets. I must have read every post there is but still not grasping.

I am running 1.02.21.ext3-boot_live-0.5.1.1 using a thumb drive connected to give me ext plugin capabilities.

I was able to enable moviesheets and run thumbgen. But I am getting confused when trying to point to a moviesheet repository on a network share.

The roadblocks I'm running into are:

1) How do I point thumbgen to a repository on a network share?

2) I understand that I would need to run netapp for msheetdir to point to a network share. (Having trouble with this configuration)

3) Lastly, I'm having an issue setting up the msheetdir through wec

Would the virual usb drive be of any use for this instance?

Sorry if these questions have been asked many times. Like I said, I've read multiple threads over and over and still struggling to grasp.

Any help is greatly appreciated.
fiendz138
n00b
 
Posts: 13
Joined: Mon Aug 25, 2014 8:18 pm

Re: Moviesheets Problems   

Postby mad_ady » Thu Sep 18, 2014 11:29 pm

1. You need to map that network share to a drive letter and thumbgen should pick it up
2. If you're running 1.02 and if you have WDTVEXT=ON, then you can use the MovieSheet built-in plugin directly. No need for netapps. See this for instructions: http://wiki.wdlxtv.com/How_to_use_Movie_sheets_v2
3. Again, instructions are here: http://wiki.wdlxtv.com/How_to_use_Movie_sheets_v2

You don't need virtual usb drive since you already have a thumbdrive.
User avatar
mad_ady
Developer
 
Posts: 4573
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Moviesheets Problems   

Postby fiendz138 » Fri Sep 19, 2014 4:58 am

mad_ady wrote:1. You need to map that network share to a drive letter and thumbgen should pick it up
2. If you're running 1.02 and if you have WDTVEXT=ON, then you can use the MovieSheet built-in plugin directly. No need for netapps. See this for instructions: http://wiki.wdlxtv.com/How_to_use_Movie_sheets_v2
3. Again, instructions are here: http://wiki.wdlxtv.com/How_to_use_Movie_sheets_v2

You don't need virtual usb drive since you already have a thumbdrive.


Thanks for the info :D

I will try your suggestions
fiendz138
n00b
 
Posts: 13
Joined: Mon Aug 25, 2014 8:18 pm

Re: Moviesheets Problems   

Postby fiendz138 » Sun Sep 21, 2014 8:26 pm

I am very close to having the moviesheets up and running.

The issue I'm running into now is when I go into WDTVExt Plugins on the Live Plus, Available Plugins, and click on Enable Moviesheets, it changes to Disable Moviesheets but when I reboot (unplug power and reboot), moviesheets is disabled again.

Any ideas why this is hapenning?

Thanks for any help.
fiendz138
n00b
 
Posts: 13
Joined: Mon Aug 25, 2014 8:18 pm

Re: Moviesheets Problems   

Postby mad_ady » Sun Sep 21, 2014 10:28 pm

Not really, but if it's enabled you should have:
Code: Select all
root@Deneb:/root# grep ExtSheet /conf/wdtvext-plugins
/wdtvext/plugins/P10ExtSheet/ExtSheet.plugin.js


Also, you should see some relevant messages in /tmp/dmaosd.log
User avatar
mad_ady
Developer
 
Posts: 4573
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Moviesheets Problems   

Postby fiendz138 » Tue Sep 23, 2014 10:10 pm

Very strange problem. Under Available Plugins, I see enable moviesheets, but when I do enable it, I reboot. Then when it comes back up, it shows as enabled again.

Under Download Plugins, I don't even see Moviesheets anymore.

Is there a way for me to clear plugins and see if I can download/see moviesheets again?

Thanks!
fiendz138
n00b
 
Posts: 13
Joined: Mon Aug 25, 2014 8:18 pm

Re: Moviesheets Problems   

Postby fiendz138 » Tue Sep 23, 2014 10:16 pm

mad_ady wrote:Not really, but if it's enabled you should have:
Code: Select all
root@Deneb:/root# grep ExtSheet /conf/wdtvext-plugins
/wdtvext/plugins/P10ExtSheet/ExtSheet.plugin.js


Also, you should see some relevant messages in /tmp/dmaosd.log


I forgot to mention that when I run "grep ExtSheet /conf/wdtvext-plugins", this is what is listed
/wdtvext/plugins/P10ExtSheet/ExtSheet.plugin.js
/wdtvext/plugins/MovieSheet/P10ExtSheet/ExtSheet.plugin.js

Since I have the Live Plus, I am running the 1.02.21.EXT3-BOOT_LIVE-0.5.1.1 off of a thumb drive always connected.

I had read in a thread that a .wdtvext-plugins directory needed to be created on the thumb drive to see the WDTVExt Plugins option in the menu, Could this be causing an issue? Should I delete this plugins folder from the thumb drive?
fiendz138
n00b
 
Posts: 13
Joined: Mon Aug 25, 2014 8:18 pm

Re: Moviesheets Problems   

Postby mad_ady » Tue Sep 23, 2014 10:41 pm

The ExtSheet plugin is included in the firmware. I'm not sure where it picks up /wdtvext/plugins/MovieSheet/P10ExtSheet/ExtSheet.plugin.js from. You can have a .wdtvext-plugins folder on the USB drive, but it should be empty at this point. You can use the OSD to enable/disable the ExtSheets plugin. Doing it from the OSD will control it without the need to reboot.
User avatar
mad_ady
Developer
 
Posts: 4573
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Moviesheets Problems   

Postby recliq » Fri Sep 26, 2014 1:26 am

This looks indeed strange, it looks like you installed the old plugin alongside the newer version which is included in the firmware.

Try removing
Code: Select all
/wdtvext/plugins/MovieSheet/P10ExtSheet/ExtSheet.plugin.js

from file system and config...

You should also try to remove
Code: Select all
/conf/wdtvext-plugins

it should be re-generated with the correct defaults on reboot.
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

Re: Moviesheets Problems   

Postby fiendz138 » Fri Sep 26, 2014 5:11 am

recliq wrote:This looks indeed strange, it looks like you installed the old plugin alongside the newer version which is included in the firmware.

Try removing
Code: Select all
/wdtvext/plugins/MovieSheet/P10ExtSheet/ExtSheet.plugin.js

from file system and config...

You should also try to remove
Code: Select all
/conf/wdtvext-plugins

it should be re-generated with the correct defaults on reboot.


To remove the extsheet.plugin.js, would I use rm /wdtvext/plugins/MovieSheet/P10ExtSheet/ExtSheet.plugin.js? I tried deleting it using a file browser, but it gave me an access denied error.

I've also tried removing /conf/wdtvext-plugins.

Once I can confirm how to remove the extsheet.plugin.js, I will try it tonight and report the outcome.

Thanks again for all of your help
fiendz138
n00b
 
Posts: 13
Joined: Mon Aug 25, 2014 8:18 pm

Next

Return to n00b central

Who is online

Users browsing this forum: No registered users and 5 guests

cron