Sign up here and you can log into the forum!

Need some help with ssh

The place for n00b questions, anything goes...no n00b too n00bish.

Need some help with ssh   

Postby Raven » Mon Apr 19, 2010 12:58 pm

I'm having a problem with ssh and I'm not sure what I did wrong so I'll start from the beginning.

I downloaded the latest release which was "1.01.24_B-RAD.CC_WDLXTV_LIVE-0.4.1.9-6.zip" and put it on a USB flash drive. The WDTV Live detected the firmware and updated. I checked the system info screen to make sure everything was ok and it was. Then I made sure networking was working, got an IP address, everything was fine. I used Terminal to telnet in (I'm in OSX 10.6.3) and connected as root and then used the passwd command to set a password. Everything worked ok.

Problem is, after I ssh in, I try to .ls and nothing happens. When I do .ls -al I get a listing with hardly anything in it. It looks like this:

Code: Select all
# ls -all
lrwxrwxrwx    1 root     root           17 Jan  1  1970 .ash_history -> /tmp/.ash_history
drwx------    1 root     root           20 Jan  1  1970 .config
lrwxrwxrwx    1 root     root           18 Jan  1  1970 .nano_history -> /tmp/.nano_history
drwx------    1 root     root          152 Jan  1  1970 .ssh
#


I'm pretty sure there are supposed to be a bunch more dirs in there. I'm not exactly sure where I went wrong. I wanna edit net.mounts and S00custom-options but I don't have access to the files. Any help would be much appreciated.
Raven
n00b
 
Posts: 14
Joined: Mon Apr 19, 2010 12:38 pm

Re: Need some help with ssh   

Postby Raven » Mon Apr 19, 2010 5:11 pm

I just tried installing the latest official release (1.01.24_B-RAD.CC_WDLXTV_LIVE-0.4.1.9.zip) instead of the latest beta and I still don't have all all the directories. I'm really not sure what I'm doing wrong. This isn't exactly rocket science.
Raven
n00b
 
Posts: 14
Joined: Mon Apr 19, 2010 12:38 pm

Re: Need some help with ssh   

Postby mctt » Mon Apr 19, 2010 11:03 pm

Sounds normal to me. Have a look in /tmp or /conf.
User avatar
mctt
Beta Tester
 
Posts: 103
Joined: Fri Apr 16, 2010 2:41 pm

Re: Need some help with ssh   

Postby Raven » Tue Apr 20, 2010 2:23 am

Ok, I figured out what I was doing wrong. Seems that when I ssh in, I have to do a cd .. to go 1 dir up. Then everything shows up using ls. I haven't used a command line in years. It didn't even occur to me to try it.
Raven
n00b
 
Posts: 14
Joined: Mon Apr 19, 2010 12:38 pm

Re: Need some help with ssh   

Postby mctt » Tue Apr 20, 2010 3:47 am

Don't worry, I do pwd and ls every time I login out of habit. Everytime I do plain ls and nothing is output it a short bolt of puzzlement washes over me :oops:
User avatar
mctt
Beta Tester
 
Posts: 103
Joined: Fri Apr 16, 2010 2:41 pm

Re: Need some help with ssh   

Postby kroetkroet » Tue Apr 20, 2010 4:05 am

What you could try is to 'customize' your prompt (by default, root's prompt equals #). You can put anything like root@wdtvlive:/tmp/media/USB2> into it! You never get lost in which user you were logged in (equals whoami), the host you are on (equast hostname) and the path you are working in (equals pwd). You even can but date/time stamps in them!

Please check http://www.linuxselfhelp.com/howtos/Bash-Prompt/Bash-Prompt-HOWTO-2.html for more information!

Greetz,
:geek:
WDLXTV-fan! - In case you need further assistance: read our WIKI, search our Forum and most of all: donate 'something' to b-rad for his great efforts!!!
User avatar
kroetkroet
Beta Tester
 
Posts: 1010
Joined: Mon Apr 05, 2010 11:53 pm


Return to n00b central

Who is online

Users browsing this forum: No registered users and 3 guests