Sign up here and you can log into the forum!

ASIX updated drivers (makes gigabit cards work)

General WDLXTV forum

Re: ASIX updated drivers (makes gigabit cards work)   

Postby freak_wdlxtv » Sat Mar 17, 2012 11:11 pm

@joost:
telnet != ssh...
use putty

@clioguy:
1. Can I have as many app.bin files as I want on bootup from a USB?
there is a limit, I doubt u'll hit it.
2. where is the location of the net.config file?
you create it, it should always live at the root of your flash drive
freak_wdlxtv
n00b
 
Posts: 18
Joined: Fri Jan 21, 2011 9:42 am

Re: ASIX updated drivers (makes gigabit cards work)   

Postby se.afasia » Sun Mar 18, 2012 2:06 am

...we need the steps to follow,the how to create the flash stick all steps!!
thnks
User avatar
se.afasia
n00b
 
Posts: 10
Joined: Mon Mar 05, 2012 3:31 am
Location: Greece,Argos city

Re: ASIX updated drivers (makes gigabit cards work)   

Postby baspower » Fri Mar 23, 2012 4:25 am

@freak_wdlxtv

registered here just to say thanks for your work!
i have a gen1 collecting dust at home and i have just placed an order for a Plugable AX88178 adapter.

thanks again man. you rock!
baspower
n00b
 
Posts: 1
Joined: Thu Mar 22, 2012 2:02 pm

Re: ASIX updated drivers (makes gigabit cards work)   

Postby Jim3 » Mon Aug 26, 2013 2:50 pm

Hi,

Sorry to dredge up an old post.

I'm after some help getting my usb ethernet adapter working. So if you chaps don't mind lending a hand, I'd really appreciate it.

I have a Sitecom ln-028 gigabit ethernet usb adapter that uses the AX88178 chipset.

I have a standard install of 1.03.01_B-RAD.CC_WDLXTV-0.5.8.1 (except for adding the required lines into the net.config)

I have put downloaded the app.bin file containing the drivers into the root of my usb stick.

Nothing happens, I get a no ip message in the system settings page.

No lights are coming on on the adapter so I reckon its not loading drivers.

How do I enable start up logging to see what is going on?

Also I had to use a different memory stick to the one I used to install wdlxtv so I'm not sure if there is some directories etc that need to be created in the root of the memory stick for it to work correctly? Does wdlxtv expect the standard linux folders (/bin, /etc, /opt) etc?

My memory card looks like this:

Code: Select all
drwxr-xr-x    1 Jim      Administ        0 Dec 31  1999 .wd_tv
-rw-r--r--    1 Jim      Administ     8.6k Nov  6  2009 Changelog
drwxr-xr-x    1 Jim      Administ        0 Aug 26 23:07 FOUND.000
-rw-r--r--    1 Jim      Administ     2.6k Nov  6  2009 README
-rwxr-xr-x    1 Jim      Administ     3.1k Aug 26 23:28 S00custom-options
-rw-r--r--    1 Jim      Administ      24k Aug 26 21:52 app.bin
-rw-r--r--    1 Jim      Administ      578 Aug 26 23:29 net.config
-rw-r--r--    1 Jim      Administ      503 Nov  6  2009 net.mounts
-rw-r--r--    1 Jim      Administ      24k Nov  6  2009 screen_saver.png
-rw-r--r--    1 Jim      Administ      13M Nov  6  2009 wdtv.bin
-rw-r--r--    1 Jim      Administ       53 Nov  6  2009 wdtv.ver
-rw-r--r--    1 Jim      Administ      73k Nov  6  2009 welcome_background_bg.jpg


Thanks in advance guys.
Jim3
n00b
 
Posts: 2
Joined: Mon Aug 26, 2013 2:37 pm

Re: ASIX updated drivers (makes gigabit cards work)   

Postby Jim3 » Tue Sep 10, 2013 10:58 pm

Got it working.

Couldn't get the posted driver to work. I got errors when trying to modprobe it in.

Downloaded the driver source and cross compiled a new one.

I had to add in my usb ethernet adapter's vendor id and product id into the driver source for it to be picked up.
Jim3
n00b
 
Posts: 2
Joined: Mon Aug 26, 2013 2:37 pm

Re: ASIX updated drivers (makes gigabit cards work)   

Postby bulforce » Mon Dec 09, 2013 3:49 pm

Hello all,

I got one of those little boxes laying around for a while, today decide to test it and see what can be done. I put the custom firmware and it boots up ok, however my USB lan card is not recognised.

I have ASIX AX88772B USB 2.0

I am not sure that the driver posted here will work with this chip.. The link is no longer working and I am having really hard time finding this old stuff on the internet.

If anyone has this I will be greatly thankful if you reupload it some where.

Thanks all.
bulforce
n00b
 
Posts: 1
Joined: Mon Dec 09, 2013 3:43 pm

Re: ASIX updated drivers (makes gigabit cards work)   

Postby Megaweapon » Thu Dec 12, 2013 6:44 pm

bulforce wrote:The link is no longer working and I am having really hard time finding this old stuff on the internet.

If anyone has this I will be greatly thankful if you reupload it some where.


I'm not positive that there weren't any additional files (I can't find an archive anywhere, just the .bin file) but hopefully this will be a more permanent location:

https://drive.google.com/file/d/0B3TDtvIObejeNnppRG1CblBMYzg/edit?usp=sharing

Such great work should not be lost.
User avatar
Megaweapon
n00b
 
Posts: 5
Joined: Sun Nov 21, 2010 10:16 am

Previous

Return to Discussion

Who is online

Users browsing this forum: No registered users and 1 guest