Sign up here and you can log into the forum!

ASIX updated drivers (makes gigabit cards work)

General WDLXTV forum

ASIX updated drivers (makes gigabit cards work)   

Postby freak_wdlxtv » Sun Mar 06, 2011 4:47 pm

http://www.2shared.com/file/rq-r6LsE/asix-gigabit-driversapp.html

Included in this app.bin is the driver for the 88178 chip:

dependencies:
none

Modules:
/lib/modules/2.6.15-TvDock/asix_updated.ko

The driver is UNTESTED! I do not have this device so that means I have no way to test. I only
created this was because someone requested this. Regardless of what driver you use, be sure to use
the log-saver app since this will grab all the log files and info needed for debugging any problems. If
you want me to help you send me the output from log-saver or else your PM's and postings
will be ignored.

Installation:
net.config

uncomment the last line #SUPPRESS_OTHER=yes
the add LOAD=asix_updated

so..
your net.config will have all the other info you put it plus the following lines:

LOAD=asix_updated
SUPPRESS_OTHERS=yes
Last edited by freak_wdlxtv on Tue Mar 08, 2011 2:11 pm, edited 1 time in total.
freak_wdlxtv
n00b
 
Posts: 18
Joined: Fri Jan 21, 2011 9:42 am

Re: ASIX updated drivers (makes gigabit cards work)   

Postby Donk » Tue Mar 08, 2011 9:31 am

I tested this driver with a USB 2.0 to 10/100/1000Mbps Gigabit Ethernet Adapter, which uses an AX88178 chip, the device works now, thanks very much freak.
I've set up shared pc folders on the WDTV via nfs using putty,
I have yet to measure throughput, but it plays every file I have tried so far.
1080p mkv can be a bit choppy but I put that down to using homeplugs which max out at 79mb and a g network card/router.

Thanks again to freak_wdlxtv for sorting out an issue which has been posted about for over a year on various wdtv/linux forums.
I appreciate the fact that he made this effort for others even though he does not own this usb/ethernet device, so fair play to him.

BTW does anyone know how to mount drives which are attached to the WDTV to NFS server, I would like to try sending downloaded files directly.
Donk
n00b
 
Posts: 4
Joined: Fri Oct 29, 2010 2:33 pm

Re: ASIX updated drivers (makes gigabit cards work)   

Postby asif9t9 » Tue Mar 15, 2011 10:06 am

I have a Trendnet TU2-ETG, all working fine. And I have a gigabit setup at home. Can I do something to get a gigabit hookup to my WDTV Gen1? Is there really a point, if I already have a 100Mbps connection from my NFS Server to my WDTV?
asif9t9
n00b
 
Posts: 16
Joined: Sun Jul 25, 2010 2:11 pm

Re: ASIX updated drivers (makes gigabit cards work)   

Postby Megaweapon » Wed Jul 13, 2011 5:37 pm

I had pretty much given up hope that anyone would do this, but here it is! :o

VERY happy to report that my AX88178-based Monoprice MP-UL220G USB ethernet adapter works fine with this new driver on my "Gen 1" WDTV running WDLXTV 0.5.8.1

Both the WDTV and the adapter (which I bought specifically for this purpose) were gathering dust before. Now I expect to have a lot of fun with them!

Thank you, freak_wdlxtv! :D
User avatar
Megaweapon
n00b
 
Posts: 5
Joined: Sun Nov 21, 2010 10:16 am

Re: ASIX updated drivers (makes gigabit cards work)   

Postby mrgimo » Mon Oct 03, 2011 1:29 am

freak_wdlxtv wrote:I only created this was because someone requested this.


Thank you very very much! I'll try it ASAP! :)
mrgimo
n00b
 
Posts: 4
Joined: Fri Nov 26, 2010 3:15 pm

Re: ASIX updated drivers (makes gigabit cards work)   

Postby Viper780 » Mon Oct 03, 2011 2:32 am

asif9t9 wrote:I have a Trendnet TU2-ETG, all working fine. And I have a gigabit setup at home. Can I do something to get a gigabit hookup to my WDTV Gen1? Is there really a point, if I already have a 100Mbps connection from my NFS Server to my WDTV?


my Belkin Gbit USB Stick is working very good here: http://geizhals.at/eu/224350
User avatar
Viper780
n00b
 
Posts: 16
Joined: Sun Oct 24, 2010 4:45 am
Location: Vienna/Austria

Re: ASIX updated drivers (makes gigabit cards work)   

Postby Joost » Fri Nov 25, 2011 5:49 am

Hai there,

I''m using a Konig CMP-NWUSB20 USB to Ethernetadapter which obtained a IP adress when connected, but I can't nevertheless not connect.
This adapter uses the ASIX 88772 chipset and I was wondering if the updated drivers menntioned int his post will work on the AX 88772 chipset also?

Hope someone could help me out on this one.
Thanx
Joost
n00b
 
Posts: 5
Joined: Fri Nov 25, 2011 5:41 am

Re: ASIX updated drivers (makes gigabit cards work)   

Postby kroetkroet » Fri Nov 25, 2011 5:54 am

Hai Joost,

it could be great to have a look into your logs - please refer to the topic start talking about logsaver, to capture & save log files for debugging purposes.

Good luck!
KK
WDLXTV-fan! - In case you need further assistance: read our WIKI, search our Forum and most of all: donate 'something' to b-rad for his great efforts!!!
User avatar
kroetkroet
Beta Tester
 
Posts: 1004
Joined: Mon Apr 05, 2010 11:53 pm

Re: ASIX updated drivers (makes gigabit cards work)   

Postby Joost » Fri Nov 25, 2011 4:13 pm

Solved by changing from USB2 to USB1 and adapter works fine. I managed to change root password using telnet.

Only SSH give as result; port 22: Connection refused.

Anyone?
Joost
n00b
 
Posts: 5
Joined: Fri Nov 25, 2011 5:41 am

Re: ASIX updated drivers (makes gigabit cards work)   

Postby clioguy » Sat Dec 03, 2011 4:33 pm

Hi all,

Stupid questions really, but nonethelss:

1. Can I have as many app.bin files as I want on bootup from a USB?
2. where is the location of the net.config file?
clioguy
n00b
 
Posts: 11
Joined: Thu Dec 01, 2011 2:09 pm

Next

Return to Discussion

Who is online

Users browsing this forum: No registered users and 2 guests