Sign up here and you can log into the forum!

for your review: wdlxtv-palace (gen3)

Yes, this is your place to show off. Let us see what you're doing with your device[s]

Re: for your review: wdlxtv-palace (gen3)   

Postby KAD » Thu Dec 12, 2013 12:49 pm

couldn't open it from work, but this is the first listing in google

http://www.exploit-db.com/exploits/19402/

web address looks correct
it's really really simple
add home.php to any SMP OSD theme (.zip file)
upload using curl
execute home.php using curl
start telnet
enjoy root telnet access while running official firmware

if nobody takes this up, I was thinking about making an ext3 version firmware
probably wouldn't be called wdlxtv, but I'd just make some really simple edits, like auto start telnet, ssh, ftp, etc ...

besides the DTS-MA support
I've already confirmed WD fixed NFS, so it now uses TCP
another surprise, I haven't looked into /conf/proftpd.conf exist in official firmware
it's not running, but it's there

a lot of the standard googies are there as well
wget, rsync, etc ....
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

Re: for your review: wdlxtv-palace (gen3)   

Postby DJArty » Thu Dec 12, 2013 1:48 pm

Thank you KAD .
Additional info and ext3 later will be best.
WD TV Live (1.02.21-WDLXTV-0.4.7.3);
Please Donate PayPal to email: djartyua ( a t ) gmail (d o t) com
WebMoney: WMZ114867333413; WMU219453404899; WMR161810775332
User avatar
DJArty
Developer
 
Posts: 540
Joined: Wed Jul 21, 2010 2:30 am
Location: Ukraine

Re: for your review: wdlxtv-palace (gen3)   

Postby KAD » Thu Dec 12, 2013 9:04 pm

well I guess this is a bust for new firmware,

palace alpha utilities say homebrew mode is successful
but I can't get it to actually boot palace over the top of 2.01.86

so to answer your question
DJArty wrote:new firmware 2.01.86 work with wdlxtv-palace?


no, it's no working,
just a guess, need new sha1sum crack file

edit:
PS. I might give this another try, I'm still very surprised this isn't working
on another note, if anybody needs/wants the firmware files, I ran rsync on the official firmware last night, so I've got all the files
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

Re: for your review: wdlxtv-palace (gen3)   

Postby KAD » Fri Dec 13, 2013 8:04 pm

SUCCESS :mrgreen:

I knew something wierd was going on yesterday
not sure why it did not like my ext3 format thumbdrive
change the thumbdrive to fat32

palace boots just fine over most recent firmware

and one up
I've successfully booted a stock ext3 firmware
I've got a super busy weekend, with a wedding on sunday
but, firmware is soon to follow

:mrgreen:
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

Re: for your review: wdlxtv-palace (gen3)   

Postby leveltrauma » Sat Dec 14, 2013 11:35 pm

KAD wrote:SUCCESS
.
.
.
I've successfully booted a stock ext3 firmware
I've got a super busy weekend, with a wedding on sunday
but, firmware is soon to follow

:mrgreen:


Sounds really good, it would be really great to use the palace with the new firmware! Thank you
leveltrauma
WDTVer
 
Posts: 20
Joined: Sat Jun 22, 2013 4:42 am

Re: for your review: wdlxtv-palace (gen3)   

Postby dkslc » Sun Dec 15, 2013 12:41 pm

Alright, I cannot get Palace to boot up. Here's my device info and what I have done. Any suggestions would be welcome.

Part Number: WDBHG70000NBK
Firmware: 2.01.86

1) Downloaded and unzipped the WDLXTV-Palace-homebrew-kit-v2.zip and 1.12.14_WDLXTV_PALACE-0.0.2.zip files from the first page of this thread.
2) Edited device-ip.txt and placed the IP address (and only the IP address) of the SMP into the document. Saved and closed.
3) Executed win-homebrew-upload.bat.
4) Executed win-homebrew-brewme.bat.
5) Executed win-homebrew-status.bat.
Code: Select all
D:\WDLXTV-Palace-homebrew-kit-v2\homebrew>win-homebrew-upload.bat
"Attempting to upload WDLXTV Homebrew theme to 192.168.1.160..."
"press any key to start"
Press any key to continue . . .
"This could take a few minutes, wait for it!"
<script language="javascript" type="text/javascript"> window.top.window.stopUplo
ad(1);</script>

'Success uploading WDLXTV Homebrewer theme.'
''
"press any key to exit"
Press any key to continue . . .

D:\WDLXTV-Palace-homebrew-kit-v2\homebrew>win-homebrew-brewme.bat
"Attempting to enable homebrew mode, if you see lots of jibber jabber you need t
o upload the theme first."
"press any key to start"
Press any key to continue . . .
WDLXTV WD TV Homebrew Kit v2 -- by b-rad
Enabling...
Success, homebrew enabled--place homebrew files on USB and reboot.
"press any key to exit"
Press any key to continue . . .

D:\WDLXTV-Palace-homebrew-kit-v2\homebrew>win-homebrew-status.bat
"Attempting to check homebrew status, if you see lots of jibber jabber you need
to upload the theme first."
"press any key to start"
Press any key to continue . . .
WDLXTV WD TV Homebrew Kit v2 -- by b-rad
Checking Mode...
HomeBrew Mode: ON
"press any key to exit"
Press any key to continue . . .

6) Copied the four files to my FAT32 formatted USB thumbdrive.
Code: Select all
G:\>dir
Volume in drive G is CRUZER
Volume Serial Number is 64E7-C41D

Directory of G:\

01/05/2013  05:05 PM       182,177,792 wdlxtv-palace.bin
12/17/2012  10:01 PM               271 wdtvlivegen3.bin.mpm
12/17/2012  10:02 PM                78 wdtvlivegen3.bin.mpm.sha1sum
01/01/2013  03:21 PM             1,389 runsit.sh
               4 File(s)    182,179,530 bytes
               0 Dir(s)   1,868,599,296 bytes free

7) Safely ejected and removed the USB drive from my PC.
8) Powered off and pulled the plug on the SMP.
9) Inserted the USB drive into the front USB port of the SMP.
10) After about a minute, I put the plug to the SMP back in, powering on the device.
11) The SMP boots up, and I can see the gibberish at the bottom of the screen (where it says the Homebrew theme is loading... not really a theme).
12) I go into the "About" screen, and my firmware still says 2.01.86.

Ideas anyone?
dkslc
n00b
 
Posts: 4
Joined: Sun Dec 15, 2013 12:03 pm

Re: for your review: wdlxtv-palace (gen3)   

Postby KAD » Sun Dec 15, 2013 9:34 pm

leave thumbdrive plugged into WD
execute win-homebrew-brewme.bat again

it should be generating a file sysconfig.patched which will appear next to the other files on your thumbdrive
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

Re: for your review: wdlxtv-palace (gen3)   

Postby dkslc » Mon Dec 16, 2013 6:54 pm

Well, I cannot get this to work. I ran win-homebrew-brewme.bat again (with the thumbdrive still plugged in), but sysconfig.patched is not being generated. I tried it while powered on and also while in standby mode (plugged in, powered off). No dice.

I'm going to stockify, reset to factory and try again, but I have a few questions before I start.

A) Based on my steps 3-10 (re-listed below), is there anything that I am missing and do I have anything out of order (Do I need to move step #4 to after step #10)?
3) Executed win-homebrew-upload.bat.
4) Executed win-homebrew-brewme.bat.
5) Executed win-homebrew-status.bat.
6) Copied the four files to my FAT32 formatted USB thumbdrive.
7) Safely ejected and removed the USB drive from my PC.
8) Powered off and pulled the plug on the SMP.
9) Inserted the USB drive into the front USB port of the SMP.
10) After about a minute, I put the plug to the SMP back in, powering on the device.


B) Does the USB port (front vs. back) matter?

C) When executing upload and brewme, does the WD need to be powered on or in standby (or does it not matter)?
dkslc
n00b
 
Posts: 4
Joined: Sun Dec 15, 2013 12:03 pm

Re: for your review: wdlxtv-palace (gen3)   

Postby leveltrauma » Tue Dec 17, 2013 8:31 am

It doesn't matter, the important thing is that you have the theme uploaded, then pull in the usb stick (everything to the root of the stick) and then restart the smp by using Config > System > Restart.
But it only works if you have select the new homebrew theme
leveltrauma
WDTVer
 
Posts: 20
Joined: Sat Jun 22, 2013 4:42 am

Re: for your review: wdlxtv-palace (gen3)   

Postby KAD » Tue Dec 17, 2013 9:03 am

you have some extra steps in there, maybe should be like this

3) Executed win-homebrew-upload.bat.
4) Executed win-homebrew-brewme.bat.
5) Executed win-homebrew-status.bat.
6) Copied the four files to my FAT32 formatted USB thumbdrive.
7) Safely ejected and removed the USB drive from my PC.
9) Inserted the USB drive into the front USB port of the SMP.
10) make sure SMP can read USB stick, then use on screen menu to reboot
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

PreviousNext

Return to Look at Me!!!

Who is online

Users browsing this forum: No registered users and 1 guest