Sign up here and you can log into the forum!

RSS feed for site/forums

This is the place to let known your feelings of the wdlxtv.com experience and how it could be made better. Its not the place to ask about / request firmware features.

RSS feed for site/forums   

Postby RobinE » Wed Apr 21, 2010 12:06 am

An RSS feed for the forums and site would be very useful.
RobinE
n00b
 
Posts: 3
Joined: Sat Apr 17, 2010 4:51 am

Re: RSS feed for site/forums   

Postby b-rad.cc » Wed Apr 21, 2010 12:07 am

click smartfeeds and create different feeds to your hearts desires ;)
PM's are for private matters only, please post public matters on the forum to help others who might have the same issue.
:mrgreen:
User avatar
b-rad.cc
WDLXTV Team
 
Posts: 3003
Joined: Sat Apr 03, 2010 9:35 am
Location: New York

Re: RSS feed for site/forums   

Postby RobinE » Wed Apr 21, 2010 12:15 am

I tried using all the default settings, but Google Reader reported there were no items... Am I doing something wrong?
RobinE
n00b
 
Posts: 3
Joined: Sat Apr 17, 2010 4:51 am

Re: RSS feed for site/forums   

Postby RobinE » Wed Apr 21, 2010 12:18 am

Ah! that's better... I changed the settings to "last 90 days", and it looks good now. Sorry for being so dumb.
RobinE
n00b
 
Posts: 3
Joined: Sat Apr 17, 2010 4:51 am

Re: RSS feed for site/forums   

Postby b-rad.cc » Wed Apr 21, 2010 12:20 am

:oops: i have no idea to tell you the truth as I have never tried it. No one complained after I added the feature and thanks were said...so I sort've imagined it worked.

Does smartfeed RSS not work OR work for anyone out there?

I just tried it myself a few different ways and it works just fine :?:
PM's are for private matters only, please post public matters on the forum to help others who might have the same issue.
:mrgreen:
User avatar
b-rad.cc
WDLXTV Team
 
Posts: 3003
Joined: Sat Apr 03, 2010 9:35 am
Location: New York

Re: RSS feed for site/forums   

Postby Mr Lazy » Wed Apr 21, 2010 1:54 am

It doesn't work 100%.

Taking IE8 as an example, if I click on the RSS/feeds icon I get four options:
Feed - forum.wdlxtv.com
Feed - New Topics
RSS
ATOM

The first two work fine, the last two give "Internet Explorer cannot display this feed" and then gives an error such as:
Code: Select all
Only one top level element is allowed in an XML document.
Line: 892 Character: 2

<br />


It's not IE8 though (I don't use it for RSS it's horrible) I use RSSOwl 2 which is excellent but this also has trouble with those two feeds. It can put it through the www3 feed validator and it gives a similar error to that above.

I also tried making my own filter on the Smartfeed page but this too gives a similar error.

To be honest I'd decided to use the email subscription method instead as it's easy to choose which boards/topics you like.
User avatar
Mr Lazy
WDTVer
 
Posts: 24
Joined: Mon Apr 12, 2010 5:55 am
Location: U.K.

Re: RSS feed for site/forums   

Postby b-rad.cc » Wed Apr 21, 2010 6:31 am

i'll debug those two feeds and find that pesky break.
PM's are for private matters only, please post public matters on the forum to help others who might have the same issue.
:mrgreen:
User avatar
b-rad.cc
WDLXTV Team
 
Posts: 3003
Joined: Sat Apr 03, 2010 9:35 am
Location: New York

Re: RSS feed for site/forums   

Postby Dark_Wizard » Fri Apr 23, 2010 3:13 pm

This is the error I get:

"RSS Feed XML Error: junk after document element at line 52" in my app.....

After viewing the actual xml I see this at the end of the file:

<b>Fatal error</b>: Using $this when not in object context in <b>/home/wdlxtv/forum.wdlxtv.com/smartfeed.php</b> on line <b>708</b><br />
Dark_Wizard
WDTVer
 
Posts: 48
Joined: Mon Apr 12, 2010 2:45 pm

Re: RSS feed for site/forums   

Postby b-rad.cc » Fri Apr 23, 2010 4:36 pm

could you guys pm me particular url's of feeds that aren't working? I'm trying to get one of these errors, but I cannot.
PM's are for private matters only, please post public matters on the forum to help others who might have the same issue.
:mrgreen:
User avatar
b-rad.cc
WDLXTV Team
 
Posts: 3003
Joined: Sat Apr 03, 2010 9:35 am
Location: New York

Re: RSS feed for site/forums   

Postby Demo » Sat Apr 24, 2010 1:01 am

I'm unable to view ANY feed in ANY feed viewer.
This one for example:
http://forum.wdlxtv.com/smartfeed.php?u=442&e=zHnWAYF0n5t31qvG6NcsHcJzuwChdHhYwZtjgwGJCFeYV1xNZTTFyQ..&lastvisit=1&forum=37&limit=1_MONTH&sort_by=user&feed_type=RSS2.0&feed_style=HTML
leads to errors described by others. When I try to download the URL with curl, I get
Code: Select all
...
    </channel>
</rss>
<b>Fatal error</b>:  Using $this when not in object context in <b>/home/wdlxtv/forum.wdlxtv.com/smartfeed.php</b> on line <b>708</b><br />
and then curl hangs indefinitely.

(I don't know if that's related to the problem but it seems that every page with a discussion thread hangs in curl, not only rss feeds, e.g. http://forum.wdlxtv.com/viewtopic.php?f=35&t=133).
Demo
n00b
 
Posts: 5
Joined: Fri Apr 23, 2010 2:09 pm

Next

Return to Comments & Suggestions about wdlxtv.com websites

Who is online

Users browsing this forum: No registered users and 1 guest