Page 2 of 2

Re: nfs server

PostPosted: Thu Sep 04, 2014 6:58 pm
by KAD
nfs-utils is building now

but something odd README in nfs-utils package states it's critical that rpc.mountd and exportfs be started before rpc.nfsd

and I'm using the S94nfsserver start script from WDLXTV which starts rpc.nfsd before anything else the only item started prior to nfsd is portmap

edit: new nfs-utils has the same result as debian-squeeze binaries
also changing the daemons start order did not change the result

Re: nfs server

PostPosted: Thu Sep 04, 2014 9:43 pm
by mad_ady
I'm not sure if you can start the NFS daemon with strace (and write the output to a log file). Also, if you can do it, instruct strace to follow forks. You should at least see what it dies of...

Re: nfs server

PostPosted: Fri Sep 05, 2014 6:58 pm
by KAD
well, I'm out of idea's

strace and packet captures are not providing me any usefull info

I did confirm that only nfs version 2 is being exported/available
but specify vers=2 still fails

I guess, I'll have to ditch the idea of adding nfs server

unless somebody else has a brilliant idea

Re: nfs server

PostPosted: Sat Sep 06, 2014 1:21 pm
by KAD
well I found that specifying vers=2

the error message in kernel log is different
"kernel: nfsd: peername failed (err 134)!".

but I also found RMerlin had the same issue with router firmware, and was unable to find any fix

http://www.smallnetbuilder.com/forums/showthread.php?p=125930

and what's even more ironic, the user reporting the error was using the nfs server on his router, to share to a WD SMP
what's unclear is the error coming from the kernel itself or the kernel module

either way, I don't think I can fix it

Re: nfs server

PostPosted: Tue Sep 09, 2014 8:41 pm
by KAD
I couldn't help myself decided to try again

/tmp/messages.txt
Code: Select all
svc: 192.168.1.123, port=706: unknown version (4 for prog 100003, nfsd)
Sep 10 04:30:36 (none) kernel: svc: 192.168.1.123, port=39398: unknown version (3 for prog 100003, nfsd)
Sep 10 04:30:36 (none) kernel: svc: 192.168.1.123, port=41789: unknown version (3 for prog 100003, nfsd)
Sep 10 04:30:55 (none) mountd[6184]: authenticated mount request from 192.168.1.123:757 for /tmp/media/usb/USB1140/965D-5276 (/tmp/media/usb/USB1140/965D-5276)
Sep 10 04:30:55 (none) kernel: CPU 0 Unable to handle kernel paging request at virtual address 0000008c, epc == c1011480, ra == c1011478
Sep 10 04:30:55 (none) kernel: Oops[#3]:
Sep 10 04:30:55 (none) kernel: Cpu 0
Sep 10 04:30:55 (none) kernel: $ 0   : 00000000 00000000 00000000 84010000
Sep 10 04:30:55 (none) kernel: $ 4   : 00000040 00000000 00000054 00020e3c
Sep 10 04:30:55 (none) kernel: $ 8   : 00000000 00000040 91d32700 84880000
Sep 10 04:30:55 (none) kernel: $12   : dc311760 ffd23940 00000000 00000000
Sep 10 04:30:55 (none) kernel: $16   : 00000000 00000020 9247204c 9201dd80
Sep 10 04:30:55 (none) kernel: $20   : 9255f018 9255f018 c1013750 c100f900
Sep 10 04:30:55 (none) kernel: $24   : 00000000 84480370
Sep 10 04:30:55 (none) kernel: $28   : 91d52000 91d53e00 8400b7a0 c1011478
Sep 10 04:30:55 (none) kernel: Hi    : 00000252
Sep 10 04:30:55 (none) kernel: Lo    : b2c79c80
Sep 10 04:30:55 (none) kernel: epc   : c1011480 decode_fh+0x3c/0x74 [nfsd]
Sep 10 04:30:55 (none) kernel:     Tainted: P      D W
Sep 10 04:30:55 (none) kernel: ra    : c1011478 decode_fh+0x34/0x74 [nfsd]
Sep 10 04:30:55 (none) kernel: Status: 1000dc03    KERNEL EXL IE
Sep 10 04:30:55 (none) kernel: Cause : 0080000c
Sep 10 04:30:55 (none) kernel: BadVA : 0000008c
Sep 10 04:30:55 (none) kernel: PrId  : 0001937c (MIPS 24Kc)
Sep 10 04:30:55 (none) kernel: Modules linked in: nfsd exportfs 8192cu cifs wdtv_rv_microp i2c_hal fctrl(P) ufsd(P) proc_pipe irkernel em8xxx(P) llad(P) [last unloaded: llad]
Sep 10 04:30:55 (none) kernel: Process nfsd (pid: 6179, threadinfo=91d52000, task=87e31b48, tls=00000000)
Sep 10 04:30:55 (none) kernel: Stack : 9255f00c 84480514 00000000 00000001 91cae000 c10139cc 84880000 c10119f8
Sep 10 04:30:55 (none) kernel:         9255f018 9255f018 c1013750 c100f900 91cae000 c10033e4 91d53e80 9201dd80
Sep 10 04:30:55 (none) kernel:         00000002 8447f420 00000000 91cae000 84880000 c10139cc 9201dd80 9255f018
Sep 10 04:30:55 (none) kernel:         00000011 8447a2cc 840375e0 00100100 00200200 84463ca0 91caed90 8403e434
Sep 10 04:30:55 (none) kernel:         01000000 fffffff5 0000006c fffffff5 00057e40 8448aea4 91cae000 fffffffc
Sep 10 04:30:55 (none) kernel:         ...
Sep 10 04:30:55 (none) kernel: Call Trace:
Sep 10 04:30:55 (none) kernel: [<c1011480>] decode_fh+0x3c/0x74 [nfsd]
Sep 10 04:30:55 (none) kernel: [<c10119f8>] nfssvc_decode_fhandle+0x24/0x6c [nfsd]
Sep 10 04:30:55 (none) kernel: [<c10033e4>] nfsd_dispatch+0xb0/0x2cc [nfsd]
Sep 10 04:30:55 (none) kernel: [<8447a2cc>] svc_process+0x48c/0x848
Sep 10 04:30:55 (none) kernel: [<c1003d44>] nfsd+0x164/0x224 [nfsd]
Sep 10 04:30:55 (none) kernel: [<84057bbc>] kthread+0x84/0x8c
Sep 10 04:30:55 (none) kernel: [<84017d88>] kernel_thread_helper+0x10/0x18
Sep 10 04:30:55 (none) kernel: Code: 00002821  24110020  3c038401 <ae11008c> 26040004  02402821  2463637c  0060f809  24060020



you can see v 3 & 4 fail as expected
v2 authenticates properly
Kernel error message is
Code: Select all
kernel: CPU 0 Unable to handle kernel paging request at virtual address 0000008c, epc == c1011480, ra == c1011478

on the client side all that is visible is that mount attempt hangs

probably still not fixable, but interesting

Re: nfs server

PostPosted: Wed Sep 10, 2014 2:13 am
by kroetkroet
Couldn't help to google bit too, although this is way out of my comfort zone :lol:

I started from here: https://lkml.org/lkml/2002/7/23/47, these guys also got NFS issues (on an SMP box), at the same virtual address as you (0000008c). I read through the answers, something with kernel compile preempt came up, something with corrupt memory and network drivers. Don't know if it helps you further down the line?

Why don't you use samba? :mrgreen:

Re: nfs server

PostPosted: Wed Sep 10, 2014 7:57 am
by KAD
lol, it's way out of what I should be doing, but hey learning a lot

and like usuall, I will probably never use the function (all my media is already on a home server)
just keeping myself busy, adding more stuff to SMP firmware

Re: nfs server

PostPosted: Thu Sep 11, 2014 2:45 am
by recliq
This really sounds like a kernel problem... :( if this is the case there's not much you can do to fix it (signed kernel yadayadayada...)

Re: nfs server

PostPosted: Thu Sep 11, 2014 6:58 am
by kroetkroet
yada yada yada :lol:

and then I stopped reading :mrgreen: