Page 2 of 2

Re: segmentation fault while using aria2

PostPosted: Mon Mar 25, 2013 6:34 am
by avkiev
wisetube wrote:Unfortunately the link on rapidshare from here doesn't really work: http://forum.wdlxtv.com/viewtopic.php?f=43&t=494
So, I would really appreciate the app.bin, probably the missing squeeze filesystem image from the post above or any other advice how to proceed.

You can try this link: WDTV Tools Development VMware Image
It is old, but I hope it can helps
Good luck ;)

Re: segmentation fault while using aria2

PostPosted: Mon Mar 25, 2013 9:35 am
by recliq
I think that VMWare image is for Gen1 development, if it includes the WD toolchain you need to change that at least...

Re: segmentation fault while using aria2

PostPosted: Tue Mar 26, 2013 8:41 am
by Alicia
recliq wrote:I think that VMWare image is for Gen1 development, if it includes the WD toolchain you need to change that at least...


true, it's for Gen1. And it includes the toolchain.

Re: segmentation fault while using aria2

PostPosted: Sat Mar 30, 2013 7:45 am
by recliq
Ok, I recovered my VBox images and did some compiling...

Here's a very basic aria2.app.bin, no configuration or init scripts included yet.
I haven't tested this app, I can just say it runs... I leave the testing to those how know this app.

aria2.app.bin
:ugeek:

Re: segmentation fault while using aria2

PostPosted: Sat Mar 30, 2013 11:14 am
by wisetube
hi recliq,

thanks! the basic is working. I will continue testing.
meanwhile, please find my input for your beer in paypal ;) (from andrr567)

thanks,
Andriy

Re: segmentation fault while using aria2

PostPosted: Sat Feb 17, 2018 2:37 am
by t123321
I have compiled aria2 1.17 using debian squeeze image.
In order to compile newer versions we have to use gcc 4.6.3 or newer
Currently in squeeze image we have gcc 4.4.5. Is there any way to update gcc?
I have tried with no success.

Re: segmentation fault while using aria2

PostPosted: Sun Feb 18, 2018 11:23 pm
by mad_ady
I think you need to compile it from its source.

Re: segmentation fault while using aria2

PostPosted: Sat Feb 24, 2018 7:43 am
by t123321
Thats how i compiled aria 1.17. I downloaded source and compiled it. I build an app and everything is fine.
The problem is that to compile newer versions you need gcc 4.6.3
I use debian squeeze image uploaded by b-rad back in 2010. The image has gcc 4.4.5 and i cant upgrade it.

Re: segmentation fault while using aria2

PostPosted: Mon Feb 26, 2018 3:46 am
by mad_ady
See if this guide helps:
https://gist.github.com/jtilly/2827af06e331e8e6b53c
It will probably take a long time to compile and a lot of disk space.