Page 1 of 1

[SOLVED] Netflix + Canada + WDLXTV Live Plus

PostPosted: Wed Jun 06, 2012 6:24 am
by german
Hi all,

Apologies if this is a really stupid question, but reading through the Netflix-related posts on here I can't seem to find a straightforward answer. I'm using a WDTV Live Plus that's perhaps 18 months old, in Canada. For the longest time I've been on WDLXTV Live Plus 1_03_39.B-WDLXTV (from memory), which was a release where Netflix would pop up "Sorry, this device cannot be authorized" or something similar. I upgraded straight from this release to the latest 1.05.04_B-WDLXTV-Plus-0.5.1.1 this morning, and was able to log in and browse shows, and got as far as "This title can't be played, please try again later or select another episode" (again, from memory). My understanding from this forum is that it's because I don't have the correct crypto keys for Netflix. Is there some way I can obtain these keys without a lot of hassle to enable Netflix?

Edit: This is how to make Netflix work if you're in a similar situation. Note this WILL wipe your config, for me all I lost was screen resolution settings and SMB password, but be warned!
  • Get a USB stick you know works to flash a new firmware (although you won't need to do that)
  • Start Netflix app, and hit up, up, down, down, left, right, left, right, up, up, up, up, and unregister Netflix from the device
  • Download the official firmware from http://download.wdc.com/wdtv/wdtvliveplus_1.06.16_B.zip
  • Extract the files in the zip and copy wdtvlive2.bin to the root of your USB stick AND RENAME IT wdtvlive.bin
  • Follow the instructions at http://wiki.wdlxtv.com/Booting_Original_FW but don't reboot yet!
  • Instead of issuing the final set of commands starting with config_tool -c ROOT_TAG='104', issue the command:
    Code: Select all
    rm -r /conf/* && config_tool -s && config_tool -s && reboot
  • Your device will restart (mine came up on composite video and I had to change my TV input).
  • Once it has booted, telnet back in and issue the commands from the wiki HOWTO:
    Code: Select all
    config_tool -c ROOT_TAG='104'; config_tool -s; config_tool -s; reboot
  • Your device should now boot the stock firmware. When I started Netflix from the USB stick, it timed out a few times and I had to hit "retry", but eventually it let me log in and I could watch it.
  • After about 5-10 minutes of Futurama I pressed stop, then the home button, said "yes I want to exit Netflix", and once I was back at OSD, pressed the power button.
  • Pull the USB stick, and push the power button again.
  • At this point you should have working Netflix, so reconfigure your SMB password and TV resolution, and enjoy!

Re: Netflix + Canada + WDLXTV Live Plus

PostPosted: Wed Jun 06, 2012 10:48 pm
by mad_ady
If you didn't use netflix on the stock firmware, the correct keys/settings were never completed.
You need to boot an official firmware, activate netflix, watch some content for a while, and then upgrade to wdlxtv.

Re: Netflix + Canada + WDLXTV Live Plus

PostPosted: Thu Jun 07, 2012 2:07 am
by RevDrew
read this thread, it gives you good info and I think the files you need.

I had netflix for a month, only things I saw on it were already at least 2 years old, I let it go after the free trial.

http://forum.wdlxtv.com/viewtopic.php?f=38&t=5202

Re: Netflix + Canada + WDLXTV Live Plus

PostPosted: Thu Jun 07, 2012 6:43 am
by german
Thanks for the info, guys. I was hoping to be able to do this without flashing a stock firmware but I guess it's not going to happen. If I make it work I'll report back on what I did here.

Re: Netflix + Canada + WDLXTV Live Plus

PostPosted: Thu Jun 07, 2012 9:27 pm
by mad_ady
You don't have to flash - you can boot the official firmware off the USB drive, but it involves a bit more work: http://wiki.wdlxtv.com/Booting_Original_FW

Re: Netflix + Canada + WDLXTV Live Plus

PostPosted: Fri Jun 08, 2012 7:33 pm
by german
Thanks mad_ady, I've read through that wiki post and I understand what needs doing to create a bootable USB firmware. Once I've got the stock firmware booted off a usb stick, do I need to do any manual file management after I get netflix working? Or literally "play netflix for a while; reboot to wdlxtv"?

Edit: I'm booted into 1.06.16B official via the method mad_ady linked, but Netflix won't play (I deactivated it in wdlxtv prior to booting from USB). So, I'm not sure what my problem is at this point. Any suggestions welcome, I'll keep tinkering and if I succeed, will report back here.

Edit 2: I booted back into wdlxtv, wiped /conf as described in http://forum.wdlxtv.com/viewtopic.php?f=38&t=5202 and rebooted, logged back in and did a config_tool -c ROOT_TAG='104' && config_tool -s && config_tool -s && reboot, and after that I could watch Netflix on the stock firmware running off the USB stick. Watched a few minutes of Futurama, exited to the OSD launcher thing, turned off the WDTV and pulled the USB stick, turned it back on, and it still works! BOOYA!

Re: [SOLVED] Netflix + Canada + WDLXTV Live Plus

PostPosted: Fri Jul 06, 2012 1:01 pm
by Angus_NB
Thanks guys, great instructions. Followed the Wiki and am now watching Netflix.