Sign up here and you can log into the forum!

rtorrent and magnet links

This is the place to ask for how to use software that is (or isn't) included in the various wdlxtv flavours. Questions about software such as rtorrent, NZBGet, sshfs, curlftpfs, ssh, telnet, etc.

Re: rtorrent and magnet links   

Postby mystacor » Fri Sep 14, 2012 3:54 am

Does anyone of you work with "aria2" (package from optware). It also supports magnet links.

Cheers mystacor
mystacor
n00b
 
Posts: 12
Joined: Sun Sep 09, 2012 2:00 am

Re: rtorrent and magnet links   

Postby lula77 » Wed Sep 26, 2012 11:43 am

I could install 0.9.2 with no problem but when trying to download a magnet link as soon as it finishes it goes to pause status instead of seeding. Could someone help on that ? The same when trying .torrent. All changing to Pause instead of Seeding.

also this message appears on General tab

Save as: X-Powered-By: PHP/5.3.2-1 Content-type: text/html /tmp/rt/rtorrent/finished/Windows 8 Activator.rar
lula77
n00b
 
Posts: 3
Joined: Tue Oct 18, 2011 4:14 pm

Re: rtorrent and magnet links   

Postby mcfoka » Sun Oct 07, 2012 10:01 am

Hi,

I'm pretty new to wdxltv soft and rtorrent as well.
What I need is torrent client that's accepted by priv-tracker I use, so either transmission 2.13 or rtorrent. I've managed to get transmission running, and I like remote access it has very like, but from what I understand rtorrent is faster solution, and it has one functionality I miss in transmission - easy unpacking after torent is downloaded.
So looking for newer than stock version of rtorrent I downloaded 0.9.2.app and I've managed to start it but I cant get it to work the way I want it.
I was able to run it changing rtorrent.rc the way it's described, but I manage to break it by setting wrong download dir. Then I tried to edit rtorrent.rc and rtorrent-0.9.2.rc to change download directory to /tmp/mnt/xyz/downloads but it wont apply my changes... it keeps downloading torrents to default "/tmp/rt/rtorrent/.incomplete" download directory (I dont have auto move on). If I edit rtorrent and rtorrent-0.9.2.rc and change the directory and few other settings(ports/slots) rtorrent wont start with:

Starting rtorrent-0.9.2 config saved val:key => (PLUGIN_WEBDIRS,mt-daapd|/usr/share/mt-daapd,umsp|/usr/share/umsp,nzbgetweb|/usr/share/nzbgetweb,rtorrent|/usr/share/rutorrent,transmission-daemon|/apps/transmission/usr/share/transmission/web) config saved val:key => (PLUGIN_WEBDIRS,mt-daapd|/usr/share/mt-daapd,umsp|/usr/share/umsp,nzbgetweb|/usr/share/nzbgetweb,rtorrent|/usr/share/rutorrent,transmission-daemon|/apps/transmission/usr/share/transmission/web,rtorrent-0.9.2|/apps/rtorrent-0.9.2/var/www/rutorrent-3.4) S92rtorrent: Starting bittorrent: rtorrent-0.9.2 S92rtorrent: executing deleted console workaround . S92rtorrent: rtorrent started successfully Done


or
Starting rtorrent-0.9.2

config saved val:key => (PLUGIN_WEBDIRS,mt-daapd|/usr/share/mt-daapd,umsp|/usr/share/umsp,nzbgetweb|/usr/share/nzbgetweb,rtorrent|/usr/share/rutorrent,transmission-daemon|/apps/transmission/usr/share/transmission/web)
config saved val:key => (PLUGIN_WEBDIRS,mt-daapd|/usr/share/mt-daapd,umsp|/usr/share/umsp,nzbgetweb|/usr/share/nzbgetweb,rtorrent|/usr/share/rutorrent,transmission-daemon|/apps/transmission/usr/share/transmission/web,rtorrent-0.9.2|/apps/rtorrent-0.9.2/var/www/rutorrent-3.4)
S92rtorrent: Starting bittorrent: rtorrent-0.9.2
S92rtorrent: executing deleted console workaround
.
S92rtorrent: rtorrent started successfully
renice: getpriority: No such process
Done

I can manage to get it back, by deleting config files and letting it create it's own, but again, if i change anything via webend - I'm getting nowhere - changes wont apply, and after reboot they're gone.

I'd be grateful for any help solving this. (alternatively if someone could point me out to a simple way of getting transmission to unrar my torrents after they've completed downloading...)

EDIT:
after some more tries I've managed to get rtorrent to save settings, but I'm still not able to download torrent to my set directory, getting "wrong directory" error.
My disk is at:
Code: Select all
Mount point: /tmp/mnt/F21843B31843759F
Device: /dev/sda1
Options: rw,noatime,nodiratime,nls=utf8,uid=0,gid=0,fmask=0,dmask=0,sparse

and my settings:
Code: Select all
# Default directory to save the downloaded torrents.
directory = /tmp/mnt/F21843B31843759F/!sciagniete

# Default session directory. Make sure you don't run multiple instance
# of rtorrent using the same session directory. Perhaps using a
# relative path?
session = /tmp/mnt/F21843B31843759F/!sciagniete
mcfoka
n00b
 
Posts: 1
Joined: Sun Oct 07, 2012 9:37 am

Re: rtorrent and magnet links   

Postby workingman » Wed Oct 10, 2012 12:40 pm

lula77 wrote:I could install 0.9.2 with no problem but when trying to download a magnet link as soon as it finishes it goes to pause status instead of seeding. Could someone help on that ? The same when trying .torrent. All changing to Pause instead of Seeding.

also this message appears on General tab

Save as: X-Powered-By: PHP/5.3.2-1 Content-type: text/html /tmp/rt/rtorrent/finished/Windows 8 Activator.rar


Hi lula,

I managed to reproduce that as well and does seem to be related to the move completed torrent option. If you right click and Save To... the path in there has that X-Powered-By stuff

I removed that up to /tmp right clicked again and did force recheck and they are seeding properly. Not sure yet why it's happening at all though. Will test some more and post back if I find anything.
workingman
DLX'er
 
Posts: 68
Joined: Sun Apr 01, 2012 3:04 pm
Location: Montreal, Canada

Re: rtorrent and magnet links   

Postby workingman » Wed Oct 10, 2012 12:54 pm

mcfoka wrote:Hi,

I'd be grateful for any help solving this. (alternatively if someone could point me out to a simple way of getting transmission to unrar my torrents after they've completed downloading...)

EDIT:
after some more tries I've managed to get rtorrent to save settings, but I'm still not able to download torrent to my set directory, getting "wrong directory" error.
My disk is at:
Code: Select all
Mount point: /tmp/mnt/F21843B31843759F
Device: /dev/sda1
Options: rw,noatime,nodiratime,nls=utf8,uid=0,gid=0,fmask=0,dmask=0,sparse

and my settings:
Code: Select all
# Default directory to save the downloaded torrents.
directory = /tmp/mnt/F21843B31843759F/!sciagniete

# Default session directory. Make sure you don't run multiple instance
# of rtorrent using the same session directory. Perhaps using a
# relative path?
session = /tmp/mnt/F21843B31843759F/!sciagniete


Hi mcfoka,

If you want rtorrent to unpack your torrents when complete you have to turn off the automove feature. Check: http://wiki.wdlxtv.com/How_to_use_rTorrent#Automatic_unpack_torrents_when_finished

Are you sure you want to have an ! point in your directory name..?

Also you should be setting that /tmp/mnt/F21843B31843759F directory in the web front end -> rtorrent -> config

Then just keep it simple in your rtorrent.rc
Code: Select all
# Default directory to save the downloaded torrents.
directory = /tmp/rt/rtorrent/.incomplete

# Default session directory. Make sure you don't run multiple instance
# of rtorrent using the same session directory. Perhaps using a
# relative path?
session = /tmp/rt/rtorrent/.session


The system will create some nice links for you.
Code: Select all
ls -la /tmp/rt
lrwxrwxrwx    1 root     root           46 Oct 10 15:31 /tmp/rt -> /tmp/mnt/ae9463c5-efdb-4b91-b8ba-705115b0c06c/
# ls -la /tmp/rt/rtorrent
drwxrwxrwx    6 root     root         4096 Sep 14 15:19 .
drwxr-xr-x   10 root     root         4096 Sep 14 15:21 ..
drwxrwxrwx  210 root     root        20480 Oct 10 16:00 .incomplete
drwxrwxrwx    5 root     root        73728 Oct 10 16:32 .session
drwxrwxrwx    2 root     root         4096 Oct 10 16:00 finished
drwxrwxrwx    2 root     root         4096 Oct  8 02:34 torrents


HTH!
workingman
DLX'er
 
Posts: 68
Joined: Sun Apr 01, 2012 3:04 pm
Location: Montreal, Canada

Re: rtorrent and magnet links   

Postby workingman » Wed Oct 10, 2012 1:19 pm

lula77 wrote:I could install 0.9.2 with no problem but when trying to download a magnet link as soon as it finishes it goes to pause status instead of seeding. Could someone help on that ? The same when trying .torrent. All changing to Pause instead of Seeding.

also this message appears on General tab

Save as: X-Powered-By: PHP/5.3.2-1 Content-type: text/html /tmp/rt/rtorrent/finished/Windows 8 Activator.rar


Found some hard coded paths in the original autotools setup file. Will test a new version later this evening and post another update if I fix it.

Thanks for letting me know lula!
workingman
DLX'er
 
Posts: 68
Joined: Sun Apr 01, 2012 3:04 pm
Location: Montreal, Canada

Re: rtorrent and magnet links   

Postby workingman » Wed Oct 10, 2012 6:13 pm

No luck guys.. seems like autotools are all broken actually. At least my watch directory wasn't working and neither was move on complete.

I'm long passed the point of diminishing returns though so I'll going to have to leave it and try again tomorrow.
workingman
DLX'er
 
Posts: 68
Joined: Sun Apr 01, 2012 3:04 pm
Location: Montreal, Canada

Re: rtorrent and magnet links   

Postby se7zer » Thu Oct 11, 2012 5:47 am

Hi,

sorry to intrude the topic. I would pretty much like to download the rtorrent.0.9.2.app.bin.
I would like to create one app.bin even to compile rtorrent on the WDTV, but I need to study some more first.

The link for the rtorrent.0.9.2.app.bin is broken. Can someone upload it again?
The reason I want this version is that it MAY accept torrents with special non ASCII characters.
0.8.6 doesn't work with the encoding = UTF-8 option in /conf/rtorrent.rc.

Thanks
se7zer
n00b
 
Posts: 10
Joined: Mon Oct 08, 2012 7:14 am

Re: rtorrent and magnet links   

Postby workingman » Thu Oct 11, 2012 12:31 pm

Hi se7zer,

Sorry! When I was working on it yesterday I moved it assuming I'd be uploading a new version after I fixed the move on complete issue.

I still haven't fixed that but have found that thankfully the watch directory function isn't broken too so it's just move on complete that I need to fix.

I've just put the most recent working version back where it was so that link should work again.

Don't think I'm going to get a chance to fix the move on complete today... sorry guys. Still not exactly sure what's wrong either :(

If you want I can test that UTF-8 encoding for you.. just point me at a troublesome torrent file and I'll give it a try.
workingman
DLX'er
 
Posts: 68
Joined: Sun Apr 01, 2012 3:04 pm
Location: Montreal, Canada

Re: rtorrent and magnet links   

Postby se7zer » Thu Oct 11, 2012 2:09 pm

Thank you workingman,

I am using your rtorrent-0.9.2 and special characters non ASCII torrents does not work on the WDbox. It does on Ubuntu 12.04 thou.
Seems to be a limitation on the way busybox handles characters, so after hashing rtorrent can't find the filenames which contains ç, ã, etc.

=[

Still I hope it will work on ascii char torrents :D
se7zer
n00b
 
Posts: 10
Joined: Mon Oct 08, 2012 7:14 am

PreviousNext

Return to Application Questions

Who is online

Users browsing this forum: No registered users and 3 guests