Sign up here and you can log into the forum!

rtorrent failed to start 1.05.04_V-WDLXTV-Live-0.5.1.1

This is the place to ask for how to use software that is (or isn't) included in the various wdlxtv flavours. Questions about software such as rtorrent, NZBGet, sshfs, curlftpfs, ssh, telnet, etc.

rtorrent failed to start 1.05.04_V-WDLXTV-Live-0.5.1.1   

Postby aft3rgl0w » Sat Dec 24, 2011 11:08 am

Hi all.
First time i flashed my wdtv live i used "1.03.49_V-WDLXTV-Live-0.4.7.3 [flash]" and i had correctly set up rtorrent as explained in wiki and it was working fine (i had also commented out the #encoding_list = UTF-8,UTF8,UTF-16,UTF16)line.
today i simply downloaded and flashed "1.05.04_V-WDLXTV-Live-0.5.1.1 [flash]"
rtorrent didnt work so i said ill clean out conf/rtorrent.rc as well as delete .mnt file and rtorrent directory and mainyl start from scratch again.

i have tried every step of the wiki and i still cant get it to work.
when i click enable rtorrent on webend i get the following error messages:


config saved val:key => (PLUGIN_WEBDIRS,mt-daapd|/usr/share/mt-daapd,nzbgetweb|/usr/share/nzbgetweb,umsp|/usr/share/umsp)
config saved val:key => (PLUGIN_WEBDIRS,mt-daapd|/usr/share/mt-daapd,nzbgetweb|/usr/share/nzbgetweb,umsp|/usr/share/umsp,rtorrent|/usr/share/rutorrent)
S96rtorrent: Starting bittorrent: rtorrent
S96rtorrent: executing deleted console workaround
.
S96rtorrent: rtorrent failed to start!!!
Done




basically i have my .mnt file on root of the hdd. the hdd is also mounted as /tmp/mnt/B03CB1C43CB1863E also created the rtorrent directory on that hdd and at some point it created me 4 directories inside that.(.incomplete,.session,finished,torrents) permissions seem ok (777).

my /conf/rtorrent.rc basically looks like this:
# Default directory to save the downloaded torrents.
directory = /tmp/mnt/B03CB1C43CB1863E/rtorrent/

session = /tmp/mnt/B03CB1C43CB1863E/rtorrent/


#encoding_list = UTF-8,UTF8,UTF-16,UTF16 ( i tried uncommenting the line too not sure how it should be on this FW level????....)



now on webend config
i have ticked "enable rtorrent" and RTORRENT_DIR=/tmp/mnt/B03CB1C43CB1863E/ (do i need to have /tmp/mnt/B03CB1C43CB1863E/rtorrent instead)

i also tried flashing with the 3 firmware files on usb and S00custom-options. (the usb is the same used a few days ago to flash previous fw and its hard formatted FAT32.)

basically my file looks like:

config_tool -c RTORRENT=ON
config_tool -c RTORRENT_DIR=/tmp/mnt/B03CB1C43CB1863E/


lastly when i flash with S00custom-options, do i just put the file at the root of the drive or i have also have to have it withing the "extra" directory and then place that at the root of the usb drive? ( i tried both as i wasnt sure)
well if you got that far and have an idea then thanks much and merry xmas :)
aft3rgl0w
n00b
 
Posts: 1
Joined: Sat Dec 24, 2011 10:36 am

Re: rtorrent failed to start 1.05.04_V-WDLXTV-Live-0.5.1.1   

Postby Faith » Tue Apr 09, 2013 12:51 am

The same was here, I have managed this issue by deleting the rtorrent.lock file in rtorrent/.session folder.
After this it was started normally.
Faith
n00b
 
Posts: 9
Joined: Sun Sep 19, 2010 6:34 am


Return to Application Questions

Who is online

Users browsing this forum: No registered users and 1 guest