Sign up here and you can log into the forum!

[REQUEST - £10 waiting!] SABNZB+

This is the place to ask for how to use software that is (or isn't) included in the various wdlxtv flavours. Questions about software such as rtorrent, NZBGet, sshfs, curlftpfs, ssh, telnet, etc.

Re: [REQUEST - £10 waiting!] SABNZB+   

Postby spazlon » Sun Dec 11, 2011 6:43 pm

I don't get what I am doing wrong. I have tried everything I can think of for the last 3 days. Here is the output I get when I start SABNZB+:

Code: Select all
# /opt/bin/python2.5 /opt/share/SABnzbd/SABnzbd.py -f /opt/share/SABnzbd/sabnzbd.ini -w 1 -l 2 --log-all --browser 0
2011-12-11 18:35:46,642::INFO::[SABnzbd:973] --------------------------------
2011-12-11 18:35:46,647::INFO::[SABnzbd:974] SABnzbd.py-0.5.6 (rev=2503)
2011-12-11 18:35:46,651::INFO::[SABnzbd:984] Platform = posix
2011-12-11 18:35:46,656::INFO::[SABnzbd:985] Python-version = 2.5.6 (r256:88840, May 30 2011, 08:30:43)
[GCC 4.0.4]
2011-12-11 18:35:46,766::DEBUG::[lang:132] Language file /opt/share/SABnzbd/language/us-en.txt, encoding=latin-1, language=English (US)
2011-12-11 18:35:47,244::DEBUG::[__init__:671] Loading data for bookmarks.sab from /opt/share/SABnzbd/cache/bookmarks.sab
2011-12-11 18:35:47,251::INFO::[__init__:702] /opt/share/SABnzbd/cache/bookmarks.sab removed
2011-12-11 18:35:47,262::DEBUG::[__init__:671] Loading data for rss_data.sab from /opt/share/SABnzbd/cache/rss_data.sab
2011-12-11 18:35:47,269::DEBUG::[scheduler:123] Scheduling RSS interval task every 60 min (delay=17)
2011-12-11 18:35:47,275::DEBUG::[scheduler:134] Scheduling VersionCheck on day 4 at 12:16
2011-12-11 18:35:47,281::DEBUG::[__init__:671] Loading data for bytes9.sab from /opt/share/SABnzbd/cache/bytes9.sab
2011-12-11 18:35:47,288::DEBUG::[__init__:671] Loading data for queue9.sab from /opt/share/SABnzbd/cache/queue9.sab
2011-12-11 18:35:47,297::INFO::[postproc:139] Loading postproc queue
2011-12-11 18:35:47,302::DEBUG::[__init__:671] Loading data for postproc1.sab from /opt/share/SABnzbd/cache/postproc1.sab
2011-12-11 18:35:47,309::INFO::[__init__:702] /opt/share/SABnzbd/cache/postproc1.sab removed
2011-12-11 18:35:47,317::DEBUG::[downloader:253] Initializing downloader/decoder
2011-12-11 18:35:47,325::DEBUG::[__init__:671] Loading data for watched_data.sab from /opt/share/SABnzbd/cache/watched_data.sab
2011-12-11 18:35:47,335::INFO::[downloader:334] Resuming
2011-12-11 18:35:47,340::DEBUG::[__init__:405] PAUSED_ALL inactive
2011-12-11 18:35:47,480::INFO::[__init__:251] All processes started
2011-12-11 18:35:47,488::INFO::[SABnzbd:269] Web dir is /opt/share/SABnzbd/interfaces/Classic
2011-12-11 18:35:47,495::DEBUG::[lang:132] Language file /opt/share/SABnzbd/interfaces/wizard/language/us-en.txt, encoding=latin-1, language=United States
2011-12-11 18:35:47,662::INFO::[SABnzbd:1038] Starting SABnzbd.py-0.5.6
2011-12-11 18:35:47,667::DEBUG::[__init__:262] Starting postprocessor
2011-12-11 18:35:47,686::DEBUG::[__init__:265] Starting assembler
2011-12-11 18:35:47,701::DEBUG::[__init__:268] Starting downloader
2011-12-11 18:35:47,711::DEBUG::[scheduler:159] Starting scheduler
2011-12-11 18:35:47,723::DEBUG::[__init__:273] Starting dirscanner
2011-12-11 18:35:47,731::DEBUG::[newzbin:100] Starting msgidgrabber
2011-12-11 18:35:47,728::INFO::[dirscanner:375] Dirscanner starting up
2011-12-11 18:35:47,741::DEBUG::[__init__:278] Starting urlgrabber
2011-12-11 18:35:47,747::INFO::[urlgrabber:103] URLGrabber starting up
2011-12-11 18:35:47,756::INFO::[SABnzbd:390] _yenc module... found!
2011-12-11 18:35:47,760::INFO::[SABnzbd:398] par2 binary... found (/opt/bin/par2)
2011-12-11 18:35:47,766::INFO::[SABnzbd:406] unrar binary... found (/opt/wrappers/unrar)
2011-12-11 18:35:47,770::INFO::[SABnzbd:411] unzip binary... found (/opt/wrappers/unzip)
2011-12-11 18:35:47,775::INFO::[SABnzbd:417] nice binary... found (/opt/wrappers/nice)
2011-12-11 18:35:47,780::INFO::[SABnzbd:421] ionice binary... found (/opt/wrappers/ionice)
2011-12-11 18:35:47,785::INFO::[SABnzbd:426] pyOpenSSL... found (True)
2011-12-11 18:35:47,900::INFO::[SABnzbd:1136] Starting web-interface on localhost:8080
[11/Dec/2011:18:35:47] ENGINE Bus STARTING
2011-12-11 18:35:47,908::INFO::[_cplogging:55] [11/Dec/2011:18:35:47] ENGINE Bus STARTING
[11/Dec/2011:18:35:47] ENGINE Started monitor thread '_TimeoutMonitor'.
2011-12-11 18:35:47,964::INFO::[_cplogging:55] [11/Dec/2011:18:35:47] ENGINE Started monitor thread '_TimeoutMonitor'.
[11/Dec/2011:18:35:48] ENGINE Serving on localhost:8080
2011-12-11 18:35:48,099::INFO::[_cplogging:55] [11/Dec/2011:18:35:48] ENGINE Serving on localhost:8080
[11/Dec/2011:18:35:48] ENGINE Bus STARTED
2011-12-11 18:35:48,111::INFO::[_cplogging:55] [11/Dec/2011:18:35:48] ENGINE Bus STARTED
2011-12-11 18:35:49,100::DEBUG::[misc:695] Checked for a new release, cur= 50699, latest= 61499 (on http://sourceforge.net/projects/sabnzbdplus/files/sabnzbdplus/sabnzbd-0.6.14)
2011-12-11 18:36:02,282::INFO::[rss:376] Running scheduled RSS scan


It looks like everything is running fine. When I try to access http://192.168.1.111:8080/sabnzbd from the browser on my PC it says "Unable to Connect. Firefox can't establish a connection to the server at 192.168.1.111:8080." I know that is my IP address.

Next I open another SSH and use lynx to connect to http://192.168.1.111:8080/sabnzbd. It opens and redirects me to http://192.168.1.111:8080/wizard. Fine, I go through the wizard and tell it to allow connections from any computer on the network. I close lynx, restart sabnzbd, and sabnzbd says it is listening on 0.0.0.0:8080. So I stop sabnzbd, edit sabnzbd.ini, change host to localhost, restart sabnzbd and it wants to run the wizard again.

What am I doing wrong? I have tried python 2.5 and 2.6.

I am running WDLXTV Live Plus 1.03.49 0.4.7.3.
WDLXTV Live+ 1.05.04_.0.5.1.1 SVN on external USB
spazlon
WDTVer
 
Posts: 45
Joined: Sat Jan 29, 2011 11:39 am
Location: Mangaf, Kuwait

Re: [REQUEST - £10 waiting!] SABNZB+   

Postby spazlon » Sun Dec 11, 2011 7:36 pm

Ok, so after taking a break I finally figured it out.

The 0.0.0.0 means it is listening for any computer on the network. Also, running lynx doesn't set it up correctly so that's why it was failing. The solution is to set host = 0.0.0.0 manualy in the sabnzbd.ini file, then load wdlxtv ip:8080/wizard (sabnzbd automatically redirects there) and do the wizard config there.

Now I have a problem with the init.d script. In my /opt/etc/init.d I have S89SABnzbd with the following:

Code: Select all
#!/opt/bin/bash
case "$1" in
start)
  echo "Starting SABnzbd."
  /opt/bin/python2.6 /opt/share/SABnzbd/SABnzbd.py -f /opt/share/SABnzbd/sabnzbd.ini -d
stop)
  echo "Shutting down SABnzbd."
  wget -q --delete-after "http://localhost:8080/sabnzbd/api?mode=shutdown&ma_username=xxxx&ma_password=xxxx&apikey=xxxx"
;;
*)
  echo "Usage: $0 {start|stop}"
  exit 1
esac
exit 0


Here are my file permissions:

Code: Select all
# ls -l
-rwxr-xr-x    1 root     root          401 Dec 11 19:48 S89SABnzbd



This is what it says when i do sh /etc/opt/bin/S89SABnzb start

Code: Select all
# sh /opt/etc/init.d/S89SABnzbd start
/opt/etc/init.d/S89SABnzbd: line 6: syntax error: unexpected ")" (expecting ";;")


I know my error is on line 6, but I don't know enough about bash scripting to fix it.
WDLXTV Live+ 1.05.04_.0.5.1.1 SVN on external USB
spazlon
WDTVer
 
Posts: 45
Joined: Sat Jan 29, 2011 11:39 am
Location: Mangaf, Kuwait

Re: [REQUEST - £10 waiting!] SABNZB+   

Postby recliq » Mon Dec 12, 2011 1:50 am

It tells you the error... you are missing a ;; before the stop) case:
Code: Select all
#!/opt/bin/bash
case "$1" in
  start)
    echo "Starting SABnzbd."
    /opt/bin/python2.6 /opt/share/SABnzbd/SABnzbd.py -f /opt/share/SABnzbd/sabnzbd.ini -d
    ;;
  stop)
    echo "Shutting down SABnzbd."
    wget -q --delete-after "http://localhost:8080/sabnzbd/api?mode=shutdown&ma_username=xxxx&ma_password=xxxx&apikey=xxxx"
    ;;
  *)
    echo "Usage: $0 {start|stop}"
    exit 1
    ;;
esac
exit 0
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

Re: [REQUEST - £10 waiting!] SABNZB+   

Postby spazlon » Mon Dec 12, 2011 2:57 pm

Argh! Thanks! I kept putting ;; after stop and after the ) which of course both failed.

The problem now is that when I run /opt/etc/ini.d/S89SABnzbd I get this error:

Code: Select all
# sh /opt/etc/init.d/S89SABnzbd start
Starting SABnzbd.
/opt/bin/python2.6: can't load library 'libc.so.0'


If I start it manually it works fine.

Also, anybody else having problems unraring files when they complete? Mine say _FAILED_ every time one finishes.
WDLXTV Live+ 1.05.04_.0.5.1.1 SVN on external USB
spazlon
WDTVer
 
Posts: 45
Joined: Sat Jan 29, 2011 11:39 am
Location: Mangaf, Kuwait

Re: [REQUEST - £10 waiting!] SABNZB+   

Postby recliq » Tue Dec 13, 2011 6:57 am

which opt.bin are you using?
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

Re: [REQUEST - £10 waiting!] SABNZB+   

Postby spazlon » Tue Dec 13, 2011 10:05 pm

recliq wrote:which opt.bin are you using?


Ok, don't yell at me. I did'nt read the whole forum. I was going off the the instructions in the wiki.

So now I have SABnzbd working and I updated the wiki with step-by-step instructions that ACTUALLY work.

http://wiki.wdlxtv.com/Setup_sabnzbd

Next week I will add instructions on how to get Sickbeard and Couch Potato working.
WDLXTV Live+ 1.05.04_.0.5.1.1 SVN on external USB
spazlon
WDTVer
 
Posts: 45
Joined: Sat Jan 29, 2011 11:39 am
Location: Mangaf, Kuwait

Re: [REQUEST - £10 waiting!] SABNZB+   

Postby recliq » Wed Dec 14, 2011 2:18 am

It sounds different if I start to yell ;)
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

Re: [REQUEST - £10 waiting!] SABNZB+   

Postby kroetkroet » Sat Dec 17, 2011 2:45 am

... and I'm still wondering who got the £10 :lol: :lol: :lol:
WDLXTV-fan! - In case you need further assistance: read our WIKI, search our Forum and most of all: donate 'something' to b-rad for his great efforts!!!
User avatar
kroetkroet
Beta Tester
 
Posts: 1008
Joined: Mon Apr 05, 2010 11:53 pm

Re: [REQUEST - £10 waiting!] SABNZB+   

Postby spazlon » Sat Dec 17, 2011 12:19 pm

It needs to go to ch1ptune. I just took all of his information and organized it on the wiki.

Also, SABnzbd, SickBeard, and Couch Potato take a LOT of RAM. b-rad gave me a kernel that has swap enabled so I created a 512MB (possibly overkill) swap file on the HDD and now everything runs pretty smooth. It still has some lag and takes a while to load the pages, but at least now the OSD and Netflix are smooth.

I will update the wiki with how to add a swap file.

b-rad, are there any warnings or anything you want me to post about the kernel you gave me? Anything that is know to not work or issues people should avoid? I will add your comments/warnings to the swap section on the wiki.
WDLXTV Live+ 1.05.04_.0.5.1.1 SVN on external USB
spazlon
WDTVer
 
Posts: 45
Joined: Sat Jan 29, 2011 11:39 am
Location: Mangaf, Kuwait

Re: [REQUEST - £10 waiting!] SABNZB+   

Postby s0laris » Sat May 05, 2012 5:03 am

Just got this up and running :) Cheers for the help everyone

I have on minor issue, I have all my media on a nas box and when a file is saved to the share it doesn't appear when I browse to it in Windows Explorer unless I type the full path.

I've mounted my nas using:
mkdir /tmp/mnt/NAS
mount -t cifs -o username=user,password=pass //<ip>/share /tmp/mnt/NAS

Should I be using xmount instead or does it sound more like the chmod settings in SABnzbd?
s0laris
n00b
 
Posts: 5
Joined: Fri May 04, 2012 1:15 pm

PreviousNext

Return to Application Questions

Who is online

Users browsing this forum: No registered users and 1 guest