Sign up here and you can log into the forum!

[SOLVED] Already broke my head - why plugin not downloading?

Feature requests / enhancements discussion regarding the web interface

[SOLVED] Already broke my head - why plugin not downloading?   

Postby DJArty » Mon Mar 31, 2014 11:43 am

Already broke my head :| - why plugin not downloading?
About exmefs and newexmefs..
On 1.05.04-0.5.1.x firmware you can select it in Addons Manager, press Save - looks like good messages like added, but really box stay unselected and plugin really dont added to UMSP and /tmp/umsp-plugins

Only handmade
Code: Select all
sudo umsp-plugman-web download exmefs
can help but only until you reboot..
Looking to addonsmanager index.php looks like all added plugin go via "umsp-plugman-web add ..." command, but all other plugins appear in umsp..
Few days before my iptvsmp plugins with same architecture was added perfectly, but this two look like have antimagic words in name :| or may be bad description in info or wec - but I dont see nothing criminal.
On 1.02.21-0.4.7.3 all normal, on 1.05 and Palace - not. May be svn vs wget problem?

May be possible to turn on some debugging mode for Webend to find-out what happen?
Last edited by DJArty on Sat Apr 05, 2014 12:24 pm, edited 2 times in total.
WD TV Live (1.02.21-WDLXTV-0.4.7.3);
Please Donate PayPal to email: djartyua ( a t ) gmail (d o t) com
WebMoney: WMZ114867333413; WMU219453404899; WMR161810775332
User avatar
DJArty
Developer
 
Posts: 540
Joined: Wed Jul 21, 2010 2:30 am
Location: Ukraine

Re: Already broke my head - why plugin not downloading?   

Postby recliq » Tue Apr 01, 2014 3:16 am

I haven't had a look at the plugins yet but here's what you can try meanwhile...

This command should list all plugins you enabled:
Code: Select all
umsp-plugman-web list


Try adding the plugin by hand:
Code: Select all
umsp-plugman-web add newexmefs


Finally you can try to add the plugin manually to /conf/umsp-plugins.
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

Re: Already broke my head - why plugin not downloading?   

Postby DJArty » Tue Apr 01, 2014 5:32 am

I know how to add manually, I'm interesting why ist not work for many other peoples..
Now parse umsp-plugman-web ...
First looks like umsp-plugman-web info/add/del combination by index.php don't give enough time for normal process... (and one command cover other else and drop it).
If make add/gen combination by hand - all good.
WD TV Live (1.02.21-WDLXTV-0.4.7.3);
Please Donate PayPal to email: djartyua ( a t ) gmail (d o t) com
WebMoney: WMZ114867333413; WMU219453404899; WMR161810775332
User avatar
DJArty
Developer
 
Posts: 540
Joined: Wed Jul 21, 2010 2:30 am
Location: Ukraine

Re: Already broke my head - why plugin not downloading?   

Postby KAD » Tue Apr 01, 2014 7:57 am

for smp I had problem downloading plugins at boot time

I had to create separate init.d/ script to start download

it's pretty simple, check if online -> if not online sleep -> if online start download -> exit after 5 attempts

but if you get some plugins downloading at boot, and others don't, the problem is probably different
If you like my work please consider a Donation. Donate
Please read the appropriate documentation before posting questions! READ ME FAQ WIKI
PM's are for private matters. Post support questions to the appropriate forum, or they will be ignored.
User avatar
KAD
Global Moderator
 
Posts: 5103
Joined: Mon Apr 12, 2010 4:59 pm
Location: Seattle, WA USA

Re: Already broke my head - why plugin not downloading?   

Postby recliq » Tue Apr 01, 2014 9:57 am

I don't think I got the exact problem yet...
is the problem that when adding your plugin from webend it doesn't end up in /conf/umsp-plugins ?

I spotted one tiny possible problem in the umsp-plugman-web script, but hence it works from console it shouldn't be the problem here.
Anyways I saw that umsp-plugman-web just uses one "config_tool -s" (just change config_tool -s to config_tool -s && config_tools -s) to save /conf, it should be done twice on newer firmwares to be absolutely sure both /conf NAND partitions are updated (yes there are two which should backup each other).

Anyways for debugging umsp-plugman-web should log all actions to /tmp/messages, have a look at the logger statements in the script and check the logfile for (missing) log entries...
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

Re: Already broke my head - why plugin not downloading?   

Postby DJArty » Tue Apr 01, 2014 10:32 am

Yes I look into messages and edit umsp-plugman-web for more logger mess.
Now I see newexmefs appear into /conf/umsp-plugins but disappear before install.php end make job on WDLXTV Addons Manager page. So when ending umsp-plugman-web gen start - no newexmefs - do nothing.
WD TV Live (1.02.21-WDLXTV-0.4.7.3);
Please Donate PayPal to email: djartyua ( a t ) gmail (d o t) com
WebMoney: WMZ114867333413; WMU219453404899; WMR161810775332
User avatar
DJArty
Developer
 
Posts: 540
Joined: Wed Jul 21, 2010 2:30 am
Location: Ukraine

Re: Already broke my head - why plugin not downloading?   

Postby DJArty » Thu Apr 03, 2014 4:13 pm

Ok, finally find-out.
This is "bad gay"
Code: Select all
sed -i "/$2/d" /conf/umsp-plugins
into del section of /usr/bin/umsp-plugman-web

so "efmefs" don't installed because umsp-plugman-web later make del for "fs" and sed - delete "exmefs" from /conf/umsp-plugins
so "newefmefs" don't installed because umsp-plugman-web later make del for "exmefs" and sed - delete "newexmefs" /conf/umsp-plugins
;)

Who is architector? Think need to correct sed for 100% сompliance but not only entry.
WD TV Live (1.02.21-WDLXTV-0.4.7.3);
Please Donate PayPal to email: djartyua ( a t ) gmail (d o t) com
WebMoney: WMZ114867333413; WMU219453404899; WMR161810775332
User avatar
DJArty
Developer
 
Posts: 540
Joined: Wed Jul 21, 2010 2:30 am
Location: Ukraine

Re: Already broke my head - why plugin not downloading?   

Postby mad_ady » Fri Apr 04, 2014 12:42 am

Nice find! I think the scripts were made either by RMerlin or by recliq. If you manage to rewrite the sed bits and provide a patch, I'm sure recliq can push it in the svn.
User avatar
mad_ady
Developer
 
Posts: 4522
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Already broke my head - why plugin not downloading?   

Postby recliq » Sat Apr 05, 2014 2:46 am

I think that would be me... :oops:

I guess this should be correct regex:
Code: Select all
sed -i "/^$2 /d" /conf/umsp-plugins

Can you test this DJArty? If it works I will commit this change to SVN asap...
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

Re: Already broke my head - why plugin not downloading?   

Postby DJArty » Sat Apr 05, 2014 11:18 am

Actually I remove old fs plugin (its not work more than year) from svn to Immediate solve the problem :)
But test you new sed theoretically, so yes - its working good, and please commit change to svn.
(KAD please use new version in Palace image)

Another question - why deleted plugins from svn anyway visibly on 1.05.04 and Palase via umsp-plugman-web repolist and can be downloaded via umsp-plugman-web download ....
Looks like its because used wget but not svn engine. And wget can see virtually deleted plugins in svn.. Think it must be sync - wget variant and svn.

Its another problem but it exists. Actually now its even opposite question "why plugin downloading" if I delete it from svn :)
WD TV Live (1.02.21-WDLXTV-0.4.7.3);
Please Donate PayPal to email: djartyua ( a t ) gmail (d o t) com
WebMoney: WMZ114867333413; WMU219453404899; WMR161810775332
User avatar
DJArty
Developer
 
Posts: 540
Joined: Wed Jul 21, 2010 2:30 am
Location: Ukraine

Next

Return to Webend Web Interface

Who is online

Users browsing this forum: No registered users and 2 guests