Sign up here and you can log into the forum!

Webend shows the wrong version of UMSP plugins updates

Feature requests / enhancements discussion regarding the web interface

Webend shows the wrong version of UMSP plugins updates   

Postby mutulaki » Tue Nov 12, 2013 2:07 am

Hi all,

There is an issue with Webend that shows the wrong version of the UMPS plugins updates.

Example:
filmsenzalimiti version in svn is 0.1.2
but the proposed update version is 0.1.1 in Webend update dongle.

Is this due to the fact that I have created an directory "italian" in svn in order to rplace in it all the italian plugins?
I have also created a french directory to regroup the french plugins.

Was it a good idea to make these 2 directories or should it be better to place all plugins in main english "plugin" directory?

Thanks for your help to solve this issue

M
mutulaki
DLX'er
 
Posts: 134
Joined: Thu Feb 02, 2012 1:38 am

Re: Webend shows the wrong version of UMSP plugins updates   

Postby mad_ady » Tue Nov 12, 2013 3:11 am

I'll tell recliq to check the server-side plugin that pushes the svn changes into the webend. It may have stopped working.
User avatar
mad_ady
Developer
 
Posts: 4522
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Webend shows the wrong version of UMSP plugins updates   

Postby recliq » Tue Nov 12, 2013 3:30 am

@mutulaki:

It seems you copied the plugin from the std.plugins dir (english plugins) to the italian dir and updated the later without removing the version in the std. dir.
You should make shure there's only one version of the plugin in the UMSP svn tree!

How to fix:
- remove the old dir/plugin in the std. plugin dir
- update the new plugin in italian dir, just push a svn update (eg. insert a blank line in the file or something like this)

This should resolve the problem, if it doesn't contact me again.

You need to do this for every plugin you "moved" (well in fact you cpied it, if you had really moved the files there wouldn't be any problem ;))
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

Re: Webend shows the wrong version of UMSP plugins updates   

Postby mutulaki » Tue Nov 12, 2013 5:21 am

Thanks mad_ady and recliq for the help,

I use TortoiseSVN for getting the svn updated. In fact I have created the "italian" and "french" directory in my local disk then I have made use of commit SVN to push the plugins to the svn. From the log (rev. 1006 to 1008) I see that the plugin dir were first added then removed from old location.

I have tried to delete the plugins from std.plugins dir but Webend keeps the version of the last updated plugin even if there is no more the plugin in std-plugin dir. It looks that even that I have deleted the plugin he is still in svn.

I have also checked that only one version is present in the svn tree

How could I correct this issue?

Thanks for all,

M
mutulaki
DLX'er
 
Posts: 134
Joined: Thu Feb 02, 2012 1:38 am

Re: Webend shows the wrong version of UMSP plugins updates   

Postby mad_ady » Tue Nov 12, 2013 7:01 am

Did you commit the changes after you deleted the plugin from svn?
User avatar
mad_ady
Developer
 
Posts: 4522
Joined: Fri Nov 05, 2010 9:08 am
Location: Bucharest, Romania

Re: Webend shows the wrong version of UMSP plugins updates   

Postby mutulaki » Tue Nov 12, 2013 7:04 am

yes, I used the function commit from TortoiseSVN
mutulaki
DLX'er
 
Posts: 134
Joined: Thu Feb 02, 2012 1:38 am

Re: Webend shows the wrong version of UMSP plugins updates   

Postby recliq » Tue Nov 12, 2013 8:44 am

I'll have a look when I find some time... can't promise yet when this will be, maybe you have to wait until weekend.

PS: I think I just saw the problem... the dir is correctly moved in SVN but the script that creates the repos still has it in place in it's temp dir, so I have to purge that temp dir and restart the repo process.
Will do that later today.
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany

Re: Webend shows the wrong version of UMSP plugins updates   

Postby recliq » Tue Nov 12, 2013 10:04 am

@mutulaki: Can you please verify if the problem is solved now? I rebuilt the UMSP repoand the version seems to be ok now:
filmsenzalimiti.xml

PS: If it's solved, please message me next time you move a plugin and I'll fix the repo or even patch the script to export current SVN version each time...
­WDLXTV Project Maintainer
-:] If you like my contributions feel free to donate for a beer or a new flash drive. ...and always remember: RTFM! (README, FAQ, WIKI) [:-
User avatar
recliq
WDLXTV Team
 
Posts: 5513
Joined: Thu Apr 15, 2010 8:09 am
Location: Kiel, Germany


Return to Webend Web Interface

Who is online

Users browsing this forum: No registered users and 1 guest